Huge bug: Pencil won't work properly, creates tons of extra lines. PLEASE HELP!

So, I just got Pencil2D, I’m super new to it.
But the moment I try to draw on the canvas, the line I create is accompanied by dozens of lines lagging slowly behind it in an array, and when I take my pen off, it STILL keeps going, making random lines and spazzing out.

Screen Shot 2019-06-25 at 8.18.51 PM
D:

It’s absolutely unusable as it right now and I really want to try it, any help???

background info:
-Using Wacom Tablet
-Have a Mac computer
-Mouse works fine: doesn’t have this problem
-I tried deleting and re-intstalling and updating Wacom driver

1 Like

@GlaucousLace Hi. Sorry to see you’re having issues and thank you for being so thorough with your report, it helps a lot.

It is quite odd indeed that this is happening since wacom tablets are about the most compatible input devices with Pencil2D, but there’s always a first time I suppose.

Anyway, can you please answer a few more questions to help developers review this faster?

  1. Which version of Pencil2D are you currently using? To find out go to HELP > ABOUT menu.
  2. You mentioned you’re using a mac but which version? To find out follow this guide https://support.apple.com/en-us/HT201260
  3. If possible can you let us know what is the wacom tablet product number (e.g PTH-450) which you can find on the back of the tablet itself or in the box
  4. And what is the driver version you downloaded? e.g 6.3.19-3

If you updated the drivers to the latest web version for your tablet, you’re certainly a step ahead, however I have to ask that you try to use other drawing software to report if it’s a global issue with the tablet or if it’s specific to Pencil2D under macOS environments?

You can try the following free drawing apps to see how the tablet behaves:

https://www.krita.org


If any of those work properly, then we’ll take a deeper look into this issue. For now i’ll tag one of the mac developers so they can guide you further once you’ve provided the info I mentioned, but just in case you require to work and you can’t wait for Pencil2D to get fixed while you’re being provided with customer support, please take a look at our curated list to find another animation software that can help you meanwhile:

https://pencil2d-software.tumblr.com/post/184584013311/alternative-desktop-animation-software-pencil2d

Hopefully this can be solved soon for you.

@scribblemaniac Hey sorry to bother you. I was wondering if you could take a look at this issue once the user has submitted the pending details I asked recently. It seems like a non-standard problem and it is mac related so I thought you’d be better equipped to review it, once we ascertain that it is a reproducible bug. Thanks in advance :slight_smile:

1 Like

Thank you for such quick help!

The version I have installed is ‘0.6.4’
My mac operating system is OS X El Capitan (10.11)
my Wacom tablet product number is PTH-651
and finally my driver is 6.3.35-2
(Another point of note is I had the previous driver version after I downloaded and installed Pencil2D when I discovered the issue. I checked for driver updates and installed the update hoping it’d solve the problem, but it still persists. my computer is also fully updated)

I’m an artist and draw quite often using clip studio paint and photoshop and flash, and I’ve never run into this bizarre an issue before, I just did a check just in case and it currently works perfectly fine on all my drawing software ^^

Also a couple maybe useful things I forgot to mention in my original post but might as well provide in case they prove useful!
-Tried the ol’ “turn computer off and back on again/restart” trick to no avail
-Tried turning mouse off whiles using tablet in case it was like sensing the mouse as well or something weird, but no luck
-Tried turning of pressure on Pencil2D and fiddled with sensitivity/pressure/touch pad settings on my wacom to try and fix or at least help or worsen problem in hopes of finding it’s source, but alas stayed just as crazy glitchy no matter what
-This glitchy weirdness applies to ALL tools, not just pencil. The only tools exhibiting normal behavior are non-drawing based tools like select and fill bucket etc. etc. Even smudge tool is doing the weird line spazziness

Again, thank you so so much for the kindness and help and so quick!! Hopefully it’ll be running smooth in no time.

Well you’ve done almost everything I would suggest already. There are a few things I can think of for you to do right now that might help. First off, make sure you are using the new legacy mac build. On the Pencil2D downloads page, under the Mac panel, make sure you’ve downloaded the 10.7-10.11 version rather than to 10.12 version. If you are already using that version, then you can try and use the 10.12+, it might still work for you. Second, if you could record a video of the behavior happening that would be really helpful to visualize how the extra lines are being drawn. I would recommend using either the builtin Quicktime Player or the free and open source licecap to capture the screen. Finally, if you can, please try downloading Krita which @JoseMoreno linked above and seeing if it has the same problem. Unlike clip studio paint, photoshop, or flash, it uses the same programming framework as us, so this would help to narrow down if it’s a problem with Pencil2D or this framework we use.

Sure thing! Where would you like me to send the video to for you? And I’ve got the right version all checked and set up. I’ve got Krita downloading so I’ll tell you the results of that when I get em.

@GlaucousLace You can upload the video on youtube.com or anonymously on streamable.com and paste a link here :slight_smile:

Here you go!

Pencil2D is a perfect program for casual animating and it’s free! It has all the basics of raster drawing and animating. It’s essentially a digital flip book. people do create magnificent things with it.

I’ve found my xp-pen deco pro drawing tablet is much easier to use, though a mouse isn’t impossible. The tablet I have can also feel sensitivity, which I don’t believe you can mimic with a cursor. One thing you can do just as well with a mouse is pixel art!

Hey, I was wondering if this has been solved at all, I have windows 10 using pencil 2d and all of my lines are doing that strange jagged thing? it doesn’t seem to be changed by speed or pressure at all. Only happens with my wacom cintiq, which has up to date drivers installed. It doesn’t happen if I use my mouse.

Recorded the line drawing to show what I mean here

@TragicPhoenix Hi. Thank you for taking the time to report this. Unfortunately we don’t know what happened with Wacom, but this is a problem introduced by their drivers at least 6 months ago or even before that, specifically on Windows 10 (though it also seems to happen on certain macOS versions).

In some reported cases users have been able to fix this by turning the Windows Ink option off completely as there seems to be a conflict with both Windows touch screen / Ink drivers and Wacom products, not only the Cintiq.

You can watch this video to see how to turn off windows ink for Cintiq screen tablets (it’s short, under 2 min)

Also try to make a separate application profile on your wacom driver window to turn off windows ink and also to force the drivers to recognize Pencil2D as an application with special needs.

Unfortunately my wacom intuos pro broke and I don’t have Windows 10 so I can’t help the devs test this, but we’ll be on the lookout for fixes for sure.

1 Like

@JoseMoreno Thanks for the fast reply :slightly_smiling_face: I already tried turning wondows ink off for pencil 2d in the wacom settings, it didn’t make a difference. The weird thing is that I can get the regular lines at random points with the cintiq?

All still seems to work fine on my intuos at least

@TragicPhoenix Does turning off the stabilizer in the brush options affect it at all?

Did this issue ever get resolved? I recently downloaded the pencil 2D, after watching some youtube clips on Pencil 2D ordered a Wacom tablet, which arrived today (jolly exciting!), to alas this very same issue. Mac 10.11.6, Pencil2D v0.6.4, Wacom Intuos CTH-490. Any additional information to the above, very helpful thread, would be gratefully received. Thank you

Have you downloaded and installed the latest drivers for your tablet (https://www.wacom.com/en-us/support/product-support/drivers)? It might sort of work without them on mac, but you will want to install the drivers to have the best compatibility.

Thanks for your response yes, I have downloaded it fresh today, the latest for the Mac OS level, Driver 6.3.37-3, the Wacom the Wacom desktop center says this is up to date. It is precisely the same issue GlaucousLace had in July 19.

@GlaucousLace, did you ever get this fixed? I am experiencing the same issue now. Thank you.

@PShooter Hi. I’m afraid, we have not been able to find a way to reproduce this in the few years that this started to happen. The only pattern we’ve found is that it’s linked to CTH and some Cintiq wacom tablet models, as well as MacOS 10.11 and under which unfortunately for Apple themselves are considered legacy versions by now.

This legacy status also affects the foundation technology Pencil2D uses for handling input, graphics and more (Qt Framework) because they are forced to deprecate macOS versions at the same rate Apples deprecates them (since they are the ones that supply them with the bridge tech to develop for macOS in the first place)

So, what i’m trying to say is that, we will surely look into it, but we’ve had this issue ever since Apple started deprecating “snow leopard” (10.6) and your version “el capitan” (10.11) has been no exception to this problem.

At this point, If @scribblemaniac or any other developer is available to look into it, I’d like to ask if you’re willing to test future development builds aimed at legacy macOS versions with their help to see if it’s possible to fix this since none of us have an older macOS version to test.

Considering that newer versions of Qt framework bring fixes and changes to the input handling, we are in a bit of a tough spot since at some point we too will be forced to deprecate most versions of macOS support, or at least that’s my impression.

Of course I’m saying all this by myself right now, but let’s wait for them to chime in to let us know if this is something that is possible for them to look into or if it’s simply a lost battle.

In case of the latter i’ll gladly recommend some alternative programs so you can at least continue animating while having minimal issues.

Thanks @JoseMoreno, understood, it is a shame because Pencil2D is soooooo good! and easy to use, everything is just trying to temp me to get a new mac! But my in house approver won’t sign it off :slight_smile: Trying to get to grips with OpenToonz, where the pen works but the UI is a lot more involved.

Imprint