Lines won't draw correctly with Wacom Bamboo tablet


I’m using a Wacom Bamboo Pen and Touch tablet on a Mac OS X 11 10.11.6 (El Capitan). I just tried out Pencil 2D (V0.6.4) for the first time today, and unfortunately, get this when I try to draw curved lines with my tablet:

I browsed a few other bug report posts with similar issues and downloaded the latest available drivers for my tablet, changed the settings from pen to mouse mode and from hover click to click and tap, and restarted between these steps, but unfortunately the problem persists.

The problem is also limited to Pencil 2D, since any lines I drew via my tablet showed up normally in other drawing software. Using any Pencil 2D drawing tool (pencil, pen, brush) also produces the same effect.

Thank you very much for your help and taking the time to look into this issue.

@ekkstatic Hi. Since you’re using “El Capitan” you must be using the legacy version of Pencil2D for macOSX. Unfortunately this problem has been reported plenty with Wacom Bamboo and CTL tablets as seen here Huge bug: Pencil won't work properly, creates tons of extra lines. PLEASE HELP!

The problem is that most Wacom tablets work fine (they don’t exhibit this issue), but it’s those two models specifically along with El Capitan (10.11) or Windows 7/10 that show this problem.

While it’s not entirely the hardware’s fault despite these tablets being refurbished (which is why they are cheaper than the other verisons), having an older macOSX version will limit your ability to get the latest updates and fixes available for your tablet which in the case of the Pen & Touch version their last update was from 2015 :pensive:

For now it doesn’t really seem like we can solve this directly at the moment, but can you try using the latest version of the software and see if this improves or worsens your experience? You can download it from the official website at

Just don’t delete the version you’re currently using so you can have a base for comparing both versions (and you can have multiple Pencil2D version in your computer, since they are not installed but are rather portable)

The new version has a small issue with the layout so you probably need to follow the following advice (video included) to stack panels in order to avoid their contents getting weirdly displayed (devs are already looking for a fix) here’s a video with a simple workaround to avoid the panels crushing into each other:

Hey, thanks for replying so quickly!

I completely understand that some of these things just have to do with my using older software. Unfortunately, because of this I get a “you have OS X 10.11.6. The application requires OS X 10.13 or later” error message whether I try to install the latest stable version or the latest nightly build.

I haven’t had good luck with updating my computer in the past (between speed and needing to preserve some older programs that aren’t always compatible with the latest OS X versions) but I will do some research and see if there’s a version that’s a good compromise.

Thanks again for all of your help, and hope to get back to you soon!

@ekkstatic Ah my apologies. It was an oversight on my behalf. We haven’t announced this new version because there are still pending release tasks and some of the maintainers have not udpated these versions. It seems the legacy version link is the same from the previous version on the this link:


I don’t want to give the impression that we’re forcing you to update, because even if you did there’s not guarantee of the software working properly on newer systems.

If you want please try using another software meanwhile we manage to get the legacy download for the most recent version so you can test it out. I personally abhor the constant need to push users to update their computer systems at least in the case of Apple’s and Microsoft’s perspective since they tend to drop a lot of backwards compatibility and we also lose the ability to support those systems in the long run.

Consider trying out Wick Editor which is also free and since it’s based on web technologies and vector graphics it should work just fine with any browser (though you can download a desktop version but i’m unaware of how to obtain it at the moment)

I’m honestly sorry I can’t do much more right now to help you out :pensive:

No need to apologize at all, you have honestly gone amazingly above and beyond here and I cannot thank you enough!

As for Apple/Microsoft’s general move towards forced obsolescence - agreed, completely.

I’ll try out Wick Editor for now, and I look forward to coming back to Pencil 2D in the future and seeing whatever else is in future versions. Hopefully when the time comes I can contribute whatever I can to the project too. :smile:

@ekkstatic Yeah, it’s too bad to be honest. I had to part with my older Windows OS which was working perfect. And now Windows 10 while not that bad, it does have a lot of cringe inducing idiosyncrasies.

As for Pencil2D, it is unfortunate, this new version the devs added sound scrubbing, movie import, a very basic pegbar alignment feature, another feature to import layers from other Pencil2D files and many more things as a foundation for future improvements.

Everyone is welcome to contribute, so you’ll certainly be more than welcome :smiley:

@ekkstatic Pencil2D v0.6.5 for older mac versions is ready, but has not been updated yet because we have not been able to find someone to test it to make sure it actually works on these systems. Here is a link to it: . If you have a chance, could you please test this and let us know if:

  1. It runs on your computer
  2. Audio playback works
  3. Video export works

This would be a huge help to us. Unfortunately, this new version will likely not fix your tablet issue. I have the same tablet and while it works fine with more modern mac versions, I get the same result with the so called “legacy mac build”. I’ll look into it now that I can reproduce the issue, but it is likely the result of the older versions of the tools that we have to use to build Pencill2D in a way that supports older macOS versions.

1 Like

No problem, I’d be happy to help you test it out :smile:

Unfortunately, I just get a “You can’t open the application “Pencil2D” because it may be damaged or incomplete” error message and can’t install it.

Let me know if there’s anything else I can help with!

@ekkstatic Sorry about that, I overlooked an issue with the app. Please try this version:

@ekkstatic Just doing a follow up in case you did not get the notification for my previous message. We are still looking for someone to test this version. If you are willing to test this, it would be a great help to us.

I am so sorry, that is entirely my fault and I apologize. This was a bad case of “I thought I replied to the thing but did not in fact hit reply.” I’m still happy to help out however possible.

Anyways, unfortunately that one didn’t open either. Here’s the message that I got: pencil2Dproblem

Are you 100% positive that was the newer version? If so, does the application icon have some indicator on it that it is bad (a cross through it or something similar)? Can you please take a screenshot of what comes up when you right click on the .app and select “Get Info”?

This is what I got:

I deleted and re-downloaded the most recent zip file from the link (and also deleted any older Pencil2D files) to be sure. After I click on and open the zip file, it will redirect me to a new folder with the .app file.

Hence, leading to the aforementioned “Pencil 2D cannot be opened because of a problem” message (let me know if you want me to submit the error report anywhere in particular - I saved this to a separate .txt document just in case it’s needed.)

This topic was automatically closed 42 days after the last reply. New replies are no longer allowed.