Audio won't play no matter what I do

I imported a .WAV audio file and no matter what I do it won’t play, I’ve tried restarting the program and still nothing, I don’t want to have to reinstall but it might be my only option. ;-;
it’s not my computer because all other audio is working and i don’t specifically have pencil muted, I’ve checked to make sure,

Wtf is the problem?

Saammee!!

Though I was thinking I’m just an idiot cause Iv’e never really used programs like this for the computer.

 

I used it before but that was forever ago xc

try this http://www.pencil2d.org/forums/topic/a-few-problems-and-a-few-solutions/

@kitty_hatt_1 Hey Kitty. Well the thing is, right now Pencil is incapable of importing sound as it is, unless you tinker with the program itself. The link that Sfepa suggested, might work depending on your system. I’ve tried it and it works on mine (Windows 7). Qt is a software development environment, so it’s safe to get the outlined software packages.

Now since it’s annoying to download the whole 260 mb package just for a few plugins I managed to trim it down to the essentials (a.k.a the needed plugins)

Here’s a link to a zip file containing all the files.

https://dl.dropboxusercontent.com/u/59671876/4.8.5-VC2010.zip

  1. Go to your C:\ drive and create a folder named “Qt” (without the quotes)
  2. Inside the Qt folder, extract the downloaded zip file
  3. Afterwards it should look something like this C:\Qt\4.8.5-VC2010

After doing the previous steps, launch pencil again and do the following:

  1. Create a new “sound layer”
  2. With the layer selected import a .wav sound file for testing purposes.
  3. On your bitmap layer create a new keyframe on a faraway frame. Let’s say if your sound has a duration of 2 seconds, you have to make your new keyframe on frame 48, while using 24fps play rate.
  4. Click the play button, and see if it works!

Hope this helps, cheers!

this happened to me too aah

this didnt work for me honestly…

@sillysmartandsuper It’s a difficult solution even for an intermediate pc user, we have to propose how to fix importing audio for the next stable version, I was writing you so you could find my solution in here but I guess you already did. Please let us know what are your computer specs like OS and stuff, but for now it’s hard to do anything more with our limited development team, thank you for your patience and hope you can see a new improved Pencil2D version soon to play with!

I tried this and it didn’t work with .WAV files but I found it works perfectly fine with .MP3 files :slight_smile:

Dude, follow Jose Moreno’s Instructions and use .MP3 files instead of .WAV, I tested it out and it worked perfectly :slight_smile:

"Here’s a link to a zip file containing all the files.

https://dl.dropboxusercontent.com/u/59671876/4.8.5-VC2010.zip

  1. Go to your C:\ drive and create a folder named “Qt” (without the quotes)
  2. Inside the Qt folder, extract the downloaded zip file
  3. Afterwards it should look something like this C:\Qt\4.8.5-VC2010

After doing the previous steps, launch pencil again and do the following:

  1. Create a new “sound layer”
  2. With the layer selected import a .wav sound file for testing purposes.
  3. On your bitmap layer create a new keyframe on a faraway frame. Let’s say if your sound has a duration of 2 seconds, you have to make your new keyframe on frame 48, while using 24fps play rate.
  4. Click the play button, and see if it works!"

Then if you have a sound editing program, open the audio you want to use and at the end of the audio put a good chunk of silence, otherwise Pencil 2D won’t play the rest of the audio. In my animation(one I’m working on) a character’s dialogue goes for 4 seconds but it cut off the last part of it, so I used wavepad and put a huge gap of silence at the end(maybe a few more seconds I think) then it played all of the audio successfully :slight_smile:

HOLY F THANK YOU SO MUCHHHH it studders a little wich I understand your team is working hard but thank you thank you thank you all my work will finally be cherished

@mr-cowcoww Hi, this is a really old solution for the old version. In the enw Nightly Builds audio is working out of the box and it won’t crash your software. So please update and use the latest Nightly Build appropriate for your operating system found here:

https://drive.google.com/drive/folders/0BxdcdOiOmg-CcWhLazdKR1oydHM#list

The developers are working hard and they implemented audio scrubbing and other fixes for audio, but we have to wait for a new nightly build to be released to make this available.

I made a tutorial to install a nightly build on windows 7+, hope it is useful for you as well:

Hi,

I’m having problems with audio in both 0.6.5 and the current nightly build. It will play back correctly on export, but I don’t hear it if I scrub or if I play back in the app. As I’m trying to work on animation to a soundtrack, it’s pretty hard to do.

I have tried my usual WAVs, loaded into audacity and converted to 16-bit signed, etc., all to no avail. And if I try an MP3 it crashed 0.6.5.

Anyone have any ideas? Yes, my speakers are turned up, yes, I can hear the sound when I export, and yes, other apps can play it just fine (including if I import the finished clip into Pinnacle).

Thanks for any suggestions?

@larrydeluca Hi Larry, welcome to the forum. This is actually a first one. Hmm can you let us know what operating system you’re using right now? also are you using the 64 bits or 32bits version of Pencil2D? this can help the developers narrow down the issue.

As for the sound if it’s possible can you send us a ZIP file with:

  1. The PCLX project file where you imported the sound file (but doesn’t work)
  2. The individual WAV file that’s not working for import.

You can upload these to a google drive account you use, or to wetransfer.com and use the anonymous link function (files are deleted within a week) as described here https://wetransfer.zendesk.com/hc/en-us/articles/115004254743-How-do-I-send-a-link-transfer-

Additionally let me ask which sound option are you using? There are currently two options, one is “Sound” and the other one is “Movie Audio” if you’re using Movie audio this will only work with actual movie files, so for WAV you have to use the “Sound” option as in File > Import > Sound

As for the sound scrubbing not working, did you turn on the feature on the timeline? the volume speaker icon with an “S”?

In fact when you import the sound can you see if the sound itself is actually imported? like does the keyframe becomes bigger or is it kept as a single frame?

The other thing I can think of, if you’re using Windows 10, is that your OS blocked the files from being properly extracted, in that case please thoroughly follow this guide to minimize the permissions issues with Windows 10 (this is a problem that is unfortunately above us, so we can only provide workarounds) [Guide] How to Train Your Pencil2D (Windows)

Once you’ve sent us the files and reviewed these options, we’ll look into the issue in detail and try to come up with more troubleshooting steps.

I apologize. I’m running Windows 10 Home Version 2004 instaled 8/6/2020, OS build 19041.508, Experience Windows Feature Experience Pack 120.2212.31.0.

The hardware is an HP all-in-one With an Intel i7-7700T CPU @ 2.90 GHz. I have 12 GB of memory, and it’s 64-bit.

I’ve been using the “Sound” option (as Movie audio doesn’t list any eligible files). I did turn on the scrubbing feature in the timeline both for audio and for scrubbing.

That’s the interesting thing - I don’t see that the sound is imported, other than a single frame, but when I export a movie it plays for the duration of the clip (once exported). I did add a keyframe further out on the timeline, and that allowed sound to play further out.

I’ll send the files as requested. I do have google drive. HOw do I send them to you once they’re in google drive?

Larry

To send files from google drive, you just have to share them. You should be able to right click on the item and select “Get link”, then paste that link here. Usually that’s enough, but you may also have to change the share settings for that file to “Anyone with a link can view”.

Some other things to try are:

  • Reopening the project after importing the sound file and saving.
  • Using the Add Frame button in the timeline on a sound layer rather than using Import > Sound. This is not supposed to make a difference, but due to some bugs in v0.6.5, they do differ slightly.
  • Make sure you are not trying to import the sound on an existing frame (delete it if you have to). There is some bugs related to this as well.

Sure, who do I send the invite to? I’ve also tried the Reopening and saving. I’ll try the “Add Frame” button. I’ve tried several times by deleting the track and re-importing the sound. Like I said, you can’t hear it during playback, but you CAN hear it in the exported movie.

One more weird thing: I’ve just been learning about Vector mode, and there’s something wrong with selections for me. When I use the select or move tools, it opens up a square in the far lower right away from where my objects are drawn and my canvas is. So if I select the tool and try to drag it drags a corner in the lower right of the screen, but not around the objects. Super, super weird. (This is on the 9/18 or 9/19 build - whichever was up last night). Could this be something like a screen resolution problem? I’ve tried new projects, and the bizarre behavior still exists.

Oh, and when I did it again I realized I had tried “Add frame” and that doesn’t work, either. But as I said it’s just playback within the program (and of course you never see it on the timeline).

Here’s the link: https://drive.google.com/drive/folders/1J-x9lBOB2__dD6HTWiAnss-6I7u78TJa?usp=sharing

The files are starting to upload, but I have crummy DSL, so it may be a while. Thanks!!

@larrydeluca Thanks for sharing, don’t worry about the upload speed :+1:

It is indeed weird that you cannot hear the sound through the editor, but you can on the exported movie :thinking: I have Windows 10 Pro v1909 and it is unfortunate that i’m not able to reproduce this problem right now. Hopefully with your files i’ll be able to assist the devs.

Aside from the present issues mentioned by Scribblemaniac, regarding the reason as to why sound is still not working in-editor. As a very specific check, could you take a look at the sound mixer on the taskbar notification area as well as your sound card or video card (if using HDMI) driver configuration settings to see if Pencil2D sound channels are possibly muted?

Regarding the vector layer, this feature is unfortunately broken right now; a work in progress, so we don’t recommend using it for the time being. It will be taken care of once the brush engine is replaced with a new implementation that’s under development.

Selections in general for both bitmap and vector, have an issue related to the compositional overlays which visually relocate their position on screen as you’ve described, if you turn them off (all of them) this behavior does not appear. This has been reported and will be fixed soon (I hope :crossed_fingers: )

Lastly, I’m afraid this sound issue might not be a quick fix since we have to investigate the problem in depth to rule out internal problems, and then try more experimental solutions in case the problem lies in either Windows, or your specific system

With that said if you’re in need for a way to continue your work meanwhile we figure this out, please take a look at our alternative animation software list to try out other applications that can complement or replace Pencil2D in terms of functionality :+1: I only mention this to hopefully help you finish the work you’re doing or in case you’re in need of a speedy solution :muscle:

Imprint