Wacom Tablet has no pressure sensitivity

The link you posted above seems inactive or disabled somehow.
I just got Pencil 2d and I’m experiencing the same issue with my drawing tablet (wacom).
I’ve never had this issue when using photoshop or any other drawing software so it seems like it’s just the pencil 2D app that has the problem. Any progress on the support you or any volunteers have done?

@PandaManXpress Hi. The thread you replied to was an issue with an older version of Pencil2D (0.6.2) specifically for windows surface hardware, which has a different problem than any other graphics display tablets.

With these kind of issues though, It’s better to open a new thread just to avoid mixing unrelated problems. That said, Wacom is probably the most supported graphics tablet that Pencil2D and any other graphics app that uses the Qt Framework (the technology used to build these programs) has, so it’s pretty rare to have these problems.

I personally never experienced issues with my Wacom Intuos Pro 5, except when the proverbial Wacom drivers decide to stop working, to which I had to reset them by using the Windows services dialog and restarting the Wacom Professional Service. In these cases just unplugging the tablet won’t work, and restarting the service helps serve a similar process to rebooting. If you’re not on Windows though I think there is a way to do it on macOS, but you’ll have to browse for that.

I’ve had the drivers disconnected for example, but Photoshop keeps working for a bit during the session, so it is possible that in your case it’s still the driver problem I mentioned. I mean, it always happens regardless, and Wacom has never fixed it particularly on Windows (but also happens on macOS). also due to the latest permissions craze with both Windows10 and macOS, wacom drivers functionality have been degrading significantly.

While your issue might not be necessarily a Pencil2D issue we’ll treat it like so. I hope you don’t find this patronizing, as the following are honestly the only recommendations I can come up with with such a broad issue:

  1. Download the latest drivers from the web portal for your specific OS and Hardware (e.g Intuos, Cintiq, etc) Hopefully you installed those drivers as an administrator.
  2. On your Wacom preferences, set an application preset to control only Pencil2D and try testing different settings such as:
    a. Changing the pen mode to mouse mode back and forth
    b. Changing the Hover Click setting to Click & Tap and back (for more info please review this link https://101.wacom.com/UserHelp/en/AdvancedOptions.htm)
  3. If on Windows, turn OFF the Windows Ink checkbox.
  4. If on Windows 10, look to disable permanently the Windows Ink drivers as well.
  5. If on Windows 10, please follow this guide to set Pencil2D in a way that can help prevent permissions problems (and writing problems too when saving files): [Guide] How to Train Your Pencil2D (Windows)
  6. If on Windows 10, set Pencil2D compatibility to Windows 7 by going to the Pencil2d.exe properties > compatibility tab
  7. If on macOS, particularly Mojave or Catalina, Go into System Preferences>Security>Privacy>Accessibility, unlock the “lock” and add Pencil2D to the list of allowed apps.

Lastly, if possible please leave a reply with the following info so the devs can look into it by trying to get similar hardware to test the issue:

  • OS Version (e.g Windows 10, MacOS Mojave, etc)
  • Pencil2D version (Go to Help > About > Press Copy to Clipboard and Paste, works for both the OS and this)
  • Brand and Model number of your tablet (e.g Wacom, the model is behind the tablet, for example PTH-450)
  • Any observation or behavior that you noticed when the pressure went offline, this can help the devs find the issue and fix it faster. Anything will do, like if you opened another software or navigated in a certain way. Anything that comes to mind.

While the devs look into it, If nothing above works for you, by all means peruse this curated list of alternative animation software and try a different application that will help you create your work comfortably and without issues http://pencil2d-software.tumblr.com/post/145767476221/when-youve-worked-all-day-on-your-animation

We are not interested in making people “stick” to the app if it doesn’t work for them (we know this can be frustrating), so we’d rather guide them to other programs that can help them continue your their comfortably instead, so thank you for trying Pencil2D either way :slightly_smiling_face:

Note: I’m going to separate your question into a separate thread, you shouldn’t have any issues finding it in case you had this thread bookmarked or similar.

This topic was automatically closed 42 days after the last reply. New replies are no longer allowed.

Imprint