Version 0.6.5 problems

  1. I tried version 0.6.5 in Ubuntu 20.04 and it opens at a window size that goes off my screen. It can’t resize it and it doesn’t even have a maximize button.

  2. On Windows I don’t have the window size errors but the drawing tool keeps getting changed every time I right click to drag the screen. It was a minor annoyance but it doesn’t happen in 0.6.4.

I have just gone back to 0.6.4 for the time being as it is pretty stable and works great on Windows and Linux.

@n00b Thanks for the report. We’ll look into it.

I can’t currently comment on point #1 that much since i’m using Windows 10, so for now please let us know

  1. Did you install Pencil2D via the AppImage download? or did you use the Flatpak version?
  2. If you tried one of the methods mentioned above (e.g AppImage download), please try the other one and see if it works for you better.

For point #2 allow me to ask:

  1. Please go to the topbar menu > Help > About > Press the “copy to clipboard” button and paste your system information when answering this point. Also please state which graphics tablet you are using, if any, along brand and model (e.g Wacom Intuos Pro 5, PTH-451)

  2. To drag the screen are you using a drawing tool and invoking the hand tool through the shortcuts? (i.e spacebar) or are you using the actual hand tool (H key) to drag the screen?

  3. Assuming you have a graphics or screen tablet. Are you using the stylus left click / point or are you using the extra buttons from your stylus?

  4. If you rather use a mouse, and even if you don’t please try it out as well, are you middle clicking or right clicking to drag the view?

  5. When the tool gets changed, which tool is getting selected (e.g eyedropper tool, brush tool, etc). Does it always change to the same tool or a different tool? Is it your previously used tool or a random one?

  6. Does it happen only when you drag? or are you pressing any specific key shortcut for this to happen?

If it’s ok with you, we might ask you additional questions in the near future in order to better understand what is happening and enable us to have a better chance to find the root cause and fix the issue.

On point #2, I fixed the issue. The top button on the pen in the settings was set to (pen/eraser). That is the default setting for XP Pen Artist 15.6. I just removed that and now it works fine on windows.

On point #1: I have tried the appimage and the flatpak and they both have the same issue. Pencil2d’s window is larger than my screen and there is no maximize button. I don’t have a graphics tablet plugged into my computer so its just my laptop screen. I should also note that this problem does not happen with 0.6.4.

@n00b Thanks for the response. Going back to linux for a moment, by any chance can you share a screenshot of how the interface looks?

Additionally:

  1. Are you using a hi-dpi screen?
  2. What is you current screen resolution under Ubuntu? Can you take a screenshot of the display settings too?
  3. In the Display Settings there should also be a scaling setting as seen in this article https://www.omgubuntu.co.uk/2020/04/ubuntu-20-04-fractional-scaling-support-setting is it set to 100%? Is fractional scaling turned ON or OFF?

With this I want to see if there could be a hint that could help us find the cause of the problem on your system or if it’s related to the DPI of the desktop screen vs the display output (i.e the actual monitor)

Here is a screenshot of what 0.6.5 looks like when it opens:

And here is a screenshot of 0.6.4 on the same computer:

Here is a screenshot of my display settings:

I have a standard DPI screen. My resolution is 1600x900. And fractional scaling is turned off.

The computer is a toshiba thinkpad T430 running Ubuntu 20.04.

1 Like

@n00b Thanks! I’m going to ask one of the developers that works with Linux to review this issue and specifically test this in Ubuntu 20.04 to see if it’s possible to reproduce. Thanks again for taking the time to comment and answer my questions :+1:

Your first issue is a form of a common issue that affects all platforms. The panels on the left take up more vertical space than your screen has. See this post for a workaround: Timeline keeps disappearing whenever I press ALT

@scribblemaniac But what about the missing maximize icon… I’m not sure that is a by-product of the same issue :thinking:

That is unusual, but it could be that it’s not being shown because it cannot maximize within the screen dimensions. Well let’s see if this solves the issue first.

@scribblemaniac That workaround fixed it. The maximize button appeared once I removed the onion skin window. I was able to add the onion skin window back as a tab next to the display window. Thanks.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.

Imprint