Unable to import audio

Hi,

When I select the sound file, just 1 frame gets added to the sound layer on the timeline and then absolutely no sound plays!!

I’ve gone through your discussion forum and tried the suggestions therein, but I’ve still had no success.

I have the Windows 7 OS 32-bit, and Pencil2D 0.6.6.

The actions I perform are these:

I go to File>Import>Sound. Pencil2d prompts me to add a sound layer. I add it. Pencil2d opens a folder and I navigate to the sound file I want to import. I’ve tried both WAV and mp3 file formats, and also “processed” the file through Audacity as suggested in your forum. No luck!

As mentioned earlier, only 1 frame gets added and there is no sound. The audio buttons are on.

Please help.

@RobinAnto Hi. Unfortunately it pains me to say that the problem here might be with Windows 7 as well as the 32 bit version compatibility since nowadays this is considered legacy technology.

Honestly speaking Windows 7 is no longer being supported by Microsoft since a few years ago, and even 32 bit architecture computers are being phased out as well.

I’ll gladly ask the developers how to proceed, but this is potentially a problem we might not be able to solve anymore since the underlying technology we use (Qt Framework) is also dropping support for legacy technologies and it is hard for us to keep the software updated to benefit from improvements on their end, while keeping support for previously used platforms.

For now this is mostly a warning, this doesn’t mean we have stopped supporting Windows 7 or even Windows XP nor the 32 bit versions, however consider that in the future it may be increasingly difficult for us to do so.

With that said, please share with us:

  1. The sound file you were trying to load (don’t try to attach it, upload it to a free cloud storage service and share the link)
  2. The Pencil2D file where you tried to load the audio.
  3. Even though you provided relevant info from your system, please go to the topbar menu > Help > About > and press the Copy to clipboard button to automatically copy all the information on that window then paste it verbatim in your next reply. Don’t leave out anything otherwise it won’t help us determine the cause.
  4. Meanwhile we get the samples to test, please also follow the sound import guide and try the different ways to import sound described there, even if they don’t work let us know if you notice something unusual when trying each one [Guide] How to import sound into Pencil2D

Thanks for the swift reply, Jose :slightly_smiling_face:

It’s disheartening that my system’s age may be causing the problem. But I understand that technology waits for no one, and we have to keep up with it.

  1. Dropbox - VNNP aud.wav - Simplify your life

  2. Dropbox - OliveColour.pclx - Simplify your life

  3. Version: 0.6.6

commit: ac415788dfb21f66e1cbcc1ad60443225a2d0e37 date: 2021-02-17_13:03:37

Operating System: Windows 7 SP 1 (6.1) CPU Architecture: i386 Qt Version: 5.12.10

Hope you are able to find a solution to this issue. Looking forward to hearing from you.

From what I read on the forum, I realise that you are a very helpful person, Jose. Keep up the good work.

Thanks.

@RobinAnto Thank you for sharing your files so swiftly! I’ll alert the devs so they and myself can test the files as well and we can provide you with an alternative solution as soon as we find one.

It’s disheartening that my system’s age may be causing the problem. But I understand that technology waits for no one, and we have to keep up with it.

It is an unfortunate reality without a doubt, however we will try our best to provide this tool to people that still have not been able to upgrade due to unique situations for as long as we’re able.

Either way thank you for your patience, we’ll update this thread once we find clues and a potential solution for your issue.

Meanwhile if it is helpful, you could also try using a simple animation software through a web browser. While it may happen that you could require newer versions of your browser due to the tech involved it is my understanding that it should be easier to run them on legacy systems.

I personally recommend WickEditor https://www.wickeditor.com/#/ as it is a simple yet complete tool to create animation along with interactivity. While it is aimed at a younger audience, it should have similar tools for hand drawn animation as Pencil2D.

Thank you for your help and suggestion about WickEditor.

I downloaded Pencil2D just today and have already gotten kinda attached to it. If I don’t find anything else that suits my needs, I’ll try and use another program to play music while I animate using Pencil2D. Somewhere in the forum, such an idea was shared. I’ll let you know in case that turns out to be a viable option.

Anyway, I hope your team and you find a resolution to my problem and make my life a lot simpler :sweat_smile:

Thank you.

@RobinAnto Hi! Ok I imported the sound file sucessfully into the pencil2d file you provided. I can listen to it without issue of course, but I’m sharing it here so you can let me know if you can see the sound layer properly and if you can hear the sound as well.

If by any chance you can’t yet hear the sound, there may be really an issue with not just the 32bit app version but also potentially with your Windows version itself since WAV files should be able to be read easily without problem regardless of the Windows or Pencil2D version.

For now i’ll wait for your reply and thank you for your patience while we look for potential fixes for this problem (though I’m hoping it’s only a Pencil2D issue, because we can’t fix Windows issues ouselves :sweat_smile: )

@JoseMoreno Hi! Thanks for the reply.

Ouch! This hurts, because you can hear the sound, and it imports perfectly in your system, but it still doesn’t in mine. Only one frame shows up in the sound layer and there is no sound at all!

I’m all set to start animating using an “external” music player, but it’s going to be one laborious task. Hoping a resolution can still be found :sweat_smile:

Thank you, once again.

@JoseMoreno I wonder if this piece of info would help you in any way.

When I import a movie video, the bitmap layer gets filled with the frames, but the sound layer stays empty.

When I import a movie audio, the sound layer stays empty.

@RobinAnto Ah, thank you for verifying the file that I sent as well as the movie sound import. While it is strange, I’ve seen it happen before on older versions that didn’t have some of the fixes. Honestly at this point I’m not even sure what kind of unique environment you have that could enable such behavior.

One of the devs recently tried to use a 32bit version of the software with Windows 7 and Windows 10 through a virtual machine but they told me it was properly working for them as well :pensive:

I’ll ask them if they have any recommendation or troubleshooting tip for you but unfortunately your issues appears to be a unique case where your system sound settings could be directly affecting the way this specific software can read sound files.

This can usually be attributed due to missing OS updates or potentially problematic drivers with specific hardware, but that is honestly a bit beyond us since we don’t have direct access to your computer to do a more thorough check, so we can only guess.

For now we’ll keep reviewing this issue, however when you want to preview and add sound to your video at this point I’d recommend using a dedicated video editor instead of using a music player, this way you’ll be able to exactly measure at which frame a certain sound occurs.

There are free video editors available that can help you accomplish this, but you have to be careful looking for those that still work with Windows 7, I’m suggesting this with the additional intent of noticing if there is also a problem with these applications or not that way we may find an alternative to fix this issue, though that’s just a hypothesis.

For now here’s a list of potential tools for you to try out:

Free / Open-Source Video Editors

Open-Source

Free

@JoseMoreno Thanks for the suggestions and the various options you’ve listed out :slightly_smiling_face:

You are right about working with a video editor instead of a music player. I’ll annotate my sound file (extensively) and then import the video into P2D. I will then use the imported bitmap (secondary) layer to help me work on the primary bitmap layer. The annotations will help me close the gap in terms of the sync between the audio and video.

“I’ll ask them if they have any recommendation or troubleshooting tip for you …” Thanks for this.

@RobinAnto Hi! recently the other user that had a similar issue to yours had a breakthrough and we noticed something that could be the key to fixing this problem for your environment.

To test this I want to ask you to install a free video player called VLC. The key point for doing this is because this player comes with a good amount of audio & video codecs which should be helpful but also they might complement the vanilla codecs that come with a default windows OS installation.

https://www.videolan.org/vlc/download-windows.html

After you install it, reboot your computer then open Pencil2D and try loading a new sound file normally. If this works, it would definitely help us bridge the gap in our understanding of this problem and provide better support in the future for people with similar issues.

If it doesn’t work then I’ll ask you to install another set of specific codecs diectly at that time and keep looking for potential solutions.

@JoseMoreno I have been using VLC for many years now on this very computer. Nevertheless, I uninstalled/reinstalled VLC. The same problem continues. Only one frame gets added to the sound layer and no sound plays at all.

@RobinAnto Ah that’s unfortunate I was expecting at least some improvement on the situation :weary:

Recently one of the developers found a Microsoft related article which appears to be at least partly related to your own case. Please take a look:

https://support.microsoft.com/en-us/topic/fix-windows-media-player-stops-playing-wav-files-before-the-end-in-windows-7-d7a263e1-13af-8e61-f11d-b772318095a5

Now, while the solution outlined in the guide is to get a specific update to fix the potential root cause of your problem, if you’re not sure about trying this method it’s better to keep your current system as it is.

However if you do try this potential solution let us know if it helps at all. If it doesn’t, i’m afraid we might not be able to help much more than that since this really goes beyond our area of expertise regarding compatibility with legacy operating systems as well as Pencil2D related support topics :pensive:

Edit: There is a chance that the hotfix download button is not available considering Microsoft dropped support for Windows 7 in 2020. since I’m using Windows 10 I can’t current see the download button in the article, but hopefully you can see it with a Windows 7 OS

@josemoreno Thanks for the support article.

The hotfix download button doesn’t show up for me either. I wish it did! Anyway, thanks once again for all your help.

You are doing a wonderful job helping people. Keep it up. :+1:

This topic was automatically closed 42 days after the last reply. New replies are no longer allowed.

Imprint