Straight lines whenever I draw


I’m using the Huion 420 drawing tablet in pencil2d, and whenever I try to draw a circle it doesn’t draw then when I move the pen, it draws a straight line. I’m new to animation and drawing so I don’t know if this is normal or not, but it would be nice to turn it off.

This happens when I draw fast or slow.


@e1ement Hi, this doens’t have to do with being new to animation & drawing or not. IT may seem Pencil2D is either not recognizing your HUION tablet, or your computer is having struggles to calculate the lines.

If you can please try another free program to see if you can draw properly. There are drawing apps like Firealpaca ( or Krita ( that are completely Free, and can help you assess if your problem lies with the Huion drivers, with Pencil2D, your computer hardware (how powerful your CPU is) or all of the above.

If you can draw in either program just fine, then Pencil2D might not understand your HUION tablet input. As far as I know Pencil2D understands any WINTAB type input out of the box, so if HUION brands use wintab type drivers, it should work (which is why I’m asking you to test the other programs first).

If you can’t draw properly in other programs, but you’re sure that the drivers are of wintab type (normally there’s a label that says so) then it might be that your computer is not powerful enough to run any kind of advanced drawing program, in such case I’m afraid I don’t know what I could recommend because despite it’s simplicity Pencil2D needs a rather buff CPU (at least quad core) and minimum 4GBs of RAM, to allow for a decent drawing experience.

Try out the other software and let us know what are your computer specifications in order to better udnerstand what the problem might be. And try to maintain your HUION drivers up-to-date regardless of the software you end up using :slightly_smiling_face:

Hi and thanks for the help!

I have tried using Krita and the drawing works perfectly fine.

I have a Intel Core i5 8th gen with intel optane and a GTX 1050 graphics card and 8gb of DDR4 ram. The drawing works on other programs, such as windows paint, word 2016 and windows ink workspace sketchbook.



Here is a screenshot of the “circles” that i’m drawing.

@e1ement Thank you for taking the time to share the images and describe your tests.

It seems the problem lies with Pencil2D after all. Considering the app uses a programming framework that is veyr much the core of the software, and that framework is the one that handles (to my knowledge) how input is understood by the program.
As far as I know it only supports WACOM and wintab style of drivers out of the box. We’ve already put a research milestone on the roadmap to improve tablet support compatibility, however I’m afraid I don’t know when this will happen or when developers will have the time to pursuit such improvements.

For now all I can recommend is to use Krita to animate by hand, since their latest versions have included an animation plugin, so you should very easily be able to transition into Krita. :disappointed:

If you need more “automatic” vector animation you could try Synfig (

Hmm are you useing a line tool that might be why :thinking:

hmmmm did you actually take time to look at the context and attached images or just read the title :thinking:

hmm yes well i kinda did that lol :joy:

well then its preeetty obvious that i’m not using a line tool…

i guess haha :rofl: I some times do that

I’m having this precise issue, some things I didn’t see mentioned:
When I use a tool such as pen, pencil or brush with the mouse, I can draw smooth lines. With my Wacom tablet, these tools all behave the same way; when I press down with the pen, I can see that it registered the input, but it will not draw until I move my pen a certain distance from the initial starting point. It doesn’t matter how long I hold, it doesn’t draw until I move the pen out; at that point, it draws a straight line between the start and the point I dragged too. After that it behaves normally for the remainder of the line. Therefore, each line I draw has to start with an odd length of straight line.

Initially I thought it might be the touch function, but I turned it off and the issue persists.

Any ideas?

@WeirdoSheep Hey. I have Wacom too.

Note: Please make sure you are using the latest version of Pencil2D: (Get the Oct 14th Development version for your current OS)

  1. For the straight lines problem, here are some thoughts:

From a hardware standpoint, you might want to check if your pen is actually damaged or your nib is getting stuck into the stylus. The latter used to happen to me with wacom bamboo products.

From a software standpoint:

In the wacom tablet properties, create a profile for Pencil2D only under “Application”

Look for the “Pen” tab (where you configure the pressure sensitivity) and Lower the “Tip Double click distance” or turn it off even.

  1. Ona more in-depth level, the wacom driver is sadly a bit unstable from time to time I have aWacom Intuos Pro 5, and everytime I start my pc the driver FAILS and I have to restart it. So my Personal recommendation is to:
    a) Update the wacom drivers
    b) Once those are updated, if you’re on windows: look in the wacom configuration settings in the “Mapping” tab for a checkbox that turns off windows Ink (it should be called something like “use windows pen input”)
    c) The wacom driver will mess you up either way, so from time to time you might have to restart the driver. The most surefire way is to stop these processes on your task manager:

And then go to your services.msc config dialog (type services.msc on your windows search function)
And find the Wacom Professional Service or Wacom Consumer Service (depends on your tablet Intuos Pro will have the former, Bamboo will have the latter)


Right click on that, Press Stop. Then press Start. Or Alternatively press re-start.

This is mostly for that annoying “couldn’t find the hardware” bug.

  1. If nothing fixes your issue then don’t worry about a thing and use another program, it might be less stressful in the end
1 Like

Disabling Windows Ink in the tablet settings seems to have worked. Thanks a bunch :heart:

@e1ement We have recently made some changes to the tablet input code which may help with this issue. If you are still interested, please try downloading the 2018-11-04 nightly build for your operating system. Nightly builds can be found here. Please let us know if this fixed your issue.

@WeirdoSheep If you want to you can also try this same nightly build to see if the issue is fixed with windows ink enabled. I would love to hear if it helps or not.

Hey im having the same problems but not on pencil2d it’s actually on i used to be able to draw on it with my other tablet but that broke so i got a new one and i can’t draw on it Im using a pendisplay btw my friend doesn’t have this problem while using his so idk whats happening

@Iconic_lettuce Hey, welcome. Hmm that is weird indeed. Usually when this happens it’s mostly a problem with either the tablet’s drivers being oldish or the operating system being annoying.

If you’re using Windows 10 please try looking into this guide: Pencil2d automatically creates straight line when i put my drawing pencil on it

Even if you’re not using a Wacom, try mirroring the advice to your own device and drivers. Particularly the “windows ink” part and follo the windows “compatibility” guide linked there as well.

If you’re using a macOS or linuxOS machine, let us know as there might be something else we can recommend.