Reinstall not fixing tools panes issues!


(Sea) #1

I’m rapidly being driven mad by P2D having a mind of it’s own…I installed it and somewhow managed to get the tool palettes and things like this, which is NOT what I want, and I cannot, despite deleting all files and reintalling, get it back to “normal” with the drawing area large and the other things small and around the edges. Resetting windows doesn’t do it either.

I manually resized each one and tried to snap them to the side, but they do not do as I want. PLEASE HELP!!! I’m spending hours trying to get the programme to function and little animation done! I just want it back the way it was at the start…

Thank you


(Sea) #2

This is the best I can get to it going back the way it was. If I try anything else, like getting the windows closer together, they ping back to being large and sitting on top of one another.


(Oliver) #3

Hi @seaswimmer

You can try to clean your pencil2D registry, follow the guide explained here:

Just to be clear, if you change the layout by snapping the timeline to the bottom, the toolbox to the left etc… does it act up straight away or after you reopen pencil only?


(Sea) #4

Straight away. And then again if reopened. Thanks I shall follow the guide you suggest.


(Oliver) #5

Odd… I can’t say i’ve seen that behaviour before, if it happened only after reopen it might have had an idea but it if happens straight away, that sounds like a bug in the framework we use :confused:

What about if you maximize the window and do the same thing?
aand of course the good old, have you tried restarting the pc :stuck_out_tongue:


(Sea) #6

Ha ha no I didn’t restart PC…but I did maximise window etc. I’ve deleted reg keys now so here goes…will report back in a mo,


(Sea) #7

I get this layout on PC restart

and when I reset windows in P2D I get this layout again

(see nxt msg)


(Sea) #8


(Sea) #9

OK All is well, I once again deleted REG keys and then restarted PC before doing anything else, and reopened P2D and now it is back where it started.


(Oliver) #10

So it didn’t work by simply removing the registry? that makes me think that the restart fixed the problem :wink:

Ah well I’m glad you got it working again :slight_smile:


(Sea) #11

No reg deletion alone didn’t do it, but I can’t be sure that I didn’t have the app open, so closed everything and started again from scratch…thanks for your help!!