Pencil2D Nightly builds 2016


(Matt) #1

Nightly builds are the bleeding edge versions of Pencil2D, which contains the most recent fixes and features.

Windows: https://goo.gl/yunJod
Mac OS X: https://goo.gl/yunJod
Linux: https://goo.gl/0A0qys (provided by @oinkystudio)

You can help translate Pencil2D on OneSky!

Oct 10

  • Fix #527: Title gets an * after any changes are made. by @scribblemaniac
  • Fix #387: Users would not be warned when closing a modified document. by @scribblemaniac
  • Bug fixes and improvements (here) of Timeline by @scribblemaniac
  • Commandline overhaul, please refer to #528 by @scribblemaniac
  • Fix memory leaks at importing images by @edwrodrig
  • Movie export works again on Windows (but not yet for Mac/Linux)

July 1

  • Fix: Sound donesn’t play when using sound layer.
  • Modified zooming speed when using mouse wheel.
  • Fix #510

June 17

  • Release both 32bit and 64bit versions for Windows user
  • Add keyboard shortcut for “Goto Next/Previous frames” (@hankofficer)
  • Add a new language switcher as a drop-down list in Preference.
  • Add transparency checkerboard to color inspector preview box (@scribblemaniac)
  • Improve Mac experience, include .pcl/.pclx file associations and icons. (@scribblemaniac)
  • Improve brush size slider for value growth rates (@scribblemaniac)
  • Fix: Move the slider by clicking without dragging failed to change brush size. (@scribblemaniac)
  • Fix #426: Stopped color wheel changes from resetting alpha (@scribblemaniac)
  • Fix: Export as Image Sequence without selecting the camera. (@feeef)
  • Update translation from OneSky.

Mar 9

Jan 14

  • Enhance: Add spinbox for changing brush size and feather size, by CandyFace
  • Enhance: adds a “Bezier” toggle to the poly tool allowing you to switch between straight lines and bezier curve fitting. by @derek_saif
  • Fix: Block shortcut keys if the mouse is active. by @derek_saif
  • Fix #411, #409, #402, #397, #390, #388, #385, #383, #382, #380, #385, #377
  • Thanks @derek_saif, @feeed, CandyFace and Jonas Thomas.

Dec 19 2015

  • Enhance: The ability to have onion skin match the keyframes.
  • Fix #376: select and move frames around in timeline.
  • Fix #380: temporary switch to hand tool by holding the SPACE key.
  • Fix: move/delete selection with keyboard keys.
  • Fix #375: eraser opacity
  • Fix #372: Fixed vector selection rotation

Dec 14 2015

Dec 5 2015
Many fixes by @feeef

  • The preferences are now working (I didn’t work on the keyboard shortcuts though)
  • Onion skin is correctly working
  • Some updates in the bitmap brush engine (I still think it is not perfect and be improved)
  • Nightly build for Mac OS X is available.

Nov 29 2015

  • Fix crash on Vector layer painting.
  • Fix #304, #348

Nov 23 2015

  • Fix colour behaviour in the Vector engine by @feeef
  • Add japanese translation by tokyogeometry
  • Brush alpha handling improved by Spark01

(gordie) #2

Hi @chchwy :slight_smile:
Niiiice !


(tiber) #3

I think (maybe you’ve already discussed about it) it’s important to gather among us a test team of participants with different operating systems in order to check changes in coding.
They should keep in contact with developers.

Personally, I have two notebooks: MS Windows 7 and an old MS Windows XP SP3 (just 1 GB RAM).
I will “convert” the second one to a light Linux distro.
Except Puppy Linux (I don’t like it), which distro do you suggest to me ?


(kaiko) #4

Win8.1x64bits…

I can help withing this OS, reporting as usual information to developers


(kaiko) #5

@chchwy

I just downloaded the two files with the Nightly build but the one Pencil2D-win-20140610.zip fails to start (error: could not find or load teh Qt platform plugin windows)

The one working fine with a Bitmap layer is crashing every time I try to use a Vector Layer. I manage to draw some lines but it instantly crashes and close it.

EDITED:
I downloaded the MasterCode from Github Repository (23NOV2015), but Pencil still keeps crashing when using the Vector Layer


(oinkystudio) #6

I can help with linux since I’m using Ubuntu 14.04 in my machine. I’ll update you with the build when I get back from vacation.


(Jose Moreno) #7

@tiber I’ve hear Linux Mint (http://linuxmint.com/) is a great linux distribution for artists, relatively light yet powerful, and it’s used by people like David Revoy from “Sintel” fame. I’ve used Ubuntu in the past and it was ok, but lately its become too cumbersome with their “unity” GUI.


(Jose Moreno) #8

@chchwy Thank you Matt! So far it’s looking good, I’ve had some hiccups during my testing, but it runs and drawing, now doesn’t feel like I’m using sandpaper over concrete. Great work everyone! Another step in the right direction :slight_smile:

Here i’ll share something…

pencil_lady

I couldn’t export the image so I had to screenshot it. The camera layer bounds didn’t show up so i couldn’t frame it, and everytime I tried to export a PNG i got a JPG instead with part of the drawing on the top right. I’ll try later stuff to see if I can report properly.

For now let’s think of this as a victory, because I very seldom draw in pencil something haha :slight_smile:


(kaiko) #9

@morr,
About the image not completely exported, t is already reported long ago
Bug #284


(abhi) #10

I ran it on wine in ubuntu, while using the vector layer it crashed, but ran smooth with the tablet, Onion color thing is not working and multiple key selection needed. If possible provide 32 bit one also and please if somebody can help with the ubuntu version.

Thanks for the nightly build.


(abhi) #11

how to delete this


(abhi) #12

Posting again because tested again

I faced the same problem as @morr duly pointed out by @kaiko that its a bug, any way here is the image

[caption id="" align=“alignnone” width=“800”]Pencil test Nigtly build test[/caption]


(oinkystudio) #13

ok… so I tried building pencil in linux using qtcreator and so far it is working.

There are some tools that were not working properly. Brush tool in vector layer and pencil tool in bitmap layer has some problem. The fill tool is not working unlike from feef branch.

There are improvements though like the camera border in display option. And also the hand tool where you can move the canvass smoothly.

 

Here’s the linux build

https://drive.google.com/file/d/0B0LATwtbVtB3Wndwd0IxY1RBd0E/view?usp=sharing


(MiSc) #14

I’ve tried the nightly on my Lenovo T500 with Windows 10 and I’m getting a really weird bug. Pencil starts up fine, but the window immediately goes out of focus when I try to interact with it. Alt-tabbing back into it does nothing, it just goes out of focus again on the first stylus/mouse click.

 


(happydonut) #15

Alright guys, I’m running Windows 8 on a Pavilion 23, and I got this as soon as I tried to open Pencil:

"Pencil2D.exe - System Error

The program can’t start because MSVCP120.dll is missing from your computer. Try reinstalling the program to fix this problem."

…Only I didn’t install it in the first place because it’s running off a zip. Any ideas how to fix it? Sorry if this is a noob solution, I’m not the best at computers :'l


(manu) #16

@happydonut

Hello! I don’t think it works to just run Pencil within the opened ZIP file, you need to right-click the zip fie and “Extact All” to a known location, for example C:\Program Files or C:\Temp or whatever you think is the best place for testing.

Happy testing.


(kaiko) #17

@happydonut

The issue is in your Win8.
See the following video in order to fix the faulty .dll


(feeef) #18

Just to give you a quick update of the state of Pencil devs.

I am a bit behind my planned schedule. I was planning to have a first full featured version today but I couldn’t manage that.

I have merge my branch with the main Pencil branch which had some refactoring. This refactoring is very useful in the code but Matt didn’t complete its work on that so it is what I am doing right now. I am mainly working on centralizing the settings management in one location (PreferenceManager) because there were settings handling everywhere, some could conflict with others and make the app unstable. With this refactoring, the entire app will be much more stable.

I hope to complete this dev very soon, fix the remaining bugs and maybe get a first beta of 5.5 next week.

I will keep you updated!


(happydonut) #19

Thank you @kaiko! The fix worked, so I’m testing right now. The overall look and feel of the program is much better now, sleeker and more user friendly. Unfortunately, almost all the drawing tools have downgraded, so here’s what I’ve got (testing on the bitmap layer):

  • When Pencil2D is at full screen, the Brush and Pencil tools are considerably more jittery. Smooth curves are almost impossible to achieve and sometimes straight lines will appear out of nowhere. HOWEVER both tools are extremely smooth when Pencil2D is minimized.

  • The Pencil tool is very light with no way to change opacity.

  • Polyline now works like a Bezier Curve tool?? Except there’s no control, so it curves on its own whims.

  • Smudge is useless unless you want some really trippy glitch effects.

Improvements:

  • Select works fine and Move is smooth now, although the moved section will not show until you click outside the selected box.

  • Bucket works much better now! Have yet to encounter any glitches.

Now, the vector layer has the most problems:

  • Can only do one stroke with Pen, Pencil, or Brush tool, and then the program crashes.

  • Same goes for polyline. I can do as many lines as I want, but once I double click and finish the shape, the program crashes. On the other hand, it doesn’t do the weird Bezier effect on the vector layer.

  • All other tools have zero effect- bucket shows a light gray brush stroke but disappears when I lift the pen.

I haven’t gotten to animating yet as I’ve been busy, but I’ll keep updating! Again, as reference, I’m running 64-bit Windows 8 on a Pavilion 23.


(feeef) #20

The latest nightly build is not the right version to start serious testing. Both my devs and Matt’s where not complete so, some features are not fully implemented or have been broken by the merge.

When I complete my devs, hopefully very soon, we should see much clearer as everything should be fully implemented. Testing will be more useful at this point.