Pencil2d doesn't display properly on my tablet


#1

Hello. I have been using Pencil2D for a few months but just recently joined the forums. I recently got an XP Pen Artist 15.6. When I open Pencil2D on it, it wont allow me to maximize and the window is too big for the display. It works just fine with Krita so I am sure it is something with pencil.


(Jose Moreno) #2

@n00b Hi. a few questions:

  1. Can you take a full desktop screenshot with this behavior?
  2. Did this behavior start before or after getting the XP Pen Artist graphics tablet?
  3. What operating system are you using (please provide the version along the vendor. e.g macOSX 10.11, Windows 10 Ultimate, etc)
  4. What version of Pencil2D are you currently using?
  5. Is the current version the same with the problem? Was there any previous version that didn’t have this problem?

Thanks.


#3

@JoseMoreno Thanks for looking into this.

I am running Ubuntu 18.04 but I had similiar problems on Windows 10 Home as well.

I am using Pencil2D v0.6.2

When using the tablet as a second screen it allows me to maximize but parts of the UI are drawn over other parts. When I have it set to my only screen it is stuck in window mode and opens in a window bigger than the size of the screen.

This is what happens when I use the tablet as the only screen.

And this is what happens when I use it as a second screen.


(Jose Moreno) #4

@scribblemaniac @CandyFace @chchwy Hey sorry to bother you all. Would any of you know how we could test for this issue on Ubuntu and windows 10? Could this be a second display problem due to the Qt components or is it really related to the screen tablet itself? What do you guys think?

Edit: I also notice that the icons seem to be huge. Could this be an issue related to how HiDPi screens are interpreted by Qt as well? Also it’s weird that the user can’t resize the window, it almost appears as if the tablet itself was forcing the proportions of the application to fit the tablet drawing region, and not the other way around like when wacom forces it’s drawing area proportions on the whole screen; this could be a driver problem, but it’s weird that Krita is not affected.


(Jose Moreno) #5

@n00b Thank you for providing both screenshots, the issue is more clear now. Also no worries, hopefully thee’s something that can be done to improve this, I’ve already tagged the developers to ask for their opinion on this issue.

To help them out I have another set of questions, if that’s ok:

  • What is the max and current screen resolution of your screen tablet?e.g. I have a Wacom Intuos 5 Pro, and it supports up to 1920 x 1080
  • Is your tablet being connected via a VGA cable or HDMI cable?
  • What is your normal screen resolution in use? e.g. I have 1920 x 1080 due to the graphics card.

Without knowing about technical details, it almost appears to me as if the tablet drivers were forcing the application to conform to that specific display output size, which is rather bizarre to say the least, particularly perplexing is the fact, as you mentioned before that Krita does not have this problem. Since both are written using the same GUI framework I would expect at least a related response from other Qt-based applications (OpenToonz, Krita, Pencil2D, etc).


(Oliver) #6

It looks like a scaling issue of some sort. You can tell by the size of the title of the window on the second monitor, that the resolution is high, yet everything inside the application except the window frame suggests that scaling is applied. the application has a min. height and width and it looks to me like it has managed to squeeze it more than what should be possible, thus overflowing the widgets into each other.


#7

My main monitor is 1600 x 900.

The graphics tablet is 1920 x 1080.

Its connected through a cable that has USB-C that plugs into the tablet and the other end is an HDMI that plugs into my computer.

Here is a screen of Kirta on the same 2 screen setup if it helps.


#8

@JoseMoreno I wanted to update you on this issue. I got Pencil2D to display correctly by simply building it from source myself. I did not need to change a line of code. I just built it myself and it opened at the correct resolution. Maybe this could help out someone else who runs into a similiar issue.


(Jose Moreno) #9

@n00b Hey thanks for updating us on this matter. I’ll inform the other devs to see what they thing so we can incorporate your report into the solution of similar issues :slightly_smiling_face:

Edit: If you don’t mind I’d like to ask you a few questions. What version of Qt did you install and what dependencies did you install in Ubuntu? or what command did you run to grab all the necessary elements to compile the application again so it would work for you? That would probably help understanding why this problem appeared in the first place. Thanks in advance!


(Jose Moreno) #10

@scribblemaniac @candyface So according to the user experience, they solved this issue by compiling the program from source. Perhaps the best way to override this problem with other tablets in Linux distros would be to compile from source on the target platform, but that might be daunting for non-technical users.

Perhaps it was that by installing the necessary tools to compile from source the required specific components to the Ubuntu version were properly queried?

What do you guys think of this new information?


#11

@JoseMoreno I installed QT 5.12 which as of this writing is the most recent version. I used GCC for the compiler. Other than that, I just followed the instructions on the github page. Everything seems to be working fine except now it does not seem to register I am holding the button on the pen to move the drawing area. I think this might be do to a conflict with a version of qt I already had installed so I am going to try to remove any older versions and seeing if that helps. I will let you know how that goes.


#12

@JoseMoreno Ok I have been running lots of different test to see what is causing which errors and I have atleast figured out what was causing the scaling issues. It was the version of QT. If you build Pencil2D against any version of QT older than 5.12 the scaling issues will be there. The problem I am still having is that even with 5.12, the buttons on my pen don’t seem to work on the drawing surface. I have tested it on the color wheel and it works there but it doesn’t work at all for dragging the drawing surface around. Do you know what may be causing this?


(Jose Moreno) #13

@n00b Thank you for running all those tests. Well to me it sounds like it’s a problem with Qt itself both the previous issues and the current issue. To be honest we were also waiting for the new Qt version to fix some problems with tablet events where there was a problem with how the events were being processed and some strokes at certain angles were calculated incorrectly, however that should not affect how your buttons react to the program :weary:

I’ve already tagged some of the developers that have knowledge on the tablet issues and were testing Qt 5.12, but we might have to wait for them to answer for a more in-depth response.


(scribblemaniac) #14

The resolution bug being a Qt issue is not too surprising. We’ll keep that in mind for anyone who has similar issues in the future.

@n00b What are you mapping the buttons on your pen to? Do your buttons work with the latest nightly build? It’s possible that we’re not handling that event correctly after some recent changes to the tablet event handler code.


#15

@scribblemaniac I have them mapped to the middle and right mouse buttons. I tried it with the nightly build and it doesn’t work on that either. It will draw a straight line to where I click the button at on the drawing area. I went back and tested the buttons on the build from 10-14-2018 and it does still work on that. But both that version and the nightly build have the scaling issues so they are mostly unusable on my tablet.


(scribblemaniac) #16

Well if you want to have your cake and eat it too, you can do git checkout b5ae22c on your current source or download the source from here and compile it on your system with Qt 5.12. That should theoretically fix the scaling issue but still allow the buttons to work. I’m personally not able to reproduce this bug with my tablet, so it may be brand-specific. We’ll see if any of the other developers can or cannot reproduce this bug. If not, we may need you to do some more testing at some point to determine the exact cause of the bug.


#17

@scribblemaniac This fixes everything. Thanks. I am a developer on an open source project also so I know you guys probably give up a lot of free time to develop this great software. I really appreciate your quick response to my issue.