Onion skin is not available while working over a BG layer!

bug
onion_skin

(Royc) #1

Hello
I have imported a background for an animation test
When i’m drawing the key frames in a new bitmap layer it looks like the onion skin doesn’t reply to it-it’s simply gone…
In order to see the onion skin i need to turn off the BG layer…but it doesn’t help since i need to see my character interaction with the BG
any solution to it?

thanks


(Jose Moreno) #2

@Royc Hi this is actually known issue as you can read here: https://github.com/pencil2d/pencil/issues/989

Indeed the current workaround is to turn off the background while your animating using onion skins as you have already noticed. Until that issue is fixed (which involves a lot of work into the onion skin system) You can try to lower the opacity of the background in a different program like Krita or GIMP and export the “working background” with transparency as a PNG, then you’ll be able to import that into Pencil2d and see the onion skins through the background.

I know it’s not ideal at all but until we get the light table mode back as you can see in this request https://github.com/pencil2d/pencil/issues/1112 or the devs rewrite the timeline so we can get layer opacity as well as per this request https://github.com/pencil2d/pencil/issues/883 it’s very difficult to workaround this issue, sorry :slightly_frowning_face: