Newbie with Newbie Questions

Hello. First, thank you! To all who take the time to make this software available.

So I’m a math teacher, computer nerd, budding author, and occasional artist. :slight_smile: I like to do art for its therapeutic value. As I’ve been in Stress Mode a lot lately, I’ve been doing a lot of art. I use GIMP but felt as if the limitations of making an animated GIF were beginning to make things too difficult. So I downloaded Pencil2D and have been playing with it. I’ve read through the FAQ, looked at a few tutorial videos, and read many of the topics in the How To section. Some of my questions have been touched on, some havent, but I figured I’d clump them all up in one place anyway. Thank you in advance to anyone who can address any of my questions. Originally I was just doing animated GIFS and looking to expand so keep in mind that I began with the idea of GIFS. Also I’m old enough to have grown up in Cupertino about the same time that Apple was growing up there. My first animation class was on personally autographed by Wozniak pre-Macintosh (forgot the name) computers donated to our high school by Apple computers.

  1. I don’t understand the camera layer. I ignored it, but the first time I took my file and saved it as a movie, I got a crooked film. It was also zoomed in to about 1/4th or 1/2 the original image. Thus most of the “action” was out of the shot. I also noticed that when I go to the camera layer, it is upside down. boob in the bitmap later is poop in the camera layer (does that make sense? tried to think of an ascii method of showing what I meant) maybe boob is qooq (but it’s funnier to say boob is poop).

  2. I figured I’d somehow rotated the image in the camera layer, so I added a second camera layer and then deleted the first. The new layer was upside down. I’m pretty sure that when I imported my gif file(s) it was upside down. At the Bitmap layer I hit the R key until it was right-side-up… but perhaps that was my problem.

  3. Since my animation is a file that is 1480x1080 created in GIMP, I realize that it might be too big to create an animation. I wondered if it was possible to use the camera to “pan in” on the action for each part of the animation. Suggestions on how to do that?

  4. Since I’m here and asking… what happens if there are two bitmap layers. For example, lets say I have a paper airplane animation in the one layer, and a running stickman animation in the second layer. (I’m thinking now I have to try it out to see what it looks like) but I was just curious about that.

I did want to add or clarify that nothing I’m doing will cure cancer, entertain the masses, or otherwise do much beyond entertaining teenagers who are bummed out that they have to go to math class, again!

@Sasheena Hi Sasheena. Welcome to the Pencil2D forums. First of all, thank you for taking the time to properly explain your issues and your expectations. It helps a lot when trying to provide support for the software :slight_smile:

Before answering I must say that doing art for art’s sake along it’s therapeutic value has merit and we’re humbled that you’ve chosen Pencil2D as an alternate tool to do that along other well established packages like The GIMP.

Most of your issues seem related to the camera layer so firstly I’ll share this reply (which has GIF’s :wink:) to show how the camera work can be used.

https://discuss.pencil2d.org/t/how-to-zoom-while-drawing/3880/3

Then to reply in order:

  1. Along the previous guide I’ll briefly describe the camera layer. For lack of a better example, this layer works like a real camera in the sense that you have to manipulate it separately form your drawing.
    The following is my interpretation of the software, which will probably become part of the official documentation at some point:
    Pencil2D manages two “modes” that work seamlessly:
    • A. The CANVAS VIEW mode where you can manipulate the drawing surface (e. imagine moving the paper on your table), which only affects how you, the artist, see it (e.g zoom, tilt, pan) This mode is active whenever you have a drawing layer (bitmap [blue] or vector [green]) selected (the layer will appear slightly highlighted)
    • B. The CAMERA VIEW mode where you can manipulate the camera frame / viewfinder, which affects how the final result will be seen by everyone. This mode is active whenever the camera layer is selected.
  • It’s possible that you zoomed in the camera at some point and left it like that without noticing. To this we recommend always being aware of the ZOOM indicator on the bottom left corner of the program, and if you’re unsure, to press the key combination CTRL + H or go to View > Reset Zoom / Rotate to restore the ZOOM to it’s default state in both CAMERA and CANVAS views.
  1. Regarding the “upside-down” part, Pencil2D has a vertical mirror mode. We’ve had cases in the apst where our users inadvertently enable this and then go on to work in the animation only to find when they render that they have all their work upside-down.
  • To make sure this is NOT enabled review the “display” widget and look the for vertical double arrow. If the button is depressed, toggle it back. Or go to View > Vertical Flip this should also indicate if it’s active or not. The default state is for the feature to be toggled OFF
  1. Pencil2D has no problem by importing large files, however you do need a moderately powerful computer if you intend your animation to have both, a large resolution size and a time length beyond 10 seconds
    For longer & bigger animations, we recommend working separate shots in different files and to save constant backup copies due to a few issues our dev team is working to fix where files get corrupted and work is lost.
    You can PAN your camera by:

    • A. Selecting the CAMERA layer
    • B. Select HAND tool
    • C. Position the time indicator (red vertical bar) on the first frame you want your camera PAN to initiate
    • D. Left Click with the hand tool over the canvas to position it
    • E. move the time indicator to the final frame you want the PAN to end (you should still have the camera layer selected)
    • F. Use the HAND tool to move the canvas and PAN the shot. Pencil2D will automatically interpolate the camera motion thus providing a simulated illusion of motion
  2. I’m not sure I understand your intent here. You can have different “elements” in different layers. Each one will have to be moved separately. Moving the camera will move them all at the same time, we currently don’t have support for parallax scrolling effects (but this will be added at some point, i’ll make sure of to pester the devs for it :wink:)

To answer another question you mentioned on your comment, separate cameras don’t do anything specific yet, only one camera can be the active camera (the one that is selected) however during movie export you can choose which camera is selected to be rendered as the final movie, which helps from a cinematographic point of view to create a “master shot” will all the action from a specific vantage point, and then use “close-up” cameras on a character that’s talking, for example, to allow the artist to edit all the shots in a continuous flow; this is a principle in film-making as shots / footage are simply considered the raw material for the film itself to become a whole piece envisioned by the director or author.

I hope this answers your questions and help you progress. If you have any other question let us know. Cheers.

1 Like

I wanted to thank you for your response. There is a lot to unpack. I continued to search for answers once I posted, since I like to solve issues myself. I’m going to go through everything you mention here, so that I can try to make the most use of this. :slight_smile:

I did mean to mention the specs on my computer. It’s my birthday this month, and I decided that buying the “cheapest computer available” was really the worst choice because, even though I mostly only browsed the internet, created lessons, and used Microsoft Office, the computers invariably stopped functioning properly within a year. So this year, I decided to buy something a step above the cheapest model available. I got a Nitro 5 with 16 gb of RAM and a separate graphics card with an additional 4 gb of RAM and a SSD in addition to a regular 1 TB HD. It has a NVIDIA GTX and Win 10, 7th gen core i5 etc etc etc. :slight_smile: so hopefully this is able to handle more than my prior computer could! I feel a little guilt to spend so much on something I’ll just play around on (it’s a gaming computer, but mostly I just do art, desktop publishing, and now some attempts at animation).

Anyway… I’m going to read through your very helpful and prompt reply, and see what I can do.

In between my original message and your response, I did find that double-clicking on the camera layer name allowed me to set a higher resolution, which does allow nearly all of my art to fit in the “movie” I made. I also found the menu option that allowed me to reset the rotation (and now everything is upside down, so I’ll read through your helpful points on that)… I think it’s probably a simple thing that will result in a major lightbulb moment. :slight_smile:

Thank you again for your thorough helpful response. I’m going to play with it and see what I get. So far I have been able to make a 3 1/2 minute “movie” with music. I’ve also been creating the animations in bite-sized pieces in GIMP and then importing them, which makes it so that I have built in backups.

I’ll report back on my success, too. Thanks again!

So, the program closed unexpectedly but it had saved not that long before, and as I mentioned, I am only importing the work into it, so nothing was lost really.

I did want to mention that the upside down thing, which seems to be solved with the reset (at least now that I’ve restarted the program) wasn’t a vertical flip before, it was a 180 rotation. So it wasn’t the vertical flip. The reset, this time, does seem to have done the job.

As far as doing anything at all in camera mode, I’m still struggling with that. the hand doesn’t seem to do anything. The zoom number in teh bottom left corner says 0.00% sometimes and 100% sometimes and often says nothing at all. When I try to zoom in the camera mode, nothing happens at all.

OKAY!!! (I hope you don’t mind my thinking out loud here)… suddenly the lightbulb flashed.

I was watching the other thread where you had those GIFs and I was watching your panning and I decided to literally follow your steps, and suddenly it occurred to me that I had added nothing to the camera level, no frames (or whatever they are called)… so it was like I had no film in the camera, so it wouldn’t do anything. Once I clicked the plus button, I could pan, zoom in, zoom out, etc.

SO… now I think that I can play some more. :slight_smile:

One five-minute, utterly pointless, cutesy animation coming right up! The only bummer is that I’m only through the first 20%… but perhaps there will be five parts. I’ll post it to youtube when I’ve finished. Because – why not?

Another silly question…

My first effort I gave up on, because I was trying to insert some credits and then most of the bitmap layer just went poof and I didn’t know what I did. So I started all over again, Then i started to add in some credits, and poof everything after the place where I put the credits just went blank. I don’t know if I deleted every one of the several hundred bitmap pages, or just made them invisible, or ???

SO… I’m going to make another effort. I created the credits as an image this time.

I’m thinking that somehow I messed up by creating a new frame and doing a bucket fill (of black… the blank frames are all white), or by using the select tool (and then deselect all) or by changing my mind about where I wanted the credits to go, so I went and selected everything (all the bitmap frames) and dragging them to the right so I’d have room for the credit sequence, which I dragged all the way to the beginning.

I then decided that I didn’t like it starting with a white frame, so I bucket filled the first frame with black. After I got the credit sequence all good, I then went to the rest of the frames and selected all of them to drag them back up snug against the credits. (with a tiny gap so I’d know where each part ended). After I did that, I hit play so I could see how the credits segued into the body of the piece… only to find that the entire body of the piece was pure white.

SO… did I mute the images and they are there, did I delete them (and how, so I don’t do it again), or… any ideas how I made this collossal error? IT could also be a bug

Oh, and for reference, I just downloaded this program yesterday.

I’m going to save this file under a new name, and then start fresh. Thanks in advance for everyone who can give me some insight. Sorry for being a pest. But I’m determined to make one tiny little animation before the day is done. I have a bridge to build and a river to create, but I WILL animate what I’ve already made first!!!

:smiley:

@Sasheena Hi. Sorry to hear about the crash, however it’s unfortunate to say that in those circumstances it’s expected, because if you work on the program without saving at least once, everything will start piling up on the computer memory (RAM), and once it’s filled up due to using high resolution images and drawing for long periods of time, it will overflow and crash the program.

You have to save at least once to write the information to disk. To avoid these situations (which are uncommon believe it or not) you can just pre-save the blank file with a new name and along the autosave feature Pencil2D will only save those images that were changed afterwards. (The first time you save a lot of images it will take a long time by the way)

As for the disappearance of the images, this worries me since you’re running the Windows 10 OS. Recently we’ve been indeed dealing with a bug that makes the images disappear, however this is a very rare occurrence and 100% of the reports have been made under that OS. We used to have a similar problem that was related to the memory, but that was fixed, and right now it seems to be related to something else entirely.

Why i’m not fond of Microsoft, I don’t have anything against Windows 10, it’s just that I’ve been trying to reproduce this issue and not even with project that had a file size over 1 gigabyte, along 1500 frame at 1920 x1080 pixels, could i make Pencil2D either crash nor “dissappear” any frame. And I’m not a developer. I have a consumer computer, in fact much slower than your newly bought computer. However, I’m using Windows 7, so this “vanishing” problem seems to be specific of Win10 users and we’re still trying to find the root cause.

There was apparently a problem by moving many frames on the timeline, but I doubt this was the case for you, in this case it seems to me that it’s related to memory…

If you don’t mind me asking can you please provide me with the following information:

  1. What is the current version of Pencil2D you’re using. Please go to the menu Help > About and press the Copy to clipboard button. The paste the information on your reply.
  2. Please read the following guide:
    https://www.howtogeek.com/howto/21726/how-do-i-know-if-im-running-32-bit-or-64-bit-windows-answers/

And let us know what is your operating system bit architecture. I assume it’s 64bits, but one can never be sure with these machines.

If it is even remotely possible that you downloaded the 32bit version instead of the 64bit version, this would probably also contribute to the memory issue limiting how many of your imagescan “show up”, but I can’t be sure until we review this information.

Of course it’s also possible that there are other issues at hand, so if it’s ok with you could you share the file that had the images lost? You can use whatever cloud file storage you feel comfortable with. I normally use http://wetransfer.com as the server that was setup for these cases is not working due to some unforeseen issues. (if you want PM the link)

Next time you have a similar problem please also share a screenshot of the entire Pencil2D window, and if you want separate each issue on a different post so we can address each one separately. That way we can have a better idea of what might be happening and how to help you if it happens not to be a bug but just a misunderstanding of how the software works.

Lastly I’m going to share this guide to help you prevent data loss and to prevent the consequence of file corruption (which unfortunately happens often with Windows 10 due to a permissions problem, but we’re still investigating)

Thanks so much for your help on this. I do 99% of the time anyway, save a file fairly obsessively. I’d saved the file that got “corrupted” (both times… because it happened twice) and I have all those. I use dropbox a lot and google docs. I’ll PM you the appropriate link. I do not at all mind trying to help out with troubleshooting I will work to post new questions for each issue from this point going forth, and leave this thread entirely for the troubleshooting of disappearing stuff (for want of a better word!). If I am able to help find and fix a bug, I’ll feel like I’ve “paid” at least a little for this wonderful program. I’ve literally spent the last hour or two making the images better that I was planning to use (something therapeutic spending two hours to fix a 5 second set of images. :slight_smile:

So I copy pasted from the Help>About and got the following:

Version: 0.6.4
Operating System: Windows 10 (10.0)
CPU Architecture: x86_64

Also my computer is definitely a 64 bit, I went through the steps on the how-to-geek, to be sure, but it was definitely.

I have three files… the first one when stuff went poof (smallest file) … I don’t remember if I saved after it was clearly all messed up. Then the next one is much larger… after stuff went missing, I immediately saved as a different file name, in hopes of saving prior versions and some of my work (didn’t help). I"ve uploaded the smallest file, and will try to upload either of the other two if you need them.

I don’t mind sharing a screenshot, but not sure if it’s helpful to see the blank stuff (it just looks like a blank page, but from one point it’s all blank)… but I can. I’m guessing this is to make sure I don’t have toggles on/off that should be off/on. :slight_smile:

Whenever things get buggy with any program, (crash frequently - like with my stupid earlier computers) I have a tendency to save sequential files. For example, I am on my third attempt of the same project today, and when I saw that I had a response to my message, I went ahead and saved. Then I “Saved-As” a new file name, so I’d have my prior work, and not mess it up by doing more work on it. I’ll probably continue with the sequential saves until I’m successful at this particular effort.

I’ll send you a PM with a link to my google-docs file. Hopefully that will be enough, but I can upload the larger files for your inspection if you’d like them. :slight_smile: Anything I can do to help.

Just to be clear, this computer is also only 10 days old. Also in case it matters… I have 4 MS Word docs open (one is a full-length novel with 159,000 words, give or take), 1 MS Excel, three different users logged in to Chrome (with altogether about 20 tabs open), GIMP, the dinky calculator that comes with Microsoft, The Movies & TV App, the Photos App, and the Snipping tool app all open. Plus the Pencil2D app. All-in-all a fairly light-use sort of day.

This topic was automatically closed 42 days after the last reply. New replies are no longer allowed.

Imprint