I'm Confused. I can't install

I’m sorry, but I don’t know how to install the program. I open the zip file, and that’s it. It’s just unzipped files, no app. I was born before PC’s, and I’m stupid. I don’t understand the troubleshooting at all. Please help!

@Dela Hi. Pencil2D is actually a portable application. It’s not required to be installed in the sense that you will not get an installation wizard.

All the necessary Pencil2D ingredients to be run normally are found inside the ZIP you download from the official website.

Once you extract all and every file into a new folder (under windows) you only need to run the app by double clicking on the pencil2d.exe application (it’s the only one with a diminute pencil icon)

If you find any warning messages and you’re under Windows 10 please take a look at this guide first. It should guide you through all the necessary steps to successfully run the program under that specific OS.

If you’re using a computer with macOSX or a Linux flavored OS, you only need a specific executable. For mac you need to drag the contents into the “install” folder. For Linux you can run the portable executable.

Also, please don’t say you’re stupid. If you’re having trouble with running the software after trying out the guide it means we still have much to improve in terms of accessibility. Let us know how it goes and should anything fail, we’ll try a different approach to show you how to get the software up and running.

1 Like

Thanks. it worked. I’ll be on the forum if I need more help and show my stuff.

D.

1 Like

Hi I don’t seem to be able to unzip this file without purchasing WinRAR for Cdn$45. I’d rather not. I tried using 7zip and that doesn’t help either. pencil2d-win64-0.6.4.hotfix.1 is the file I downloaded and it’s detected as a WinRAR zip file type. I’ve already restarted my PC. Is there a way around this? Thanks in advance.

Hi Paul and welcome

WinRAR is not required to unzip Pencil2D, you can use 7zip or even Windows own file extractor. Simply right-click on the .zip file and select “extract all” should do the trick. If for some reason that option is not available, you can also go use 7zip like this.

1 Like

Thanks for the quick response. Whenever I try unzipping it unzips to the same file. I’m not sure how to describe it. I just end up with the same hotfix file. I didn’t get an option to “extract all” until I’d used 7zip and been trying for well over an hour. Usually I got “extract files” or “extract here”. I’ll share some screenshots with you in a little while. Thanks again for your help.

I noticed you wrote “pencil2d-win64-0.6.4.hotfix.1” if that indeed the name of the file, then that’s wrong. It should be “pencil2d-win64-0.6.4.hotfix.1.zip” make sure that the file has a .zip extension otherwise that could be the problem.

You could try to add the .zip extension yourself and see if it recognized it after that, usually when you unzip an unsupported file, the result will be as you describe, so that could mean the file wasn’t downloaded properly or for some other reason the extension got removed.

1 Like

The .zip extension is present at the bottom of Chrome when I first download it but doesn’t show when I look at it in the download folder. Maybe adding it will help. Good catch on your part. I should have mentioned it. I’ll try adding the .zip extension in a while when I’m done working.

@blackpbike Hi. If you read the solution for the original response on this thread there’s a guide that shows how to handle various important tasks on Windows 10 (most of them apply to other versions as well) to avoid permissions issues with third party apps including Pencil2D.

If you can’t see it here’s the direct link: [Guide] How to Train Your Pencil2D (Windows)

On this guide there are instructions and curated links that showcase many fundamental procedures to manage the downloads, including how to zip/ unzip files using the windows explorer only.

There’s no need to use a third party app. And as mentioned by CandyFace you do not need WinRAR, nor WinZIP or any paid software to unzip Pencil2D.

Since the guide is critical to maneuver and handle Pencil2D under Windows 10 due to reported problems with Windows OS aggressive security protocols, we recommend you to please take some time to review it.

Even if you end up not using Pencil2D and try other free and open source animation software, this guide will surely help you get around most common pain points for third party apps in such environment.

Thanks Jose and Oliver

Looks like the PC had WinRAR installed and it was blocking the Windows unzip utility from working.

I uninstalled the WinRAR application and everything was more or less smooth after that.

The Pencil 2D app is behaving strangely but I’ll struggle with it before I bother you with it.

Thanks again for your help and quick response!

Paul

1 Like

@blackpbike No problem. If you can define in reproducible steps just how strangely Pencil2D is behaving we might be able to troubleshoot that as well. Anything you want to ask let us know.

And by all means, even if Pencil2D ends up not being a suitable tool for your workflow if you let us know, we’ll take the feedback to heart and also recommend other apps that you might be able to try out before settling with a single tool.

I personally think it’s always better that people feel comfortable with the tools they use, so take all the time you need reviewing :slightly_smiling_face: :+1: .

Very much appreciated Jose. It works fine now that I’ve redownloaded the drivers for the Adesso drawing tablet. This was all for my 14 year old son who is super happy to finally be able to mess around with animation. I guess you can take some satisfaction in knowing that both my issues had nothing to do with the Pencil application.

Cheers

Paul

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.

Imprint