Can't open program


(Foxxer Green) #1

When i try to open the program i only get the file and when I double click that, i get a bunch of other folders, but no program.


(Jose Moreno) #2

@Foxxer15 Hi, what you are downloading is a ZIP file, which is a compressed folder that indeed contains a lof of other files. To use it you have to EXTRACT those files into a proper folder, and only then you can execute the “pencil2d.exe” (the only file with a pencil icon) to run as a portable program (meaning you don’t have to install it)

IF you are using the Windows operating system, there are guides that can help you extract ZIP files. Here’s one I found that tells you how to ZIP and Un-ZIP files in Windows.


(Marco Antonio Dominguez Cid) #3

I tried that, but it didn’t exactly work; I tried to activate the application but it said that four specific files were missing even though they were very clearly there. Is there anything that I might’ve missed while I was doing it?


(Jose Moreno) #4

@Shyguy128 Did you unblock the ZIP file? The thing is windows tends to be very jealous (particularly newer versions) of files that are not “signed” by official windows developers, so those tend to be “blocked”.

To unblock a zip file you have to right click on the downloaded zip file > go to properties > general tab > and towards the bottom press the “unblock” function. Only then you’ll be able to extract ALL the files without issue.

Of course is this continue to happen then you have to check your antivirus software and create an exception for it. Normally antivirus tend to do the same, they just block anything that looks suspicious particularly in windows systems where virus tend to camouflage in DLL files with the same names of system files. However I can assure you that if you downloaded Pencil2D from the official website there is NO virus or adware, so you can create an exception for the file without worry.


(Marco Antonio Dominguez Cid) #5

But the ZIP file isn’t blocked, and I don’t think antivirus systems block DLL files, is there anything else I should look out for? Particularly with the previous version still on the computer? Just saying.


(Jose Moreno) #6

@Shyguy128 Even if you think the file isn’t blocked, it’s better to do those steps to be safe as Windows tends to be very aggressive with such annoying behavior.

The other problem I can think of that might be happening is that when extracting, by Windows will, it decided permissions weren’t high enough so you can also try to run your zip file manager as an administrator (right click > run as administrator)

Those are the only ways that those files can go missing. If everything fails try to unzip the files on a USB in a different computer that works and then use it from your usb stick on your current computer.


(Marco Antonio Dominguez Cid) #7

Maybe some clarification and specification will be needed:
Qt5Multimedia.dll
Qt5Gui.dll
Qt5Xml.dll
Qt5Widgets.dll

I don’t get why it targets these files specifically.:thinking::confused:


(Marco Antonio Dominguez Cid) #8

I think it has to do with the update.


(Oliver) #9

That’s very odd if you’re saying the files are there.

Have you tried re-downloading the release?

also have you tried restarting your computer? computers tend to act weird if they haven’t been restarted in a while…


(Jose Moreno) #10

@Shyguy128 a few people in the past have had the same issue. The way to solve it is unblocking the zip file.

I’ll also clarify as well. Even though windows “blocks” these ZIP files, many “signed” files do get through it’s filter, but Qt5 dynamic libraries are normally blocked because those are compiled from the developer’s computer even though they use the Qt framework which is “safe” by Windows standards.

If you want deeper technical reasons we’d have to ask a developer, but I’m afraid I can’t do much more to help in this front and would have to prompt you to get a different animation software so you can continue your animation journey without further delay while this is solved.

We have a blog post with a few other solutions that might help you out as well in your animation endeavors :slightly_smiling_face:

http://pencil2d-software.tumblr.com/post/145767476221/when-youve-worked-all-day-on-your-animation