Camera Layer Movement

Not sure if this is a bug, or a setting I’m not aware of. When I set up camera layer keyframes, the image jumps from one keyframe to the next - it doesn’t move gradually as you scroll across the keyframes in between - manually or on playback. It stays in the first position (1), and when you get to the next camera layer keyframe (12), it jumps to that position - but it doesn’t move at all in the frames in between. I’ve done this a bunch of different ways - with images, and with simple drawings - nothing seems to work. I’m hoping it’s a setting of some kind, but I can’t figure out which one. Every video online shows examples of this working well, so I haven’t been able to find anything helpful. Any thoughts anyone has are welcome, and very much appreciated! Thanks!

Yeah I saw this too. My thread got a reply and basically said that this is a known bug.

That link also has a directory for a new beta version which should address the issue.
They say they hope to have it fixed next release.

1 Like

@mdewaters Hi, it’s as checklistanimations mentioned. This is a known issue that seems to have been fixed in the recent development versions. I replied to the thread they posted, so check out my answer there and see if the nightly build fixes the issue for you. If it doesn’t please let me know in this thread so I can keep track of it and notify the developers.

Thanks to you both! I did download the nightly build, and it still doesn’t work. However, I did export it as a movie, and it worked okay. James said that his worked at first, and then didn’t after editing. Mine doesn’t work at any point. Main thing for me is, I’m new to pencil2d, so - making the distinction between a glitch and something I’m not doing right is super important. And this does seem like a gigantically important tool to not be working. Not clear from your posts if this is happening to everyone, or just some? Either way - appreciate both of you responding - very helpful! Many thanks! I’ll keep my eyes out for anything new here.

@mdewaters Hi. Is it possible that you can record a screencast video to showcase exactly how it doesn’t work? I may be misunderstanding your issue, but camera interpolation should be working in the editor (I just tested with a simple camera pan). That said, indeed even in the release version exporting does work, it’s just the preview that got messed up :thinking:

Just checking but if you right click the camera layer frames do you get a pop-up menu? If not then it’s probably not the correct nightly build. Make sure you downloaded the latest one which should have this format pencil2d-[OperatingSystemName]64-#-2021-07-15.zip

On the other hand the way the camera is getting handled will change as well, hopefully in the next version or the one after that we will be able to transform the camera with the move tool instead of the hand tool, and a whole new set of features will come with it as well.

@checklistanimations I’d like to ask you as well to record a video on your exact problem as well just to be sure and post it back to the original thread you opened as well.

Thanks in advance.

p.s. You can use OBS to record a screencast easily https://obsproject.com/ and then you can upload that so we can take a look.

Hey, guys - thanks again! Trying to attach the screen capture video, but I’m only able to convert to mp4, which this site will not accept. Thoughts? Is there somehwere else I can upload it? Also, I have v. 0.6.6. I don’t see any versions that are more current - let me know if I should look for that somewhere. Thanks!

@mdewaters Hey. You could try to upload it to imgur, youtube or streamable.com if it’s short enough. Otherwise If you ZIP the mp4 file it should accept it I believe.

Won’t accept zip files, either. And Imgur wouldn’t take it, but streamable did. Thanks for the tip! Hopefully this will work. https://streamable.com/mcwg0v

1 Like

@mdewaters I made this video to showcase the fix, how to download the correct nightly build and how to check if you’re using the correct version to test if this fix works for you or not. Take your time and let me know in case there’s more troubleshooting that we can do afterwards :slightly_smiling_face:

That worked! Thank you so much for taking the time to walk me through all of this. Really appreciate it!

1 Like

Sorry - one more question. One other thing that doesn’t seem to work for me. Hope I explained it right - here’s the video. 2021-07-17 17-51-43 Thank you!!

@mdewaters Hi Mark. Well I did the best I could to make this as concise as possible but unfortunately i had to re record several times due to some hardware issues and it ended up still being a bit long. You can play the video at 1.5 speed in YT so it’s more bearable. Also the sound might be a bit loud, as I was in a rush, which I apologize in advance.

The main issue related to the transform and how the control points work is finished in minute 11:00, it’s a thorough explanation of how to achieve what you want. Afterwards I also left some information regarding how other tools work (or when they just don’t :sweat_smile: ) to avoid potential sources of frustration.

I hope this is helpful overall, but do know that currently the vector engine is broken and we recommend for every user’s sake not to use it without being fully prepared to find issued.

The engine will be certainly fixed in the future after the raster engine enhancement is fully finished, but not before.

You are so awesome - thank you for this very thorough and helpful explanation! I am a bit confused as to why the guy in this video can just click on things in the vector layer and move them, without using the selection tool. You’ll see him do this at around 2:20. But - hey, if he’s able to do it, good for him, right?!

1 Like

I did try posting a response, but it was flagged as spam/hidden. I do believe it furthered the discussion, but - I don’t know how to move beyond that being flagged part. Apologies if we’re not able to communicate further. Thanks for all of your help!

@mdewaters Sorry that this happened, the spam system is automated and AFAIK it detects links that are embedded into text :sweat: IT also seems new users have a threshold of how many youtube / streamable links they can post within certain time. I was not aware of this either so i’ll look into it with the webmaster at a later time,

We used to have to deal with unscrupulous spammers, and had to put up with it for years. If you leave the youtube link directly it should embed it automatically and it won’t trigger the spam bot.

To answer your question, as I mentioned in the video this behaviour got changed recently it seems. I was honestly not aware of it until today. I personally don’t like it so once we got into the stage where the vector engine gets fixes rights I’ll be very vocal about this.

Other users have mentioned it should even work like that for bitmap layers (using only the move tool to create selections) so there’s a lot to discuss to improve UI and UX in the future for this app.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.

Imprint