Bug with pressure sensitivity


#1

So I use a surface go and pencil 2d (64) v 0.62 and none of the pressure work the way it should on any of the tools.
I made sure I had the best driver for my surface, I have the most recent version of pencil I could find and I’ve tried all the other usual things (resetting pc, deleting and re-installing pencil .etc)
is there a way to solve this issue?


(Jose Moreno) #2

@Oddittee Unfortunately there is indeed issues with “Surface” computers. The bug exists in the tools that Pencil2D uses to build the software. Other apps have addressed this by doing manual implementations but the Pencil2D team hasn’t been able to do this.

Try using the latest dev version to see if your problem is fixed. Below are the direct links for the respective OS builds:
Windows (7+ [x64]) : https://drive.google.com/open?id=1juDKIkv1F8fuNruGBwauA_y-7UNWibis
macOS (10.11+): https://drive.google.com/open?id=1l-Uv8LWVGHfI95dmZq2PUMOUn7s2JlpN
Linux : https://drive.google.com/open?id=1ZdDvZx_MC3yq5nMDXI0npCC0iA03l_nV

If this does not work please comment back to let us know and for now I’m afraid I’ll have to provide you with a list of alternate animation software you could try that might work better with a Surface computer.

http://pencil2d-software.tumblr.com/post/145767476221/when-youve-worked-all-day-on-your-animation


#3

yeah i was afraid of it being unfixable: i tried the latest version and it didn’t work either. from the list you gave me I already have Krita installed, however I really wanted pencil to work because while Krita has pressure sensitivity, the frame rate is no where near as accurate as that of pencil 2d. I will look into some of the other provided softwares but if there ever is a patch to fix this problem I will jump straight back to pencil 2d


(Jose Moreno) #4

@Oddittee It’s not like this won’t be fixed, but since we’re just volunteers, it will take time and I don’t want to lie to you by saying things will get better soon because I honestly have no idea when this could be addressed for the better. If anything hopefully we can tackle tablet support by the third quarter of 2019, or beg other bigger projects to helps us :stuck_out_tongue: