Audio not playing the second time

I’m trying to import music into my file and it works fine the first time I play it but when I try to play it a second time it mutes, even though the icon shows that its not muted. also no activity on the sound mixer. I’ve already tried turning the music into a WAV file but that does not seem to work.

When I close and open the file the music plays for the first time but just like above, trying it another time does not work

heres a link for the file itself if it helps here

@Puga Hi. Please make sure you are using the latest version of the software v0.6.6, any version below this one will not have several of the most recent fixes made to improve the sound playback and former issues. I personally can play the entire song thrice without problem.

I mention the update because you also described having to convert the file to WAV. In the latest version this is done under the hood by Pencil2D, so regardless of audio file you will always get to use WAV internally, however in previous versions the sound file was used “as-is” and some MP3’s have playback issues due to incompatible codec patent licensing with the multimedia plugin (FFMPEG).

Another reason this could be happening is due to your computer hardware specs. It is necessary to have a decent CPU and RAM size in order to have near uninterrupted playback, and that is true for any software.

Additionally, playback in the Pencil2D editor is not always of the final speed of your animation in relation with the audio. Depending on your hardware the software can lag a bit more or a bit less, but if you have plenty of layers and frames it will always lag and your audio perception will be thrown off. In this case we recommend to always export a preview movie or use the audio scrubbing feature to accurately know where the audio is inrelation to a particular frame position.

:warning: Now, looking at your file I see all your frames are empty, this is a red flag that you’re using an older version and you should update ASAP.

If by any means you still have the file open and you still see the drawings, DO NOT CLOSE THE PROGRAM, and I beg you please save an additional copy of the file as well as export a sequence of still images with PNG format and transparency enabled to have a hard copy of the drawings. Afterwards please follow our recovery guide to have a chance to get your drawings back in case they are missing from the new file you saved apart.

Note: also consider making a habit of saving separate files by number according to your milestones, never ever save over the same file for a long period of time, this is advice for any software not just Pencil2D

@JoseMoreno covered the important things. It does indeed look like you could be using a very old version and you should update asap. Just to add here for anyone else looking at this who has a similar issue, sound playback currently may not work a second time if you use the “Jump to start” button while playing back a sound that starts on the first frame. This is a known issue and will be fixed eventually.

1 Like

Alright, I downloaded the version above but still having the issue. It might be just a RAM problem which i’ll have to work around but if you could still inspect if my new file is up to date. when I used the newer one It did not see a difference to my supposedly older version Heres the file

also forgot to mention it previously but there are purposefully no frames, ive been wanting to create an animatic but for that I’d like my continous sound

Thank you for all the help and advice you’ve done :)

@Puga Hey. Sorry to hear that :pensive:

I downloaded the version above but still having the issue

Hmm that’s the thing, I downloaded the first file and I could play it on loop consistently on the same download version I mentioned :confused:

Perhaps as scribblemaniac suggested above have you been using the “jump to start” button during playback to go to the first frame? Indeed if you do this the sound will not come out the second time, but this is the only case (so far) that we know about and it’s on the bugfix list already :thinking:

I downloaded the new ghosting wip file and I left it play around 10 times with the loop button enabled but it worked properly like an audio player would, so I don’t really know what could be happening on your end to be honest :confounded:

also forgot to mention it previously but there are purposefully no frames, ive been wanting to create an animatic but for that I’d like my continous sound

Yeah by default you get only 1 frame container at the start. Imagine you get a paper sheet or film sound track for free to start with, then you have to add only what you need, no need to repeat the frames as this is done automatically by the program until the exposure (how long the frame is shown over time) hits the next (key)frame container.

Sounds are specially loaded into their own frame containers. So one sound = one container which adapts to the length of the actual wave form. When I open your files I see the single OST in a continuous frame laid out properly, are you not seeing this? or do you need something else to occur?

FYI You can have multiple sound frames in a single layer, or create multiple sound layers to overlap sounds, however currently there’s a limitation where Pencil2D can only export up to 64 sounds, or else there will be an error, but even with this limitation lifted we always recommend to add the sound work to a video editor, and use the sound layers for dialogue and specific sound cues in case you’re animation to music or particular sfx.

I somehow the container does not exapnd, its only stuck to one frame image and when I press the jump to start button the music cuts out again

@Puga Oof, okay at least now I can see how to troubleshoot the problem.

Let’s do a few things before that:

  1. Please send me a PM with a link to the sound file you’re using so I can test that on my own. If there’s a chance the problem is actually with the file I’ll learn of it once I try it out.
  2. Go to the topbar menu > Help > About > Press the Copy to Clipboard button and immediately on your next post press CTRL + V to paste the contents of the notice. This will tell us general information the devs will need to know about your computer. Please make sure to use that button, don’t just type what you think it’s relevant.
  3. I know this might be excessive but make sure to read the sound import guide on this forum and try the different methods outlined there to bring sounds [Guide] How to import sound into Pencil2D I have the lingering feeling that without realizing you could be using a different method than what you’re supposed to, so please look at the guide as a way to troubleshoot import methods.

    Of course even if you succeed importing the file after this, please make sure to finish and share steps 1 & 2 with us so it can helps us find the root issue and hopefully improve the app for future versions.

Edit: Sorry I forgot to say that on the new version it’s important to thoroughly delete the single sound frame before trying to import again, particularly if you tried to import the sound in a previous version. You should even try deleting the sound layer just in case, that way the new improvements on sound import should kick in.

sorry for the late reply heres the clipboard info:


Version: 0.6.6

commit: ac415788dfb21f66e1cbcc1ad60443225a2d0e37 date: 2021-02-17_13:03:37

Operating System: Windows 10 (10.0) CPU Architecture: x86_64 Qt Version: 5.12.10


also Im really not sure how it could help but it may just be a problem on my device, I tried it on my laptop and it worked just fine. the sound was completly normal without muting itself image a a Ill also put the clipboard info of that laptop:


You sent Today at 20:04

punch.pclx

You sent Today at 20:43

Version: 0.6.6 commit: ac415788dfb21f66e1cbcc1ad60443225a2d0e37 date: 2021-02-17_13:03:37 Operating System: Windows 10 (10.0) CPU Architecture: x86_64 Qt Version: 5.12.10


1 Like

@Puga Thank you for all the info! it does help to focus on potential solutions, Unfortunately when I open the file I can also see and hear the sound and by looking at both hardware specs you shared, there is indeed a possibility for your desktop computer to be missing key windows files used to decode sounds.

By any chance have you upgraded Windows 10 recently? mine is asking to upgrade to version 20H2 from 1909, but I’m refusing until the last minute since it’s kind of new and it’s known that sometimes Windows 10 upgrades can damage sound drivers or even remove files (if you’re unlucky enough)

For now in the desktop computer i’ll ask you to try re-importing the sounds that are not working using the current version and follow the guide I mentioned, however make sure to completely delete the layer first, then save the file so it gets overwritten, close the app and reopen the file, then create a new sound layer and import the file again.

If that doesn’t work, then it may be a Windows 10 issue specific to your device, perhaps the sound card or sound chipset drivers are not working properly for the type of sound decoding (mp3 + wav), but unfortunately I don’t think we have the ability to troubleshoot that issue as we are since it seems it’s not really a Pencil2D issue, but rather a Windows 10 device-specific issue.

That said, please test this first and later I will also ask you to try other software with similar qualities and if you can import sound over there, there might be a chance to find an alternative workaround or fix to your current issue.

alright and thanks once again for the amount of detail in your responses. Stay safe and healthy :smiley:

1 Like

Okay I got it to work finally :) Im not sure exactly what was changed/fixed but I downloaded this Codec pack

@Puga Ah that’s interesting, so you were missing a particular codec then. Thank you for letting us know!

Hmm I’ll take a look at that package as it may be useful to know specifically which sound codec was required. Incidentally what was the version of the package that you downloaed? basic, standard or full?

@Puga FYI, be mindful that the official download site for k-lite codecs is this one Download K-Lite Codec Pack so any other site might contain potential unwanted software, so it’s good to be cautious about it.

I have not used this codec package in years since I normally have to install other design software for my job that brings generic codecs for audio and video, so knowing which specific package you got would allow us to zone in which specific codec you were missing. Either thanks again for the info!

Imprint