VLC is unable to open the MRL

Hey all, I’m working on my first animation in Pencil2D, and it’s pretty great so far. Only problem is, once I’ve exported and saved my file as an .MP4, I get the VLC error in the subject. I’ve done the basic troubleshooting on VLC’s end, and even tried opening it with Windows Media Player (different error, still unable to play it), so I can only assume it’s the way I’m saving it in P2D. Below’s how I’m doing it, am I doing something wrong? PS is there a way to not loop an .MP4 lol

Welcome @Lexenos,

When you save your file you should do it in the *.pclx format, which is Pencil2Ds own file format. Exporting to mp4, is when you want your animation as a video, so you can watch it, edit it and so forth.

The mp4 should be playable by VLC.

Did you save your animation to *.pclx?

Hello @davidlamhauge! Thank you for responding so quickly.

I did both. After saving as a .pclx, I opened the .pclx back up in P2D, then proceeded to export from there.

Fine! So, I assume your animation is ok and safe.

The export settings looks ok to me. I never personally have the loop checkbox checked, since I animate one scene/shot at a time, and edit it in kdenlive (linux).

I have never experienced problems with VLC being unable to play a mp4 from Pencil2D. If it remains a problem, somebody wiser than me should come to the rescue :wink:

Maybe you should try our Discord channel. There are people 'round the clock, https://discordapp.com/invite/8FxdV2g

1 Like

@Lexenos Hi. The loop checkbox is only enabled for APNG file types, it doesn’t weigh in for video files, but just to try that out, simply select the APNG filetype when using the [Browse] button. Then uncheck the “loop” checkbox, go back and change the filetype to MP4 and report back.

I personally think the problem here might be actually that you’re using a non standard resolution, which is neither 4:3 nor 16:9 which MP4 H264 codecs sometimes have trouble rendering (and VLC / WMP might have trouble playing too, though this is rare). Also the pixel aspect ratio might be affected by the strange resolution as well.

Just to test the latter please change your camera layer size to 960 x 540 (just NOT change the export size on the window options or else your file will become distorted) and try to export the MP4 again.

If it works let us know as well as this could be investigated as a bug. If it doesn’t work them please upload your PCLX file to wetransfer.com or google drive and share us an anonymous link so we can test the file export. I have Windows 10 so it should be a similar environment.

1 Like

@Lexenos Just to be very thorough here’s a guide to specifically fix the VLC MRL problem with various potential solutions. To be honest in my entire life i’ve never had such an issue, but it seems this can occur if you’re trying to playback the video off a local server or a computer connected remotely, so make sure to also take a look at this to cover all your bases (granted this has nothing to do with Pencil2D, but I hope it helps)

OH MAN THAT WAS IT! I switched the resolution and that fixed it immediately!

1 Like

@Lexenos I’m glad that worked for you. If you have any other issue we can help with let us know and we’ll try to assist you as soon as possible. Cheers! :smile:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.

Imprint