Video won't export, on 10-28-17 nightly build

The faq says that “Update July 21st 2017: Pencil2D developers have already implemented video export among many other fixes, if you are using a legacy version of pencil (v0.44b) or Pencil2D (0.5.4) we URGE you to download one of the latest versions on displayed on our front page.” I have the latest version, and video export continues to not work. It seems like that the export is working, but then the file just doesn’t show up in the folder. Spent a ton of time on an animation, so I was hoping I could find help here.

Also, I’ve tried image sequence export, but when compiling them in movie maker it says many of the images are corrupted.

@casper Hi sorry to hear you’re having issues. Before trying anything else please make a backup copy of your pencil2D file on a different folder, just to avoid corruption if there’s a fragmentation issue happening.

Developers are currently fixing stuff within Pencil2D. These versions are development versions so they are prone to break and get fixed often.

I just tested the version for today, October 29th, and it exports my mp4 with sound correctly, however right now there’s only a Windows (32+64bits) version. Due to the service that Pencil2D uses to automatically compile the code, it’s possible that this week there will be an update for MAC and Linux systems.

However if you don’t have windows or the version from today doesn’t work for you, Please use September 22nd (windows) or September 23rd (MAC / Linux) version to export your video. This is the version that was considered a “Release Candidate” which has up to 98% of the stuff working (camera motion was implemented there but wasn’t working as fine as on the newer versions, so avoid using it there when exporting your video).

MAC OSX (10.9 or above):
Linux (appimage):

If you have an issue with either of these versions (sep / oct), then we might need to ask you to let us know which operating system you are using as there might be an OS specific issue happening.

Please let us know if you manage to export your video.

Hi @casper,

Could you tell us what OS are you using? Are you using Win10 or a Mac?
Would you like to share your animation with us so that we can take a look at it?

I’m using Windows 10. I downloaded the latest build, and it still doesn’t work. Also, I’m not sure if it matters, but my animation is 2667 frames. I’ve tried removing the sound layer, using a different camera layer, etc. I was able to find another post that pretty much describes my experience:

@casper I’m not even kidding, please make a backup copy of your file soon. In the past people have had issues since files with such amount of frames require MASSIVE amounts of RAM to function. The problem is that we’ve had reports where such files with more than mere 400 frames or so have been wiped clean after crashing. So please, do a backup copy ASAP and store it on a USB or something. Terribly serious here.

Now there are a few things that come to mind that might help to shed light or even solve the issue. So please attempt the following:

  1. When you download the builds, normally, even for users with administrator rights, Windows does a fantastic job at blocking (uselessly) anything that has been downloaded from the web. So please make sure that you unblock the ZIP file containing the Pencil2D version because this might be stopping ffmpeg.exe from unpacking along with other required components.

To unblock the Pencil2D zip file simply right click on it > go to properties > on the properties dialog general tab go to the bottom and you should see the “unblock” or “unlock” button.

  1. If the previous didn’t work go to your Pencil2D folder and right click on Pencil2D.exe > Properties > compatibility tab > run as administrator.

Do the same for the FFMPEG.exe file in the plugins folder.

  1. Try an “older” version. Something like July 19th 2017 version. This would be just for testing purposes as this build wouldn’t have enough up to date stuff like the sound layer fixes and all that, but I know due to massive testing that the movie export works.

  2. it is possible the RAM “quota” needed for the export operation is simply not being met. So one solution is to split the file and create enough additional copies to segment animation. This might be tedious, but think of it as a last resort kind of thing.

@chchwy Have you seen reports on similar problems with Windows10? Is this a compatibility problem? Or perhaps an optimization issue?

That’s why i’m asking the animation file. Too few clues to replicate this issue since the video exporting is working fine recently.

Video exporting isn’t a memory consuming task, so if the animation itself goes ok, and then it should not be a problem to export it.