Tool Reset when Pasting, Duplicating, etc

investigate

(Jose Moreno) #1
"Hey Guys, great tool! I was just getting comfortable when I noticed the “Duplicate Frame” button or Pasting resets the tool to the move tool. Is this a known issue? I couldn’t find anyone else having the same problem. For every frame I would have to switch back to pen and resize it. Am I missing something? Thanks again!!! GReg"

@gregoryshmegory Hi I apologize for taking so much time to answer your update, it’s difficult to see anything when you just update your profile page with comments, instead of creating new threads that address the issue at hand.

I believe this is a known issue, but it’s more of a design flaw than a bug itself. That when you do any kind of the mentioned operations the current tool resets to the move tool (black arrow).

If you’re willing to help please report this behaviour to our github so a developer can try to fix it eventually, if you don’t want to or can’t do it, we will investigate and report accordingly, just not immediately since we’re lacking human resources.

Thank you for your time and take care.


(Jose Moreno) #2

This has been solved. The described behavior no longer exists so when duplicating or copy pasting a drawing the currently selected tool stays the same.

Please If anyone continues to have issues with this use the nightly builds which are always publicly available at https://www.pencil2d.org/download/#nightlybuild

Here’s a direct link to the latest ones for each major system:

I’m closing this issue as solved.


(Jose Moreno) closed #3