Timeline Navigation: Maybe a bug?

I have noticed that in the recent build (Aug. 31, 2017), there seems to be a problem with navigating the keyframes using the arrow keys(left/right). Basically, using the left and right keys we can go forward or backward on the timeline on the selected layer. But if I use the play button above the timeline to play my animation, stop it, and immediately start to navigate between the keyframes use the left/right arrow keys, it would instead highlight or move around the “play” button. Like it will start moving around the “play” button and not on the timeline itself.

Most likely the timeline gets deselected when clicking on the ‘play’ button or any other around the same bar. There are two solutions for this behaviour that I have discovered, first is to use the shortcut key “Enter/Return” to play the animation rather than clicking on the play button. Second is that in case you do click on the play button, just click on the “workspace” area once, I just do a random scribble and undo, and the timeline gets selected again.

Clicking on the timeline itself doesn’t work. Most likely this could be a known bug, I am not sure, but just wanted to highlight the issue.

@sumit_makwana Thanks man, will look into it as well.

@CandyFace Opinions on this report? I haven’t tested, but when I can I’ll get to you both.

@morr I haven’t been able to reproduce this behaviour yet, everything seems to work fine. I’ve tried to provoke the scrubber by being a little bit aggressive on the play/stop button and immediately move with arrow keys, but I can’t seem to reproduce this whatsoever.

@sumit_makwana can you upload a video of the bug and specific steps how to reproduce this?

@morr @candyface

made a video

Thanks for the video!

@morr can you reproduce this behaviour?

I’ve tried numerous of things to provoke this behaviour but the scrubber always gets the focus again. The only way for me to select a button like shown in the video, is by pressing TAB. I wonder if it’s a bug for the individual style that changes between platforms.

@CandyFace @sumit_makwana Got it on my first try, must be a Windows issue. I’m using the 64bits version. And tested it on the version from today (Sep 8)

When I click any button from the interface it becomes “selected” or a more appropiate word is “focused” so no matter what using the arrow keys will navigate on the panel, however if you press tab you can go to other panels. It went from timeline to Color Wheel > Color Palette > Display > Options Panel > Tools Panel > Timeline

Once I got through all the panels using TAB I got again to the timeline and the playback indicator was working again.

While using tab it would jump randomly from one tool to the other, not respecting visual order. Maybe each tool button index is jumbled?

It also seems that the playback is considered a button or an indexed “focus-able” element. So it’s why this might be happening. That’s my take on it, but most definitely a Windows-prone issue.

Might be confusing for users to have this happening, although it’s pretty cool to be able to browse all the panels just using the keyboard. Maybe we have to think about how keyboard shortcuts affect “focused” panels, similar to Toonboom or TVPaint.

For Sumit, when this happens to you just press Shift+Tab a couple of times to go in reverse order meanwhile there’s a way to solve the issue.

@CandyFace @sumit_makwana Also you can press CTRL + Enter to playback the animation without using the play button :wink:

CTRL + L will activate the LOOP button

Also using the period (.) and comma (,) keys will do the same as the arrow keys even if you click on the buttons and get them “focused”, just like flash lol. It’s like those are the timeline specific shortcuts for moving between frames.

Now that I think of it, this issue might not be a bug, but a rather annoying behaviour anyone can encounter.

@morr @candyface Thanks for looking into it. Even I thought that this could either be a bug or something else. Hence the title. Using the short cut keys for using the Play and Loop is the only way to avoid the “focus”. And indeed the period(.) and comma(,) keys work even after it gets focused.

Thank you.