Technical stuff

Hi @chchwy,
Could you tell us more about how you develop your fork ?

I know web languages (php,javascript,actionscript,etc) but never did try things like C++ & Qt.

How does it work ? I did install Qt and manage to open the Pencil project in it.
I dig a little in it but it seems hard to understand.

  • : is it still Qt3 ?
    The first thing to do would not be to port Pencil to Qt5 ?

I’m open to any technical information !

We use Qt 4.8.4 due to the WACOM tablet support issue

Qt5 has problem to get the pen pressure.

Ok. Maybe that’s why, when I tested to open the sources with Qt5, it told me that there were errors with Phonon ? It still is included in Qt4 maybe ?

The Phonon framework seems not to be included at Qt 5 (Qt and Key Technologies) (source)
This is a question : will it be more work for you to wait until this bug is corrected and update Qt; or to disable pressure for the moment and reactivate it at the time it works again ?

Let’s wait. Qt4.8.4 is stable

and it seems only little benefit for pencil to porting to Qt5.

Hi again!

I solved the phonon issue switching to qt 4.8.4 libraries but now, I have another problem:

:-1: error: No rule to make target ‘…/pencil/’, needed by ‘Makefile’. Stop.


  1. Any chance to solve it? (I’m new to QT Creator and its libraries)
    2: I cloned chchwy with tortoiseHg, the last revision is 307, am I working correctly? It’s the first time I use it you know…

Thanks Matt!

Hi Cirus,

Q1: Could you tell what platform did you use? Windows or OS X ? Which C++ compiler did you use?

Q2: Yes, that’s correct. Did you use git or hg before?

Sorry for my late reply!

I trapped the “out of boundrect” problem and it’s not a compiler nor code bug!

I’m testing pencil on windows XP (sorry for this :slight_smile: ) with Waccom Bamboo One. Compared to my panoramic screen the tablet is so small that, in order to avoid a huge rescaling, I’m using the tablet in relative mode (also called mouse mode).

Photoshop works fine in mouse/relative mode, pen pressure is correctly applied and pixel ratio is barely distorted but I noticed that in Krita, MyPaint, and most of the “pythoned” open source apps, relative mode isn’t working.

Let me explain what I think: There are really 2 coordinate systems you can work with, from the OS windows events or from the tablet driver. When a Windows XP user configs the tablet in absolute mode, the OS cursor updates by moving to the pen’s coordinates while in relative mode (or mouse mode), the OS cursor updates itself by adding the increments of the pen’s coordinates (or relative movements).

A solution I tested in another application was to use the standard event coordinates of the OS and all the other events from the tablet event packets (pressure, area, buttons, etc), and it worked; though I think in the case of QT it’s far more difficult.

In our case(pencil), it seems like the drawing coords are correct and the button coords are erroneous, hmmm, perhaps QT is using tablet absolute coordinates in the tool buttons panel?!?!

Hope this helped you.

Great work, Matt!

Reply to Q1:

windows XP Professional XBased/32 bit SP3
(I can test on 64bits if needed: XP and Linux)
QT is 4.8.4
GCC 4.8.0 from MingW
CMake 2.8

Q2: No, I didn’t. I’m using repositories for the first time in my life, sorry.
I have turtoiseHg and GitHub installed and I’m a bit confused about the best way of working. I guess I must create a fork, then push updates but I don’t know exactly how.

Working fine:

  1. The coordinates are ok with tablet in absolute coord mode.
  2. The raster brush is painting fast and accurate, bravo; I see no real need to include MyPaint brush engine, by now.
  3. The shortcuts are helping a lot.

Not responding as expected on Windows XP:

  1. Enter/Intro key is not adding a frame but playing the animation.
  2. When the tools are selected using shortcuts, the corresponding icon is correctly selected(down) but the new mode remain unchanged (the graphic cursor doesn’t change nor the tracings nor the option panel)

Good detective work, Cirus!

I’ll try relative mode with my Bamboo fun.


Here is a quick guide, it may be helpful.,+Compare+Code,+and+Create+a+Pull+Request


Your “Not responding as expected on Windows XP” issue #2 is the “Issue #17” on Matts´s repositories (here):

You are helping all of us. Thanks

Is there a way to disable soundlayer/phonon on compile alltogether? I uncomment it in the pro file and still no luck. This phonon compile bug is a showstopper