''Sound'' Crash

When I import sound, all it does is crash the whole program. I dont know why?

@zostiel Hi Brittany. Which version are you using? The download version you find in the page does not have sound capabilities enabled. Only recently this feature was implemented. If you’d like to try it out you can download it here:


I tried downloading the latest version, and it crashed once I clicked on it to open. I tried downloading an older version but that doesn’t work either since it’s telling me that I should see if it works on my latest version of Mac OS X. (I use snow leopard currently 10.6.8)
Can yall see if you guys can fix this?

@zostiel Hi, sorry I took so long to answer. I’ve been busy with my day job. This is deffinitely weird and I’ll see through to report this on our github, however this might take a long time to be fixed. So if you’re on a hurry to animate or finish a project I encourage you to seek for another software meanwhile since I’m afraid we can’t promise this will get fixed “soon” and I’d rather have you guys being happy than getting frustrated over the program.

Here’s a list we posted on our tumblr for possible alternatives to Pencil2D:

@chchwy If you’re looking about fixing MAC OSX issues, here’s one. Apparently there’s a compatibility issue with snow leopard, but we don’t have enough info. Is there a way that we can guide the user to send us Pencil2D crash log?

Unfortunately, Snow Leopard in no longer supported in latest Qt. (I use Qt5.7 for nightly build)

I am downloading Qt5.3 right now, the last version officially support snow leopard, and give it a try.