some question about camera layer and timeline


I just tried Pencil (the june nighty build) and I have a few question

First, is the camera layer seems to be just about ratio it doesn’t make you the desired size frame.

It seems weird… but well I’ve import a bordered image into another bipmap layer and it works fine.


But most important is How to move a keyframe? didnt find for this one…

Documentation > Adjusting keys

To test and improve your animation you can change the timing of keys. Click to select one key in the timeline and drag it where you want. To select several keys, use the hold the SHIFT key. Often you will want to extend the time between two keys, which implies moving all the subsequent keys. To do that, hold the ALT key and click the second key; this will automatically select all the subsequent keys.

Thanks for the doc, thats the first thing I tried.


I just download the 05.4 and it work fine with this one but the interface button doesnt respond with my tablet…

Double-click the camera layer name to open an input box where you can change the layer name and the size of the camera. There might be an issue if you try to use non-standard dimensions, but i haven’t looked into that.

Note that when rendering, Pencil2D uses the size of whatever camera layer is selected. If you have a non-camera layer selected, the viewport size is used.

Yes but the camera doesnt follow the zoom of the animation, but the pixel on my screen. If I zoom or unzoom its always the same rectangle I see on the screen.

What I wanted was like a sheet of paper which I can see the size and border so I can compose the image.

Oh, yeah…zooming and panning in Pencil confuses me…i’m not sure if it actually works exactly the way it’s intended, or should…i don’t really know. sorry.


@sharkylover101 Hi Erin, don’t worry. First try to go to the menu View > Reset Windows.

If this doesn’t work it may be that your panel was hidden, so in order to visualize the timeline again press CTRL + 6 on your keyboard, or go to the menu Windows > Timeline and make sure the option has a checkmark ticked over it.

If nothing works please make sure you are using the latest version for Pencil2D which you can download here for your appropriate Operating System:

Take care.