Some glitch with flash files

(Runnings Mac os x)I was trying to load a .fla file due to Adobe flash 7 Just can’t open it When I clicked on the fla file pressed open with pencil 2d and I got thisi t might be a log I don’t know and I replaced my username with something fake Raw file path: /Users/stuff you should not know about/Desktop/grass.fla

Resolved file path: /Users/stuff you should not know about/Desktop/grass.fla

File name: /Users/stuff you should not know about/Desktop/grass.fla

Is old format: true

Recognized Old Pencil File Format (*.pcl) ! (but it is a fla)

XML file: /Users/stuff you should not know about/Desktop/grass.fla

Data folder: /Users/stuff you should not know about/Desktop/grass.fla.data

Working folder: /var/folders/nx/gmblq6557jx32g3722951cf00000gn/T/Pencil2D/grass_Y2xD_cw4c7spk/

Error parsing or opening the main XML file

System Info

Pencil version: 0.6.4 (stable)

Build ABI: x86_64-little_endian-lp64

Kernel: darwin, 15.6.0

Operating System: OS X El Capitan (10.11)

end

You can’t open .fla files in Pencil2D. You should use the dedicated Flash software for that. Also, the “glitch” happens for all files that are not .pcl or .pclx files on Pencil2D.

(Thanks for telling me) I tried pencil 2d due to flash (Verison 7.0 owned by macormedia) when ever I tried opening the fla files would say unexpected file format So I tried pencil 2d now knowing it does not work I won’t ask such a dumb post again

@ShortandSimple Well as DoomPro93 mentioned, Pencil2D only opens Pencil2D files (PCLX & PCL)

It is true that older macromedia files are actually XML files under the hood, so you can open them with a zip file manager, but even then the actual vector drawings are binary files that can’t be decrypted so easily (unless you’re a technical wizard of course)

Also Pencil2D vector engine is currently a work in progress. It’s a bit too broken for moderate use, so it would be impossible to import flash vectors directly anyway.

I’ve been thinking of trying to create an exporter from Flash 8 (AS2) and Flash CS6(AS3) to Pencil2D, but this is very time consuming and I could only try to tackle it after Pencil2D vectors are properly implemented, otherwise you’d just be seeing bitmap images.

You can export PNG image sequences from flash, and SWF can be converted to FLV videos by special software with limited success (as long as you don’t use movie clips, but graphic symbols I think they do work)

Anyway, you can try looking at our alternative animation software list to review other alternatives that might be useful to you in the future, but to recover FLA files, we can’t help much i’m afraid:

p.s. I’ve moved the thread to a relevant category as this is not really Pencil2D related

This topic was automatically closed 42 days after the last reply. New replies are no longer allowed.

Imprint