[Solved] Sound files always imported to single frame


#1

Hello,

I’m trying to import sound files to an animation. They always get imported to a single frame, and I can hear no sound when playing the animation. Here’s what I have tried:

First Add Sound Layer.
Then import sound
Locate the file and import.

  • different sound files in *.wav (16bit PCM) and *.mp3 format.
  • the audio files can be play with any other audio program, e.g. vlc
  • Pencil2d versions 0.6.1 and 0.6.2

I’m on Ubuntu 18.04

Does someone have tip how to solve this problem?

Best regards,
Harald


(David Lamhauge) #2

I use Ubuntu 18.04 too, and it works flawlessly here.
If you are on frame 10, and import the sound file, the will be set at frame 10. You can drag it back and forth, but it will be attached to the the one frame. Pencil2D also saves the length of the sound file, so when you play it, the sound should be there.
If sound volume is set high enough, and everything else works, the sound should be there…


(Jose Moreno) #3

@mrtaliman Please use WAV files. MP3 that are downloaded from the web normally tend to be difficult to use because Pencil2D does not open files made with soundforge or certain proprietary sound editors. Use Audacity to convert the MP3 to WAV.

If you can’t import the wav file either then, please upload a zip file with the sound and the PCLX file so we can take a look at it.


#4

Hello, thanks for your answers.
I have tried to import WAV, to no avail. It was recorded with audacity.
The forum does not allow me to upload stuff as I’m a new user, so I’ll upload it to my Google Drive:
https://drive.google.com/open?id=1Y1eu2h4616cHamz3LM5I90ryt8XWY9Cp


(David Lamhauge) #5

@mrtaliman I have downloaded your file and opened sound_test.pclx with the test.wav on my Ubuntu 18.04. It works flawlessly. You snap seven times and say something. There must be something wrong with your headphones, speakers or something else. Maybe @JoseMoreno has other ideas.
Happy hunting!


(scribblemaniac) #6

@mrtaliman The sound is also working in your pclx file for me. Here are some things to try:

  1. Make sure that sound isn’t muted on your computer or in Pencil2D. There is a sound toggle in the timeline, make sure it does not look like this with the red disabled icon: 22%20PM.
  2. There is a known issue with audio playback with the linux AppImages. If you are using these, please try using the apt package with sudo apt install pencil2d. The pencil2d flatpak should work too, but it does not seem to be accessible at the moment.

(Jose Moreno) #7

@mrtaliman Along with what scribblemaniac mentioned here’s a guide on how to use “flatpack” files.

Apparently the install is working only via terminal commands, and this is the address for Pencil2D’s flatpack repo (on the web is not showing up for now but the app instructions exist on their build server)

https://flathub.org/apps/details/org.pencil2d.Pencil2D


#8

OK, so probably I have been doing something wrong. I will try again tonight.
So it is ok if the imported sound shows up as a single frame in the sound layer, as opposed to a triangle play icon seen in some youtube tutorials?


(Jose Moreno) #9

@mrtaliman On the sound layer, the sound file should show in a single container that has the sound and spans many frames (equivalent to as many as the original sound duration). As for the triangle icon…I’m not sure what that means Pencil2D has never shown a triangle icon on the sound layer itself to my knowledge :thinking:

Again, please make use of the flatpack option or the terminal commands that scribblemaniac mentioned as the APPImage file does have issues with certain linux distributions.


#10

I just tried the flatpak version 0.6.2 as suggested by Jose, and here the sound works as expected.

So the problem with sound import seems to be in the 0.6.1 version, which I had installed previously from the ubuntu repository.

Gonna mark this as solved.

Thanks everybody for your help!