[SOLVED] Pen tool leaves an ugly dot at the end of the stroke

which is extremely annoying and makes the tool unusable. Occurs on both vector and bitmap layers

on NB may 20th 2017

@alankalane Yes this is happening to me as well. It worsens when the “stabilization” feature is higher too. I’ll make a report about it soon, I’ve just been a bit busy with my day job. Thanks a lot for reporting.

For now I’m drawing on November 16th build and everything else on the new one, sigh. Let’s hope this can be worked upon rather quick.

@alankalane Forgot to say that it seems because of the speed of the stroke. If you draw the stroke, stop and lift your stylus, there won’t be any dots at the end of the stroke (I’ve double tested this).

I think it’s a problem on how the Wintab wacom driver pressure sensivitiy is being interpreted. Also might have to do with the fact that the pressure sensitivity checkbox is not work for any tool.


I’ve fixed this in: https://github.com/pencil2d/pencil/pull/679
Hopefully it’ll get reviewed and merged soon.