[SOLVED] I can't open any version of pencil2D anymore

It says I’m missing
MSVCP120.dll
MSVCR120.dll
MSVCP120.dll
MSVCR120.dll
In that order, each on a separate message.

It happens on
pencil2d-win32-2017-07-03
pencil2d-win32-2017-07-19
and
pencil2d-win32-2017-07-18

I haven’t tried it on any other versions.
I hadn’t had time to animate anything in a few weeks, and windows sent out at least one update. Does this have something to do with that?

Hi Nicole

That’s because you’re missing a microsoft package. Usually these packages are often installed either by Windows Update, a game or program that depends on it.

You can download the package here:
https://www.microsoft.com/en-GB/download/details.aspx?id=40784

Why you haven’t gotten that error before though, I don’t know but it’s not because of a windows update :slight_smile:

@fuzbrain Hey Nicole, it’s as CandyFace says, this is because you’re missing that particular .dll, it’s actually a very normal problem with Windows OS, these days though usually most games and software install the Visual Studio redistributables packages on the background but it’s weird you don’t have it.

Either way, you can download it from the link that was posted or also windows nightly versions do come with a vcredist_x64 file inside the Pencil2D folder. Check it out and let us know.

Thank you guys! I have no idea what happened to my computer but Pencil2D is working, thank you :3

@fuzbrain Glad to hear it’s working now. If you have any other issue let us know :slight_smile:

Imprint