[SOLVED] I can't open any saved animations

I am having issues with the November 2nd, 2016 build. Every time I save an animation they won’t open. I only have one animation that will open, and it’s file size is way smaller than all of the other files. Here’s a picture of all of the files:

You can see that the file “wolf howls.pclx” is only about 5000 kb while all of the other files (the animations that wont open) are all about 48000 kb. None of these animations were able to be opened even right after I saved them. Any help would be appreciated.

@pearlcatcher Hi this has happened in the past to another person, I managed to open it with a previous version, however I’m going to ask you to actually try opening any file with the latest build for Pencil2D from May 27 2017

You can download it directly here: https://drive.google.com/open?id=0BxwRs73A_v_aX2JIWmlZbWtHWkE

Before doing anything rash however, please backup your files. Make a few copies so any test won’t damage your files. Just due to the filesize I can tell your work has not been lost, but it may be an issue with how the file has been codified by Pencil2D Nov 2016 build

If attempting to open any of the files with a newer version doesn’t work, and if it’s ok, could you upload any of the files that you can’t open so I can test what is the problem and if possible escalate it to a proper developer so he can fix whatever issue is plaguing your files?.

Also a few questions:

  1. How many frames, approximately, are those animations that won’t open?
  2. Do you have any huge image file on any layer?
  3. Did you import sound on the file?

Thanks for reporting, I’ll be pending confirmation on this to see how I can help further.

I’m not sure how many frames are in the animations, as I believe they were all just tests to see if they would save properly. They would probably be somewhere around 3-5 frames. There is most likely no image files or sound on any of them. Sorry for not being able to answer these questions accurately, it’s been a few months since I saved these.

I am currently downloading the latest build to see if I can open them with that. Thanks for your help! I’ll let you know when I finish trying to open my animations.

I’ve tried opening all of the ones that don’t work and I’m still getting the same error as before. I’ve uploaded one of the files that doesn’t work to Mediafire. I know that Mediafire can be problematic sometimes when it comes to popups, though. I can upload the file to another download hosting site if necessary.

Here’s the link: http://www.mediafire.com/file/6w1e9od6l0bj22c/what.pclx

@pearlcatcher Ok I managed to take a peek at the codified data with my limited knowledge of the filesytem. It seems you did have about 3 or 4 individual songs loaded on different layers.

I can’t open the file with any of my test builds, so considering the sound player was relatively new for the November version maybe the file got corrupted due to the song files being loaded.

If it’s ok with you I’ll report this to the devs and ask the main dev to check this file to see if we can find the cause of the issue, and a fix. I can’t make any promises and I don’t know if it will be possible to recover the file, but at least we can try out every possible solution.

I’ll keep you posted on what happen and I’ll link later to the bug tracker where the request will be posted.

@pearlcatcher Alright, I’ve just reported this issue on the tracker. Hopefully the lead developer will have some time to review the case.

The case report was made here: https://github.com/pencil2d/pencil/issues/682

It might take some time for them to notice, but hopefully things will work out.

For now I can only suggest to try out the latest build that I linked and see if your can save and open normally with it.

As I said before I think the sounds might be the cause of trouble in this particular case.

As for the sound names I managed to see these:
data/cute song.mp3
data/Donut Hole.mp3
data/eery - Her.mp3
data/me me MEME.mp3
data/?Original Meme? KARMA.mp3
data/?VOCALOID Original?ECHO?Gumi English?.wav

It’s possible that the last two had non latin characters (i.e japanese syllabaries or ASCII characters) so if you load new sounds please rename them with latin or alphanumeric characters meanwhile this gets investigated as this may be a possible cause for this issue.

Also it is possible that having too many sound layers might also cause issues. I have yet to confirm this, but remember that Pencil2D will hold only if you have enough RAM memory. Every drawn frame uses a certain amount of memory, and if you add to that having music, it can get bogged down.

Normally in animation production you only have a track for the music, so if you can try to combine all the songs into one single file and load it into Pencil2D. That will at least diminish the amount of loading the program has to do. You can use Audacity, which is free, to do this.

I don’t remember loading any of those sound files all into one animation, but I can recall loading them onto seperate projects or loading them in and deleting them later. I do know that these are all files I have used before, just not in one project.

Thank you for trying to assist me, even if your solutions aren’t working. I really appreciate you taking time out of your day to help me out!

Hi Ashley

@chchwy has fixed your project, you can find it here.

If it still doesn’t work, let us know :slight_smile:

@pearlcatcher Hey! it’s ok. It seems that although the sound files were saved inside the file, the path to them was erased, so they would still be written into the file “checklist”, hence when Pencil2D was trying to read them it didn’t understand because of the non-ascii characters.

Some of the devs answered promptly and indeed it seems like this issue was caused by an encoding issue as I had mentioned before. This means that meanwhile the general issue is fixed, any new files you create should be ok when using the latest version as long as you import files with alphanumeric names.

For now the file that you sent was fixed by the main dev and you can download it here to test it out:

Based on this file and the input from the devs, I managed to devise as well an easy way to recover your other files. Here’s what I did:

  1. If you have winzip you can open the PCLX files as if they were zipped files
  2. You can browse on windows and right click over the PCLX file, look for the Open With… command
  3. Then on the options window that pops look for Winzip
  4. Once opened you should see a “main.xml” file and a “data” folder which contains all the stuff.
  5. Extract the files, delete or rename the sound files from the data folder
  6. Now create a new zip file from the “main.xml” and the data folder
  7. lastly you have to rename the .zip extension to a .pclx extension.

Note you can only do the last step if you have enabled the option to see file extensions on your file browser. To do this you can follow this guide: http://kb.winzip.com/kb/entry/26/

And that’s it, I managed to recover the same file you sent without any hassle, and it opens too with the latest version :slight_smile:

Hope this helps! let me know if you run into other issues.

Thank you so much! I was able to open the files with 7zip to delete the problematic files and now everything is okay. Thanks again for your help!