[SOLVED] Bug on opening an animation

Hi everybody,
I’m using Pencil2D 0.5.4 in my Linux Mint 18 Sarah based on Ubuntu Sid and I have a problem.

I’ve created a little animation with some vector layers, and around 90 frames. Yesterday I created it and today I’ve opened it and all frames are blank.

Let me clarify this. The layers are there, the frames are there, but there is nothing on the screen.
I extracted the content of the PCLX file and the main.xml is there and all the VEC files that seems to have the proper information. But nothing is displayed on the screen.

Also, if I open pencil2d in a terminal there is no error messages on the terminal.

What can I do?
Is there any place where I can upload this animation for you to examine it?


@System25 Hey. First of all welcome to the forum. It pains me to say that you are using an older version of Pencil2D which is prone to crashing. We have discontinued it’s support because of that.

There is a more recent version of Pencil2D which you can download for Linux systems here: http://pencil2d.org/download

Now, regarding your file please upload your pclx file on dropbox, mega.nz, google drive, mediafire or any similar alternative and paste the link here. That way we can be sure that a developer can take a look at it. I’ll tag @chchwy so he can help us out with this as well.

I’m not going to lie to you, the crashing problem with that version was particularly nasty because it would really wipe clean everything, and we tried as much as we could to fix it and leave it behind, but it is highly possible that the animation has been lost.

I know there’s a way to recover the files in windows systems as a last resort. But I don’t know if it can be applied for Linux systems. If you have a temp folder in your OS, Pencil may be creating copy folders that are used when the PCLX is read, but that would be a long shot if the file is not deemed recoverable by him.

In any case Let’s wait for the dev, to assist us further. And from now on please consider saving incremental copies to avoid losing all your work even with newer version of P2D as outlined here: https://www.pencil2d.org/doc/faq.html#pencil-crashed-and-my-files-are-unusable--corrupted

FWIW, on Linux those folders are created in /tmp/Pencil2D IIRC.

1 Like

Hi everybody,
this is the link to download the animation:

@chchwy @JoseMoreno Thank you for your support. I was wondering if there is some way of converting the VEC files into SVG files or something like that. Is something that could be very helpful.

Thank you very much!

@System25 I’m reviewing the file, but even though I’m trying to open it in the older Pencil2D versions, It just won’t show up. And the thing is, the VEC files are just Pencil2D Vector image own files but they are formatted similar to XML, and the data is there (the coordinates too). I’m not a dev but, even to me this is super weird.

Hopefully @chchwy can help us out. I’m asking on discord if anyone could help with a vec to svg converter, but I might have to work on it myself, so no promises there. For now it’s a patience game hehe.

@System25 Hey, just an update another dev helped us look at your file. It seems that due to the locale being from a language different than english (probably spanish like mine) All the floating point numbers are separated by commas instead of periods, so this is causing the program to fail at representing the mathematical coordinates.

So the good news is that your file is recoverable. The not so good news is that it would take some work to change all the files separators.

It should be possible to make a script that changes the commas into periods for each VEC file, however most of us are busy right now with our day jobs and since it’s not a explicit Pencil2D bug i’m afraid is not on a high priority slot, but if you have some patience we might be able to work something out to help you out.

I’m still testing the files as well, so I’ll continue to update the thread until we can have a proper solution :slight_smile:

@System25 Well, in the end @scribblemaniac (another core dev member) was very generous with his time and helped us to recover your file.

Here’s a link to your recovered pencil2d file andthe vector artwork should be showing now :slight_smile: https://drive.google.com/file/d/1F1lmQqSoolyvR4ESvMKOWVukebi1yPUk/view?usp=sharing

He also made a “bash” script available in case you or other people have a similar issues in future projects, note this only work on unix systems as far as I know, but it will solve the vec file problem on operating systems that use the comma as a decimal separator instead of a period.

Thank you very much @JoseMoreno and @scribblemaniac. :+1:

1 Like

You’re welcome. Thanks for sharing your animation files, we likely would never have found the bug causing this issue otherwise!

1 Like