Short Animation Unable to export

So I’ve made a really short animation, which is my first one ever using Pencil2D that consists of only 38 frames and no sound effects. When I tried to export the animation to a movie it showed up a new window which says “Something went wrong”. This is what the description of the problem says. (I use Manjaro Linux by the way.)

Command: /usr/bin/ffmpeg -f rawvideo -pixel_format bgra -video_size 800x600 -framerate 7 -i - -threads 4 -y /home/User/Desktop/untitled ffmpeg version n4.4 Copyright (c) 2000-2021 the FFmpeg developers built with gcc 11.1.0 (GCC) configuration: --prefix=/usr --disable-debug --disable-static --disable-stripping --enable-amf --enable-avisynth --enable-cuda-llvm --enable-lto --enable-fontconfig --enable-gmp --enable-gnutls --enable-gpl --enable-ladspa --enable-libaom --enable-libass --enable-libbluray --enable-libdav1d --enable-libdrm --enable-libfreetype --enable-libfribidi --enable-libgsm --enable-libiec61883 --enable-libjack --enable-libmfx --enable-libmodplug --enable-libmp3lame --enable-libopencore_amrnb --enable-libopencore_amrwb --enable-libopenjpeg --enable-libopus --enable-libpulse --enable-librav1e --enable-librsvg --enable-libsoxr --enable-libspeex --enable-libsrt --enable-libssh --enable-libsvtav1 --enable-libtheora --enable-libv4l2 --enable-libvidstab --enable-libvmaf --enable-libvorbis --enable-libvpx --enable-libwebp --enable-libx264 --enable-libx265 --enable-libxcb --enable-libxml2 --enable-libxvid --enable-libzimg --enable-nvdec --enable-nvenc --enable-shared --enable-version3 libavutil 56. 70.100 / 56. 70.100 libavcodec 58.134.100 / 58.134.100 libavformat 58. 76.100 / 58. 76.100 libavdevice 58. 13.100 / 58. 13.100 libavfilter 7.110.100 / 7.110.100 libswscale 5. 9.100 / 5. 9.100 libswresample 3. 9.100 / 3. 9.100 libpostproc 55. 9.100 / 55. 9.100 Input #0, rawvideo, from ‘pipe:’: Duration: N/A, start: 0.000000, bitrate: 107520 kb/s Stream #0:0: Video: rawvideo (BGRA / 0x41524742), bgra, 800x600, 107520 kb/s, 7 tbr, 7 tbn, 7 tbc [NULL @ 0x564621a55bc0] Unable to find a suitable output format for ‘/home/User/Desktop/untitled’ /home/User/Desktop/untitled: Invalid argument Exit status: CrashExit Exit code: 1 System Info Pencil2D version: 0.6.6 (dev) Build ABI: x86_64-little_endian-lp64 Kernel: linux, 5.10.56-1-MANJARO Operating System: Manjaro Linux end

Any help would be deeply appreciated. Thank you very much!

In the export dialog, make sure that your output file has the correct extension, and add it manually if necessary. That should solve your issue.

What do you mean by extension? (as I said I’m a beginner in this) If you meant export resolution, then it was correct by default and changing it would still not fix the problem.

EDIT: I tried moving this same exact project to another PC which runs Windows, and exporting went just fine! But this is a very inconvenient solution as moving files from one PC to another is an inefficient way to complete my work. What could the reasons be?

Finally fixed the problem! Turns out to be that I have to manually write the file format beside the project name when in the export dialog. (ex. .mp4, .avi, .apng) Not sure if this is only a problem on Linux, as this didn’t happen to me on Windows.

Yes sorry this is what I meant by extension: a file extension. Pencil2D is supposed to add it automatically when you select a file, but sometimes it does not work right, and that can happen on any OS. As long as you keep an eye on it or remember to check that if the export fails, you should be good.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.

Imprint