Selection tool not working right

 I ran into a bit of an issue. I discovered how to resize a selection, and it works fine except for sometimes. I drew a face and selected part of the nose (the bottom half of it), switched to the mouse tool, and went to one of the corners to resize it but as soon as I clicked the corner the selection just went away. It works on pretty much everything else except the nose and a few other places. I tried closing Pencil 2D and reopening it, and I even deleted the face and redrew it. None of this helped. How do I fix it? Please help.

@pencil2disawesome Hey. No need to redraw it, the issue is that the slection corners “sensitivity” is too low, the Pencil2D developers are already aware of this, so hopefully we can have a fix for that. If it helps try to make the selection as big as you can and select the corners on the in-side of the selection not on the outside.

Thanks. I’ll try that.

@JoseMoreno @pencil2disawesome

This issue has been fixed recently. It’s not really that the selection margin is too low, it was caused by the margin not keeping up when zooming in.

Grab the latest nightly build and let me know it if doesn’t work as expected :slight_smile:

1 Like

@CandyFace That sounds great! I was aware of the issues when zooming in (particularly due to pixel artists that mentioned the issues) but was it possible to also implement the increased corner radius and it’s visualization (circle corners) for the selection tool that martin and yourself worked on before?

@JoseMoreno The corner radius has become slightly bigger but there’s no circle visualization for now.

So you’re saying it’s fixed? I’m don’t understand.

@pencil2disawesome Yeah it’s been fixed and is available in the latest nightly build.

https://www.pencil2d.org/download/

Select nightly build for the platform you have and grab the one with latest date.

iT’s StiLl nOt WoRkInG

@pencil2disawesome I’m going to record a small video following the same steps you have mentioned before while using the development version. If there’s any other step you’re taking that I have not in the video, please record a video on your own to show where the problem is appearing.

I animate on a Mac and the newest nightly build for Mac is from 6-05-2018. Do I use this? If that’s not the right one could you release a nightly build for Mac fixing this issue?

It’s titled pencil2d-mac-2018-06-05.zip .

@pencil2disawesome It was released yesterday so it’s correct, the windows version I was using was made by someone who lives in a different timezone so that’s why it has a different number.

Nevermind. I downloaded it and it worked. Thank you for helping me!

1 Like

It’s not very often that a staff member for a service is so useful. Thank you.

@pencil2disawesome You’re quite welcome. If you have any other issues feel free to let us know :slightly_smiling_face: