Saving projects corrupt frames


(emily ) #1

After accidentally clicking “Flip X”, two of my frames merged together for some reason. I saved it under a different name in case my last save wasn’t recent enough. I opened my last save and an entire layer was deleted. So I opened the first file (where “flip x” messed up my frames). This time, half of my frames were gone and they were all merged with the frame before it. My timeline shows that half of the frames are missing, but when I play it, I see the rest of the missing frames playing while the timeline appears to have stopped.
I don’t know if I’m making any sense in this, but I’d really appreciate it if anyone knew how to fix this. I spent a long time on this animation :frowning_face:


(Jose Moreno) #2

@emily Hi. If you can please send us the file. Upload it to dropbox or google drive and paste the link so developers can take a look at it.

I’ll try to reproduce this issue on a different file meanwhile to see if there’s any way to solve it.

Meanwhile please let us know which version of Pencil2D you are using. If you are using an older version of the software if may be difficult to recover lost work but please follow this guide just in case


(emily ) #3

At the time I ran into this problem I had no idea there was a newer version. I downloaded that and was able to recover the project just fine. I should have updated the post, sorry! Thanks for the response.


(Jose Moreno) #4

@emily No need to apologize. I’m glad you were able to recover it. We always try to keep announcements on our social media so make sure to visit http://pencil2d.org/community for the different media outlets we use to communicate with out community.

If you need anything else, please let us know and we’ll gladly try to assist you however it is possible to us :slightly_smiling_face: