Picture disappeared while exporting

I’ve been using Pencil to create 2D pictures (I like the backgroundless feature and tools). I’ll draw a picture, import it as a PNG, and then fill in everything with the tools Pencil has.


Anywho, It usually takes about 4+ hours to finish 1 picture. I was JUST finished (LIKE JUST!!!) and went to export it. The files (directory) were all black squares(thought it was about to crash again, but tried anyway), and when I tried to export, the PICTURE DISAPPEARED!!! Then I tried to save, and Pencil crashed!


Tried to restart it. Restarted PC too. Now when I load Pencil with that specific file, it shows nothing. It’s still 518 bytes (so there’s obviously information there), but it’s not visible.


I didn’t animate anything, so there’s only 1 key frame. The key frame is selected, and nothing appears out of place … but I can’t find the picture. This is so frustrating. Has this happened to anyone else? Is there something I can do …? There aren’t any errors, it just loads and nothing is there.


Thanks in advance!

I’m sorry to hear about your issue @jpmissy It has happened to most of us, that’s for sure. The only thing I can think to do is to ask you to upload a copy of the file you were working on. I doubt many things can be done to save it, but it’s worth a try.

Also the black images, are only because of the transparency of the png format, whenever you export your “blank” canvas, but if you have a drawing with black lines it won’t be shown easily in the thumbnail. Try to open it with an open source image editor like Krita or GIMP, just to see if your exported image was saved.

Also there’s an autosave feature in Pencil, you can read how to enable it here http://www.pencil2d.org/forums/topic/saving/#post-27028

I’d suggest using it to prevent problems like this in the future, because the program will continue to crash until we have a truly stable version. Hope you can show us some of your work in the future. Take care :slight_smile:

That’s the problem. I did have auto save going, because I had lost work previously to crashes. The problem is my save file keeps loading it up blank … :frowning: Even though I reloaded it many times after taking breaks etc. I tried what you said, but nothing works. No exported file appeared on my desktop either. I really hope I can get it back somehow …




Thanks so much for responding! Here’s hoping you can figure out what happened!

Update: I did find some .data file … it has “pallete”, some PNG that can’t be opened, and an empty file called 002.001.vec


Is that anything …? Pencil won’t use any of it …

@jpmissy Well I can’t seem to see anything. The file loads but nothing is displayed.

Now, every pencil file is associated with a folder saved in the same path where your file is saved.

In that folder there should be some files a .png file a .vec file a palette.xml In this case the png file is the one that should hold whatever image is being seen on the canvas.

I tried also opening the PCL file using a text editor and It reference those files but nothing else appeared.

This is the one from my file:

And your file look like this on a text editor:

It’s slightly different but it still referencing to that 001.001.png file on it’s current folder.

I’m afraid though, that if your drawing is not on that folder. Then it’s gone for good. Sorry about that. Didn’t mean to get your hopes up.

I’m going to give you some side tips to get a personal and cheap versioning system for your own files. If you get a personal dropbox account, you can save your own painting files directly on the dropbox folder, and everytime you save the same file over, Dropbox will create a version of your file and upload it to your personal cloud storage. If anything like this happens again you’ll be able to trace back to an uncorrupted file, saving you hours of work.

Take care and well, best luck with your future work.

p.s. Not to diss on Pencil, but I’d rather recommend Krita for your own still image painting and drawing work. It’s easy, powerful and it’s really stable: https://krita.org