Pencil2D crashes when I import an image to a hidden layer

I accidently tried to import an image to a hidden layer and it crashed. I repeated it a few times to make sure it was able to be easily reproduced.

I am currently using the Jan 19, 2024 nightly build on Ubuntu 22.04 so I don’t know if it happens on other systems.

I tried this on Windows 11 with my older build (Nightly Aug 09 2023), and it didn’t crash. Maybe it’s newer? Or perhaps it’s the OS.

Hi. I tried this on Arch Linux but also wasn’t able to reproduce it. You said that you are able to reproduce this easily, so can you share a few more details? For example:

  • layer type (vector/bitmap)
  • type of image (for example whether it is an animated image/GIF)
  • How you import the image (since Pencil2D offers several different ways to import images)
  • Any import options you specified (such as import position)
  • anything else you think might be relevant (in bug reports, too much information is always better than too little)

Layer Type: Bitmap

Image Type: Png

How I import: File->Import

Import Options: Center of Canvas

Other relevant info: It works just fine as long as the layer is visible.

I recorded a video of it crashing here:

Also, I want to mention that this is not a critical issue for me. I just wanted to make sure the devs were aware of it.

Ah, I think I understand now. It seems this crash occurs only when importing onto a frame without a pre-existing keyframe. Thanks for the video, that helped! Even if it’s not critical for you, this could potentially lose someone else a lot of work, so it’s good that you made this report. I’ll try to put together a fix for this soon.

1 Like

Nightly build 790 (April 14, 2024) is now available and should fix the crash.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.