Pencil wont Open my WIP

I started an animation module for school, and made a test animation to show our supervisor that I had been using my class time effectively and been learning what I needed to for the module. I made a small looping animation that was only about a second long and didnt have more than 30 frames.

Last Friday I opened the .pclx file with no problem and after showing my teacher, continued to work on it.

Today I tried to open the document to work on it, but when I tried it gave me a message saying “Pencil cannot read this file. If you want to import images, use the command import.” I searched for other similar articles on here but none seemed to be my exact plight.

Opening a previous project worked fine it only seems to be this project having this problem. As it was done I’m not particularly devastated but it makes me anxious for the fate of future projects.

Unfortunately all frames were lost in my own troubleshooting efforts so I am unsure of where to move forwards.

@Krunk Sorry to hear about your problem. Please upload the problem file so developers can take a look. If there’s a way to recover the file they can help.

Meanwhile, let me ask the following:

1)what operating system are you using? is the one at school the same at home? Is it windows, linux or mac?

  1. Also which version of Pencil2D are you using? which one is at school? If it’s an older version there’s a higher probability of the file being unrecoverable, but if it’s one of the newer versions, there’s still a chance.

  2. Did you import any kind of sound file? Did it have a name with accent characters? (i.e áéíúó öüï @#!$%& , etc)

  3. Did your own filename had some of the previously mentioned characters?

Meanwhile we wait for your file, from here on, please try to save multiple versions of the same project file to prevent yourself form losing work as we suggest on our FAQ:

I’m using windows 10 and the most recent version of Pencil2D, and I’m using my personal computer so it’s the same at both locations

The title of the WIP was “guy.pclx” so I don’t believe there was anything wrong there. And there was no sound in the file.

Thank you for hearing me out and I’ll be sure to save multiple versions from here on out

@Krunk It is a weird case indeed. Then again please let me ask you to upload the file that is not working.

You can use dropbox, google drive, or any other service you feel comfortable with. If you don’t want it to be made public send me a private message on this forum so I can pass it along to the developers. This is just to exhaust all the possibilities in order to recover the file, if that’s possible, and to patch whatever issue that is causing this problem.