"Pencil cannot read this file" - Case E

I’ve been using Pencil 2d for the past few weeks now (a May 20 nightly build, I didn’t realize I didn’t have the absolute newest one) and have had no trouble saving and reopening the same file.
Today, however, I find the message “Pencil cannot read this file.” I must admit my heart dropped. I read the FAQ and realized my crashing/corruption problem is a “case E”. I read the step-by-step of how to recover it, but I’m lost on the part where I have to use WINrar ZIP to extract the files to a folder. It tells me no archives are found.

Some facts about my file: It has a lot of frames (I suppose I should have known not to use so many, but it didn’t occur to me until now.) It’s a pretty simple file, I didn’t add any sounds or import anything. All I’ve been doing is practicing my frame-by-frame animation skills of a person walking/dancing, simply using the pencil tool. There isn’t even color.

I don’t even care if I can’t use it anymore. I’m really hoping I can at least find a way to extract the images, since I spent quite a while drawing them. I downloaded the most recent nightly build…not sure where to go from here. Please help?

Hi @ayabloom

Sorry to hear you’re having trouble.

Would you mind uploading the project file, then I’ll take a look and see if I can figure out what’s going on?

@ayabloom I’ll record a video tutorial so you can understand how to extract the files, however I urge to upload a copy of the problem file as well so developers can take a look at it, since these issues are important to be examined so future updates won’t have these problems.

@CandyFace I think it might be the issue that Matt fixed before where having two layers would disable Pencil2D’s ability to open the file, considering it’s from May 22nd. It’s also possible there’s something wrong with the header, but it should become clear when the user sends the file. Thanks for looking into this!

@ayabloom you can reply to both me and Jose by adding both our names (@candyface and @morr) in your message, then we’ll both get a notification.

If you have a google drive account or something you could upload it there and share the link, alternatively you can use this service: https://www.file.io

Just upload the file and copy the link here.

@candyface and @morr I’ve just uploaded the file into my google drive and shared the link to it.


Hope it works. Thank you!

@CandyFace It seems I can’t open the file via unzip. And when I try to see the file through a text editor it shows blank despite having a hefty filesize.

It appears as if the encryption got jumbled. Might have to ask @chchwy to help out as well with this file, because it’s weird that this happens even if the build used is from early May 2017.

I still think there’s an issue with low-end / 32 bit computers that might be causing this issue, from crashing to locking the files, just like what we saw on this other thread:


Yeah, that’s the problem I faced when I tried to unzip it, there were all kinds of errors and I remember it being blank/empty. That had me worried that everything got completely erased, however it still takes up memory so it must still be there somewhere, right?

Thanks for checking it out. Does my problem seem to relate to the other person’s in the thread that you shared? I forgot to mention I’m using Windows 7, don’t know if that helps. Let me know if there’s anything I forgot to mention or could find out!

@morr @candyface @chchwy

Sorry for the late reply, @ayabloom that file is broken for good. It’s hard to say what has gone wrong but it does not contain anything but garbage values. I’m sorry to say but you’ll have to redo the animation.

@morr I’m quite confident in saying that there is nothing we can do to save it. I’ve tried checking the content with a hex editor, among other things but it always return garbage values of zeros, so i don’t believe it contains any actual data anymore.

@CandyFace That is really sad to hear. I’m still positive that it’s the same issue we had before. It just wasn’t as apparent due to 64 bit architecture builds and everyone having more than 4GB ram.

This multi-part issue is still open on github though https://github.com/pencil2d/pencil/issues/520 but it seems the only way to hunt for it is by having a really low end computer, particularly a 32 bits version build.

Thanks for trying out everything you could.

@ayabloom I’m sorry Celia. It seems this is the extent of our abilities to deal with thes ekind of issues. I completely understand the frustration of losing all of your work, and I won’t try to convince you to continue using the software. If you want a comprehensive list on animation alternative options (both commercial and free) please visit our blog here:

We hope in the future Pencil2D won’t have these kind of issues anymore, so others can benefit form using it. But it will take time. Take care and wish you well.

Huge bummer… Well alright, I’ve learned a lesson on the importance of backing up my files in as many ways as I can. I appreciate you all spending time to try and fix it. It’s tough to lose all my work, but I’ve been fervently re-drawing it by hand and catching up pretty quickly, after which I will import my hand-drawn images into Pencil 2d to organize them, and be more careful not to overwhelm the program. I know a lot of hard work goes into providing this free service, so thank you.

Despite the bugs, Pencil 2d served me well as someone totally new to animation. I hope my situation will help you guys in your efforts to learn more about fixing memory/crashing problems and whatnot. Thank you all again for your time. Please take care. @morr @candyface

@ayabloom I’m sorry to hear that.

There is another way that probably could save some of your work.

Please go to the following folder (I suppose you are using win10?)

There should be some PROJECT_NAME.Y2xD folders in it.
It’s the temporary workspace of pencil2d. Go into these folders and you might find some images in a subfolder called ‘data’.

Let me know if you are a linux/mac guy. the path is different.

@chchwy Thanks very much, I’m actually using Windows 7. (I just got a new laptop with Win 10 but for the time being I’m using my old one.) Is there a way to do that with Windows 7?

@ayabloom Windows 7 should be at the same location.
Or you could type %TEMP% in the address bar of file explorer.

I found them! Most of the images are still here! Thank you so much, I can’t believe how much of a relief this is. I have so much less work to do now. Thank you @chchwy

It looks like some of the images won’t open, could it be that these have been damaged?

This is amazing, I can’t even express my thanks.

Phew~ Happy to hear that.

Pencil2d uses plain png images to keep bitmap frames, so if an image can’t be displayed in a normal image viewer, yeah…it’s damaged.

@chchwy I dind’t know about that! I’ll try adding that to the FAQ thanks for helping out!

That’s fine, I’m just very thankful I got a lot of them back!

While I’m here, I’d like to ask if there’s a command that allows me to copy and paste multiple frames at once, or delete multiple frames at once? I can’t seem to do it. I dug through the forums and saw a similar question but I think it was from a long time ago.

Thanks so much guys!

@chchwy @morr