Pen button uses hand tool

I’m on Windows 7, have Pencil2D v0.6.6, I’m using One by Wacom and it’s drivers are v6.3.28-3.

Whenever I use one of the buttons in my pen it uses the hand tool and moves the canvas. I discovered this when I tried to use a pen button to undo by using the pen configuration to bind one of it’s buttons to “Ctrl + Z”. I have tried to change the shortcut to undo in Pencil2D to other buttons and binding the pen button to that, but it didn’t help.

I’ve noticed the hand tool doesn’t come up by just pressing the button for undo on the keyboard, only on the pen. It also doesn’t happen if i bind the pen button to any click, only if it’s bound to a keyboard button.

There was another post about the same issue but none of the provided workarounds worked for me, I could still use the keyboard for all the shortcuts, but it’d be a bummer not to be able to do so through the pen.

@TostadaConManteca Hi. Sorry for the delay. Honestly I have a wacom intuos 5 tablet, and I’ve had to create a separate app profile for Pencil2D and disable the stylus buttons from even working with the software in the past.

It seemed that before there was a bug in both the tech used to code Pencil2D and the software source as well, however it’s quite elusive and to my knowledge the problem might persist.

I’ve researched a bit while using screencast software and I found out that the stylus “right click” tablet event is understood in Pencil2D as a left-click, however If I currently map the button to something like CTRL + Z it will work :thinking: (tested it just now with a nightly build)

If possible can you try to use a development build and let us know if this continues to happen to you?

Of course we suggest to only use it to help test drive the app, and not to use it just yet for serious work since it might have some issues related to stability and performance that are being ironed out.

If the issue keeps happening It could be something else, and in that case we would aks you to provide accurate and simple to follow reproduction steps, so we can emulate your conditions and replicate the problem in a developer environment.

Hi, thank you for replying, downloading the development build worked! The pen buttons are working perfectly!

1 Like

@TostadaConManteca I’m glad, thank you for solving the thread. It’s helpful to know that this specific issue can now be solved for users of Wacom One tablets in the future. Best of luck!