Onion skin not working

Hi, I’m having trouble getting the onion skin to work. I’ve checked it’s turned on both in the display bar and in ‘View > Onion skin’ and I’ve looked at online tutorials but it still doesn’t work. Can someone help me out? Thanks!

Hi @IM639 What version Pencil2D? What OS?

Onion skin is placed in the Display window, unless you have a nightly build, where it has its own window.

@IM639 Whenever possible please reply with the information that David asked so we have a better idea how to help.

Also as a general warning, if you’re using any version up until the latest stable version 0.6.4, bear in mind that the onion skin had an issue where having a fully opaque image (e.g a background image, a photo, a layout paper scan, etc) will not allow your onion skin to show on the top layers, so you have to disable the layer visibility for the onion skin to show.

This limitation has been fixed for the upcoming release, so please use this solution as a temporary workaround if this is indeed the problem that is effecting you.

Another consideration would be to review the display panel icons and make sure both next / previous buttons are turned ON.

Also if you go to Edit > Preferences > Tools and check if the maximum / minimum opacity of the onion skins is above 0% otherwise the onion skins will not show.at all.

Additionally the diamond button on the timeline does not activate the onion skins.

All of the onion skin features have been moved to a panel for the upcoming version, so this way of accessing the features will be only temporary.

Imprint