No Audio on export movie

Hey I’ve been making a project for years with pencil and I just tested the export and none of my audio is audible whatsoever, I’m using an old software (0.6.2) because every time I use a newer version there are bugs are all over, they misplace my frames, what should I do? I’m getting close to being finished…Thanks!

@Jhamil92 Hi. The newer versions have less bugs than the older ones guaranteed.

Misplaced frames have been reported on Windows paired with specific issues on the user operating system.

Many have reported that their antivirus or a third party app they have have erased the temporary file directory periodically, thus also removing the frames from any open file, even if the working copy is open in the editor working, so when people save the file Pencil2D thinks the user deleted them instead.

Now to solve your problem it’s very simple so I’ll recommend the following:

  1. Export the video without sound as is. Keep it handy.
  2. Then get the newest version, open the animation file, turn off the drawings and only leave the sound, then export the video with the sound track.
  3. Then download a free video editor and import both videos
  4. Put the “image” video on a top track, and the “sound” video on a bottom track.
  5. Export your final video from the video editor.

I can recommend Shotcut, KDEnlive or even Hitfilm Express as free video editors.

Quite personally, I would always recommend adding your final sound effects and music track in a video editing package. Only add sound in Pencil2D to sync dialogue and synchronize animation to a beat.

Excellent tips and information thank you I will keep all of this in mind, would exporting in the latest pencil keep it together I wonder? I mean the frames get real messed up when I put an old project in the newest version, I’ll have to start new projects after this one in the latest version. Also what is a good resolution to export in? Thanks,

Joel

@Jhamil92 Hi.

would exporting in the latest pencil keep it together I wonder?

It should, there’s no reason why the project would get broken, however if it does we might need to ask the devs to investigate the file

I mean the frames get real messed up when I put an old project in the newest version

Hmm, are you using the vector layer by any chance? If so that might be the reason you’re getting these issues. Currently the vector layer has various problems but development is halted until the bitmap engine has been replaced, so it’s not recommended to be used, because we can’t guarantee a frustration-free experience.

Also what is a good resolution to export in?

For web videos anything above 720p is more than fine (1280 x 720 pixels) if you’re uploading to a video service like youtube or even newgrounds you should consider taking a look at their technical requirements if available. Here’s an example for Youtube encoding requirements https://support.google.com/youtube/answer/4603579?hl=en

If you worked with bitmap layers, I’m afraid you can only modify the camera resolution but that won’t scale your drawings. If you didn’t plan the work with the final size output from the start enlarging the image will cause it to become blurry.

If you need to resize the images, you could try to:

  1. Export only the main drawings by using the File > Export > Image Sequence > then check the Export Keyframes Only option.
  2. After that you could import them into an image manipulation software with a timeline like Krita, Photoshop
  3. After the drawings are imported resize the canvas contents with an appropriate image processing algorithm like Bicubic Smoother, Lanczos3 or Nearest Neighbour, whichever gives you better results.
  4. Then you can re-export the scaled drawings and import them back into Pencil2D

If you worked with vector layers though, you can increase the output size in the File > Export > Movie dialog without losing quality. If you change the size in the camera layer the images won’t scale afterwards either way.

1 Like

This topic was automatically closed 42 days after the last reply. New replies are no longer allowed.