New Build, Sound still doesn't work

audio
windows10
bug

(Sonic Doodles) #1

So I tried to export a small animation I’m currently working on to show some friends the progress I’m making, but whenever I export it, I can’t hear the audio at all. I tried a few more times, even changed the files, but still, nothing at all. I tried to find out why this was happening, and when I found out that there was a new version that said this problem was fixed, I removed the previous versions and got the new one, but unfortunately, I’m still having the audio problem, and I don’t know what to do now. I need some help…


(Jose Moreno) #2

@SonicDoodles Hi. Can you tell me what does it say in the menu HELP > ABOUT.

It sounds like a really odd problem considering 0.6.3 fixed many sound issues, and one that was particularly nasty was that having many sounds would make all the sounds have a really low volume so it would progressively amp it up until the end of the animation, which sounds like the one you’re having.

If the current version number on your about dialog matches the 0.6.3, meaning the software is indeed the latest version (sometimes it happens opening the file directly might open a previously registered pencil2D), please send me a link to your file so we can inspect it and help you export the video if needed.

Also, please let me know the following information:

  1. What is your current operating system (Windows 10, macOS 10.12 [sierra], etc)
  2. What type of sound files were importing (e.g WAV, MP3, etc)
  3. What movie file type were you trying to export (e.g MP4, AVI, WebM, etc)
  4. If you export a single sound on a new file does it sound properly?

(Sonic Doodles) #3

Took me a while to get back to this, my bad.

So I went to Help > About and this is what popped up:
Version: 0.6.3
Operating System: Windows 10 (10.0)
CPU Architecture: x86_64

  • The system I use is Windows 10
  • The sound file was an MP3
  • I tried to export it to an MP4, but when that didn’t work, I tried to export it as something else, but still nothing
  • And I did make a new file and tried to export a different MP3 file, but it still didn’t seem to work

(And unfortunately I am unable to send the file. It’s not letting me since I am a new user. I apologize, but I hope the information given is enough.)


(Jose Moreno) #4

@SonicDoodles It’s alright, if you can upload it to google drive , dropbox, mega.nz or use wetransfer.com to share the link (I can hide the link in case you don’t want anyone else looking at it) Normally this forum only allows single image uploads and maybe gif’s

Take your time, but it would be paramount to be able to review your file in order to fix the problem you’re having in future versions of the program so it does not happen again for you or other users.


(scribblemaniac) #5

You can also share the file with us directly here: https://www.pencil2d.org/contribute/share. Just make sure to fill out the creator field so we know which one is yours.


(Sonic Doodles) #6

Thank you so much. I have shared it. Take your time.


(Jose Moreno) #7

@SonicDoodles We received your file and we’re testing it, however we have not been able to reproduce the issue, it might an issue specific to Windows 10 and i’m pending to test that OS as well when i have more time.

I exported the animation as an mp4 but there is no loss in volume.You can download it here: https://drive.google.com/open?id=1U1tjz0OxMIHEwhsi1jaLHTIpDPu-G61I

Something I’d like you to try is that considering that you had previous pencil2d versions, please try to explicitly run the Pencil2D.exe version as an administrator.

To do that right click on the Pencil2d.exe filde inside the folder where you extracted Pencil2D, then on the pop-up menu press “run as administrator” if you’re not the admin of your computer (maybe a teacher or a parent is) ask them to help you with that only for this test.

One you open the program like that, open the file explicitly from within the program using the file > open command.

Once you’ve opened the file, immediately go to File > Export > Movie > and make sure that you press the browse button to give the file a name and the filetype. The press ok to begin the export.

When using a video player to review, try to use either VLC or Quicktime or if your Windows media player has installed support for mp4 codecs, use that as well.

If you still can’t hear a sound, it might be required to clean the Pencil2D registry, but for that I might have to make a video guide or find an article that you can reference.