MyPaint version pre-alpha preview

I am aware of the performance issues, and are currently working on rendering optimizations that should benefit master too, so hopefully the next mypaint build will perform much better.

I still have some things to work out but I’m optimistic about these changes.


Take your time! I know these problems have been a pain in the neck for a long time, and my intent by mentioning it was simply to help scoping the investigation since previous MyPaint builds did not have the performance issues or at least not as pronounced. Thank you for all the hard work and for checking on our reports :bowing_man: :+1:

Thanks for the hard work!

I also found another problem. The Polyline Tool works weirdly. It creates blocky results for some reason. It is very pronounced on partially transparent parts:

Before I go on vacation for a few days… here’s a new experimental build with a somewhat revamped canvas painter. This should perform a lot better than before.

Most of the changes are not related to mypaint but simply how we paint and update the canvas. There’s more to come but I’ll probably not be able to get more done today, so I thought i would post an update and let you test it.

Mac OS:
Win32: Pipeline broken… so no build right now.


  • How strokes and frames are drawn on the canvas and how much is updated.


  • Polyline causing overlap
  • Fix layer/keyframe dialog opacity was not taken into account for the current frame

I love this mypaint version of pencil 2d but please is there a way to integrate it into the current nightly builds cause the nightly build has add exposure(aka animate on two’s) which goes a long way.if you can’t, can you please tell me a way to do so? . Thanks in advance :smiling_face:

Hi Leri

The latest mypaint build should contain all the latest changes from master, including the add/remove exposure feature.

Thanks Mr Oliver I love the way you went out of your comfort zone to help the users of pencil. Actually i had been thinking of a way to add extra brushes until i came accross your build, this extra brushes go a really long way although I believe the original mypaint has the shape tool and lasso tool but thanks :heart_eyes:

That’s correct but that is not what we’re integrating up against. This integrated the brush system that mypaint uses, which is a separate thing. Tools like lasso, shape etc. are not part of this, so the only way to get those things too would be to make them ourselves :slight_smile:

Thanks for the reply anyways. I’ve been overly obssessed with getting the shape tool lol :joy:. Thanks for this mypaint build once again :smiling_face_with_three_hearts:

Hi Mr Oliver i want to report a bug; the app delays as soon as you use the wacom tablet, it just lags for up to 12 seconds and then register the stroke. I font know if this is an issue with my pc. Thanks in advance

Back from holiday, had a few hours to look into the performance issue surrounding tablet. There was a toolChanged signal which was fired on every tablet stroke, making the tool options widget laying out itself every time, this has now been fixed.


  • Updating toolChanged upon every tablet stroke, laying out the tool options continuously.
1 Like

I just noticed. When using a mouse, when changing tools, the mouse image uses the previous tool. For example, when changing from pencil tool to brush tool, the mouse remains a pencil, and then changing to smudge tool, the mouse is now the brush, etc…

1 Like

Thanks for reporting, apparently even though i’ve been working on a bugfix for a few days now… this one completely slipped my mind.

A new build is now ready, which introduces additional painting improvements. The tool bug has also been fixed.


It’s been a while since I’ve made an update to this and the reason for that, is that I have been working on improving the overall performance of the application bit by bit, with several PR’s that should prove to make our next stable release much faster than our current stable build.

That work got merged recently, so naturally I thought it was time to update the mypaint build again. This was not as trivial as I had hoped though… mostly because I went a bit too far in making changes, so it was basically easier to re-implement mypaint again using the changes from our master branch as a base rather than trying to fix a huge set of merge conflicts.

I also fixed a bunch of leaks months ago but back then I didn’t feel like making another update for just that.

So no new features as such except for the things that has been merged recently.

Let me know if you have issues.


New release, this puts us up to date with master again, which means that the new icons are also in this release.

A lot of internal work has been done for this release. Some of those changes resulting in saved brush preferences being reset. Not the brushes themselves, just the preferences regarding which tool option is visible and such in the tool options window.

The preset config button is gone from the brush selector window and has instead been moved into preferences. The reason being that it’s a button you’ll hardly ever use, thus it was way to prominent to be placed in the brush selector window.

The brush mapping window has gotten a slight visual update too. The icon buttons has been replaced with text.

The button to access the input mapper has also been tweaked to fit the new style.


  • Fixed brush settings didn’t show on launch.
  • Fixed brush preview would not update properly

Hmmm… This version has severe memory leaks. It just eats up my computer’s RAM after few minutes of using it. I think it was also an issue with the previous version. Pretty much unusable for me.

OS: Ubuntu 22.04

Further info: It seems that the Mypaint versions just doesn’t work in my Ubuntu system. I previously have a Debian system and the Mypaint versions from last 6 months ago and so works well. But now, even those versions doesn’t work.

1 Like

Can you elaborate on the memory leak? and preferably mention the exact memory usage you’re seeing. The peak memory usage is higher than in our current stable release, from launch being around 80 mb for me to peak at around 330 mb on mac os.

I do not see any major leaks that would cause any significant increase, and nothing introduced in this experimental branch.

Can you reproduce it consistently, and if so, how can I reproduce it?

Can you elaborate on the memory leak? and preferably mention the exact memory usage you’re seeing. The peak memory usage is higher than in our current stable release, from launch being around 80 mb for me to peak at around 330 mb on mac os.

It literally just eats every available space even swap space. My computer soon cease to function if I don’t do anything.

Can you reproduce it consistently, and if so, how can I reproduce it?

Resizing the pen with the shift key and dragging the pen seems to make the problem more likely to appear.

It doesn’t happen all the time and sometimes I will just constantly resize the brush and draw and nothing bad happens. Seemingly randomly Pencil2D becomes slow or unresponsive when resizing the brush.

On the other hand, even if it doesn’t eat my RAM, it seems to develop other issues. Shortcuts randomly doesn’t work, frames are randomly cloned when clicking on the timeline, you randomly just can’t draw at all, undo does weird things, etc.

These issues though only appear after using the application for a long-ish time (a few minutes for me). It works perfectly at first, no issues at all, then things just go south.

Overall, from what I can see, the application just become more unstable the longer I use it. It might eat my RAM or various functions just breaks.

I also think the UBUNTU OS have something to do with it. I have DEBIAN previously and the MyPaint branch from April works with no issue. The April branch however works even worse in my UBUNTU system.

That sounds very odd indeed, however the fact that you’re experiencing this with old builds now too makes me think that something else is going on.

I’ve tried to reproduce by doing the things you mentioned but i see no significant increase and it still peaks at around 330 mb for me.

Have you tried to reproduce the problem in the latest nightly build from the main branch? If not, could you try to see if you can reproduce it there too. That would be very useful :slight_smile:

If you don’t experience this on the nightly build, then I might have to boot up my own Linux distribution and see if I can reproduce the behavior :thinking:

Yes. Similar issue does happen with the main branch. Again, it is with resizing the brush using Shift + Pen drag (mouse drag works fine). It is not as bad though.

The difference is that the application just becomes unresponsive. It doesn’t eat RAM or anything, just stops doing anything and it often just resolves by itself after several moments. I can forcefully close the application too with no problem something which can’t be done with the MyPaint branch.

I also found while using the main branch that adjusting the sliders using my Pen also cause performance issues. Not as bad as brush size resizing but the application does becomes unresponsive for a few moments. No issues when using the mouse instead.

So, so far, the issue seems to stem from using my Pen for anything fancy. I can actually use either branch just fine as long as I don’t do brush resizing and slider adjusting with my pen. That requires me to use the mouse instead.