MyPaint version pre-alpha preview

Hi Mr Oliver i want to report a bug; the app delays as soon as you use the wacom tablet, it just lags for up to 12 seconds and then register the stroke. I font know if this is an issue with my pc. Thanks in advance

Back from holiday, had a few hours to look into the performance issue surrounding tablet. There was a toolChanged signal which was fired on every tablet stroke, making the tool options widget laying out itself every time, this has now been fixed.

Fixed:

  • Updating toolChanged upon every tablet stroke, laying out the tool options continuously.
1 Like

I just noticed. When using a mouse, when changing tools, the mouse image uses the previous tool. For example, when changing from pencil tool to brush tool, the mouse remains a pencil, and then changing to smudge tool, the mouse is now the brush, etc…

1 Like

Thanks for reporting, apparently even though i’ve been working on a bugfix for a few days now… this one completely slipped my mind.

A new build is now ready, which introduces additional painting improvements. The tool bug has also been fixed.

2 Likes

It’s been a while since I’ve made an update to this and the reason for that, is that I have been working on improving the overall performance of the application bit by bit, with several PR’s that should prove to make our next stable release much faster than our current stable build.

That work got merged recently, so naturally I thought it was time to update the mypaint build again. This was not as trivial as I had hoped though… mostly because I went a bit too far in making changes, so it was basically easier to re-implement mypaint again using the changes from our master branch as a base rather than trying to fix a huge set of merge conflicts.

I also fixed a bunch of leaks months ago but back then I didn’t feel like making another update for just that.

So no new features as such except for the things that has been merged recently.

Let me know if you have issues.

5 Likes

New release, this puts us up to date with master again, which means that the new icons are also in this release.

A lot of internal work has been done for this release. Some of those changes resulting in saved brush preferences being reset. Not the brushes themselves, just the preferences regarding which tool option is visible and such in the tool options window.

The preset config button is gone from the brush selector window and has instead been moved into preferences. The reason being that it’s a button you’ll hardly ever use, thus it was way to prominent to be placed in the brush selector window.

The brush mapping window has gotten a slight visual update too. The icon buttons has been replaced with text.

The button to access the input mapper has also been tweaked to fit the new style.

Bugfixes:

  • Fixed brush settings didn’t show on launch.
  • Fixed brush preview would not update properly
3 Likes

Hmmm… This version has severe memory leaks. It just eats up my computer’s RAM after few minutes of using it. I think it was also an issue with the previous version. Pretty much unusable for me.

OS: Ubuntu 22.04

Further info: It seems that the Mypaint versions just doesn’t work in my Ubuntu system. I previously have a Debian system and the Mypaint versions from last 6 months ago and so works well. But now, even those versions doesn’t work.

1 Like

Can you elaborate on the memory leak? and preferably mention the exact memory usage you’re seeing. The peak memory usage is higher than in our current stable release, from launch being around 80 mb for me to peak at around 330 mb on mac os.

I do not see any major leaks that would cause any significant increase, and nothing introduced in this experimental branch.

Can you reproduce it consistently, and if so, how can I reproduce it?

Can you elaborate on the memory leak? and preferably mention the exact memory usage you’re seeing. The peak memory usage is higher than in our current stable release, from launch being around 80 mb for me to peak at around 330 mb on mac os.

It literally just eats every available space even swap space. My computer soon cease to function if I don’t do anything.

Can you reproduce it consistently, and if so, how can I reproduce it?

Resizing the pen with the shift key and dragging the pen seems to make the problem more likely to appear.

It doesn’t happen all the time and sometimes I will just constantly resize the brush and draw and nothing bad happens. Seemingly randomly Pencil2D becomes slow or unresponsive when resizing the brush.

On the other hand, even if it doesn’t eat my RAM, it seems to develop other issues. Shortcuts randomly doesn’t work, frames are randomly cloned when clicking on the timeline, you randomly just can’t draw at all, undo does weird things, etc.

These issues though only appear after using the application for a long-ish time (a few minutes for me). It works perfectly at first, no issues at all, then things just go south.

Overall, from what I can see, the application just become more unstable the longer I use it. It might eat my RAM or various functions just breaks.

I also think the UBUNTU OS have something to do with it. I have DEBIAN previously and the MyPaint branch from April works with no issue. The April branch however works even worse in my UBUNTU system.

That sounds very odd indeed, however the fact that you’re experiencing this with old builds now too makes me think that something else is going on.

I’ve tried to reproduce by doing the things you mentioned but i see no significant increase and it still peaks at around 330 mb for me.

Have you tried to reproduce the problem in the latest nightly build from the main branch? If not, could you try to see if you can reproduce it there too. That would be very useful :slight_smile:

If you don’t experience this on the nightly build, then I might have to boot up my own Linux distribution and see if I can reproduce the behavior :thinking:

Yes. Similar issue does happen with the main branch. Again, it is with resizing the brush using Shift + Pen drag (mouse drag works fine). It is not as bad though.

The difference is that the application just becomes unresponsive. It doesn’t eat RAM or anything, just stops doing anything and it often just resolves by itself after several moments. I can forcefully close the application too with no problem something which can’t be done with the MyPaint branch.

I also found while using the main branch that adjusting the sliders using my Pen also cause performance issues. Not as bad as brush size resizing but the application does becomes unresponsive for a few moments. No issues when using the mouse instead.

So, so far, the issue seems to stem from using my Pen for anything fancy. I can actually use either branch just fine as long as I don’t do brush resizing and slider adjusting with my pen. That requires me to use the mouse instead.

I know from own experience, that strange things can happen, when the computer is not okay. Please check your RAM and if you overclocked it, turn it down a bit.

Check your cpu-cooler, if it is still properly atached to the cpu.

Benchmark your computer, to see if strange things happen.

I found another issue. Anything inside a selection doesn’t seem to be drawn or updated properly.

How to recreate: Make a selection then switch to a drawing tool (pen, brush or pencil) by clicking on the icons or shortcuts without terminating the selection. Draw within the selection. Your drawing would not be shown until you release your pen or mouse. Try starting your drawing from outside the selection then into the selection, your stoke would not appear in the selection. Same thing happens with the eraser and the polyline tool.

I didn’t do anything fancy with my computer. No overclocking whatsoever. No issue with it either.

The Old Pencil2D works just fine.

It really is just with the alpha version of this software with my particular OS.

Hello MrStevns!

I’m not sure if I asked this before but do you know the reason why the Mypaint version of Pencil2D deforms the colors when painting with transparency paintbrushes? You can see it in this picture if you look closely, it’s large blocks appearing randomly, like it’s pixelating the image but with huge pixels :slight_smile:

https://imgur.com/a/VpTbPtw

1 Like

@manu Hmm seems as if those were the tiles the canvas use to make image building faster :thinking:

In these cases it might be better to tag @MrStevns so he gets the notification :+1:

Hi Manu

I’ll need to know some more about how to reproduce this as it’s not an issue I’ve seen myself yet.

It’s true what Jose mentions, that the canvas is build on tiles, but that implementation comes from mypaint and we’re not doing much to that data so i’m not sure what would cause such an effect if you’re not able to reproduce that in mypaint itself.

Can you provide some more details, for example:

  • Which brushes do you experience this with
  • Have you configured those brushes?
  • Can you provide the steps or maybe record a session where i can see the effect take place?

btw. i did get the notifications, no need to tag as long as it’s a reply to me ;)

Hi again, ok so now I have found out how to reproduce.

  1. I renamed my old brush folder in %appdata% so Pencil2DMP could create it again with default settings just to make sure none of my old tweaked brushes could affect the test. .
  2. I noticed before that I could only see this if I have more than one layer. (WIll check again that I’m 100% sure) .
  3. I paint one layer “red” just to have something underneath .
  4. I start to paint with a big brush a few other color tones on layer 2 .
  5. On the same layer I change the brush size to a very sharp one to paint the finer details and it is then when you can see the strange effects. . I hope you can reproduce it too :slight_smile: . https://youtu.be/OQOyO9Nj1GY
1 Like

Hi Manu

I’ve finally had some time to look properly into this issue and the steps you’ve provided does seem to produce the problem consistently.

What I know so far:

  1. You need a backdrop of some kind because, ie. a red background
  2. You need to keep drawing strokes at the same area, 5-10 strokes should make it noticeable. If you use 2 layers, the effect begins after 2-3 strokes usually.

I know the problem and i’m fairly certain I know the cause… the question is how to fix it. :thinking: Well that will be my headache, thanks for reporting it though and for the detailed steps :slight_smile:

1 Like

New release!

@manu I believe I’ve fixed the tile issue! try out this release and let me know of your findings.

Bug fixes:

  • Fixed a bug causing color of a tile to degrade over numerous strokes, making the tiled surface become visible.
  • Fixed a crash caused by invalid tile lookup
  • Fixed a crash when trying to update a setting in the brush configurator

Added:

  • Ability to reset brush presets and brushes in preferences. The button is found in the same area as brush presets and requires a confirmation before being applied.
2 Likes