MyPaint version pre-alpha preview

Thank you for the reply. I have compiled the main version of pencil2d on my box successfully. However I ran into some errors when attempting to compile CandyFace’s branch. Should this version compile on linux?

@danya Hmm. There could probably be some specific linux code missing that allows you to run the app. In that sense only CandyFace can say what’s pending to be able to run it on linux.

If you don’t mind can you post all the compilation errors you ran into (not the warnings though) that way when he gets online he’ll be able to respond more accurately.

Only one error. It can’t find a header file, “brushsetting.h.” I checked and couldn’t find it in the source.
Just in case, here is the link to the source code I downloaded. Perhaps it is not the right one?

Here is the complete error from qtcreator:

/home/danya/Downloads/pencil-implement_mypaint_nobitmapsurface/…/pencil-implement_mypaint_nobitmapsurface/app/src/brushsettingwidget.h:6: error: brushsetting.h: No such file or directory 6 | #include “brushsetting.h” | ^~~~~~~~~~~~~~~~

Hi Danya, thanks for taking interest.

Regarding your compilation problem, if you run qmake before hitting build, then it should add brushsettings.h and after that you shoul be able to compile.

edit: whoops… spoke too soon and without coffee… I read config.h in my haste… the brushsetting.h should definitely exist, it’s located in core_lib/src/util/brushsetting.h

Let me look into that… I have a lot of uncommitted changes awaiting, so maybe I’ve made a half-finished push last time I worked on it.

Hello @CandyFace I looked in the directory you mentioned and the file does indeed exist, but as “BrushSetting.h”. I renamed it and I was able to compile it successfully through the command line. Looks great, thank you.

@danya Ah I recall I had that same problem and fixed it the same way under Windows. Glad to hear you managed to compile!

@CandyFace I think I told you about it on discord but that was over a month ago. I think it’d be worth submitting an issue to your branch so we don’t forget as it’s such a minor detail we might possibly forget about it again :laughing:

I haven’t touched the code for some time now, probably a month, so that might very well be the case. The issue should be fixed now, for some reason my git client didn’t register that I’d changed the casing.

A new release is out:

Main features:

  • Brush settings will be shown in tool options panel.
  • Ability to toggle on/off what settings you want displayed in tool options panel.

Test it out and see how it behaves.

Win64 : https://drive.google.com/drive/folders/0B7zQuPZEO_64UDVrZFkzZmhSSmc

Win32 : https://drive.google.com/drive/folders/0B7zQuPZEO_64QmNxdG84WDN5Znc

Make sure you grab the latest version ( beware the timestamps! )

1 Like

I downloaded the source code for the new release and compiled it successfully on linux (Arch).

I can verify that the brush settings do show up in the tool options panel as expected and I can also toggle them on and off.

There is only one thing that did not work as expected but perhaps this feature hasn’t been implemented yet. When I change tools from the same group, (eg, from the 4h pencil to the 2b pencil or to the chalk) the tool options panel does not refresh automatically to reflect the settings of the new tool.

Ah… that’s a bug, should be fixed now.

That was fast! Yes, the tool options panel is now updating when I change tools. Thank you for the fix.

Hello CandyFace,

It looks like I may have encountered a small bug and it only occurs when the 2b pencil is selected. All other tools work as expected.

To recreate

Select the 2b pencil. Move the canvas and after you let go you will see that the 2b pencil is no longer selected. Instead the 4h pencil will be selected.

Thanks for reporting, should be fixed now. New build will arrive in 15 min or so…

Yes, looks like everything is good. I have been using this version almost everyday now and have not encountered any other MyPaint related issue. Thank you for all your work.

@danya That’s great to hear :slight_smile:

New build coming within 15 min.

Notable changes:

  • Fix key events not working after selecting a brush in “Brush selector” window. An example is trying to pan the canvas using space bar, this would not trigger on first try.
  • Fix crash when copy/pasting a selection to a new frame when the selection rectangle is still shown.

Quick update:

New build available:

  • Don’t render canvas cursor when using selection tool
  • Fix canvas cursor not updating visually according to the new brush setting.

Hello

You’ve recently mentioned a few fixes related with copying/pasting and the selection tool. I figured I should mention some of the issues I have encountered with the selection tool of the MyPaint version, just in case.

  1. I like using the gray background and when I select an image and move it to a different location on the same frame I get a white square box in the original location. But it disappears when I hit enter.

  2. When I rotate the image, the image changes size (gets smaller) as I rotate, but fortunately it goes back to the original size when I hit enter.

  3. When I begin to draw again on the same frame, the drawing that I moved and rotated earlier gets duplicated.

To recreate

Set background to grey. Draw something. Select drawing. Rotate drawing and move drawing to a different location on the same frame. Draw something else on the same frame.

Thanks for reporting :slight_smile:

  1. Selection causing white rect - fixed
  2. Rotation selection, distorts image - fixed
  3. Weird behaviour when drawing on layer after a selection has been made… - working on it.

Confirmed on linux. 1 and 2 are now resolved. Thanks!

Before I forget, I recently and accidentally closed the brush selector window (where the MyPaint Brushes are) and realized that there is no easy way to get this window back without restarting or clicking on the reset windows button. At least none that I know of.

Ah… yes you’re right, I forgot to add it to the menu. it has been fixed now.

Imprint