My project's files are "corrupted"

Can anybody help me, please? I worked so so hard on my project, and for some reason, when I tried to launch the file to continue working o it, it shown the following message:

Is this normal? I’ve been working on this project for 1 entire month, and I feel so sad rigth now.At least I exported into video some of the thing, but not the completed video.

@Mimikyu007_OwO Hi. Sorry to hear this. We’ve done this in the past haven’t we?

I recall I gave you a warning back then that for large projects it’s a must to save multiple files instead of saving to a single file in order to avoid this problem as it was bound to happen.

This is particularly true now, and more than ever, since Windows 10, macOSX 10.15 and Linux distribution systems have become more and more aggressive when dealing with external apps (that is applications that are not installed from their “approved” software manager or app stores)

Anyway. As usual the only way we can help is if you share the file and we recover what we can. Please use wetransfer.com to upload the file, and read this guide to learn how to use the anonymous link option https://wetransfer.zendesk.com/hc/en-us/articles/115004254743-How-do-I-send-a-link-transfer-

We’ll only be able to recover whatever is inside the file, but if the animation was too long, since Pencil2D saves from the last frame to the first, a portion of the initial part might have been lost. Since you mentioned that you have an exported video you can use a video editor to fill in the blanks.

@Mimikyu007_OwO As a separate question can you let me know which Linux OS version are you using? (e.g Ubuntu 18.04, Linux Mint 17.7, etc)

Also, if you want try out the nightly build AppImage file from this link which is the latest version of the software and should have some improvements related to this specific problem (saving normally, file gets corrupted due to operating system), try to open the file with it as well, just in case.

Thank you so much for helping me, this is really a problem for me right now . I don’t remember that you already said me something like this, anyways thanks for remainding it. Here is the file:

Oh, I have Fedora 29 if I remember well. And I think that my Pencil2d is the latest version.Anyways, I’ll try the applmage file.

@Mimikyu007_OwO Hi, you sent an AUP (Audacity Project) file, but not the Pencil2D file. The other file is not a pclx file, it’s actually a text edit file with some dialogue.

Please look carefully and send the pencil2d file.

Oh hmmm ok, give me a second.

OMG I found my mistake, o my gosh I’m so dumb!!. The problem was me, I was trying to open the wrong file, the real one actually works very good XD

Oh my lord I feel sappy right now haha

@Mimikyu007_OwO I’m glad that you can use the file now. Make sure to create an extra copy in case the file does get corrupted by an unforeseen problem. One can never be too careful :v:

1 Like

Okay, thank you! :slight_smile:

Imprint