My drawings (in Pencil2D)

Image created with Pencil2D

What I found after working with Pencil2D:

When zooming-out three times the size of the initial canvas, for instance, the Grid boundaries appears on the middle of the canvas. I thought of the possibility of having an on/off button for the Grid. By the way, this boundaries of the Grid does not represent the real Size of the Camera (final render). Not sure if someone has also noticed this but it would be a good idea to have the size of the Grid matching the size of the camera. That will allow the artist to have everything inside it when rendering an image/animation.

When starting Pencil2D it allows me to use right there the keyshortcut LMB+drag for moving all the layers´s content (while the HANDTool icon is selected as a cursor). But right after drawing some lines or just taping at the canvas, this shortcut “LMB+drag” stops working.

I experienced a bad behaviour of the MoveTool. Maybe because I have zoom-out the canvas, not sure. Well, when trying to reduce the image size (which is outside of the boundaries of the Grid) by selecting it first then dragging its corner to a desirable size, it happens that all selected image just disappear. It is Like not able to handle that size. (not always happens this behaviour)

Despite selecting a random Alpha-control value on the ColourWheel-Panel, it always goes to its default value (255) every time another colour is selected. I think that having it “fixed” to a desire value will give a better way of working to the artist. Here another suggestion: To provide to the Alpha-Channel box-value, a slide-control for a fast changing value (like the Pen-Tool slide´s size)

When using the toggled-color-palette (shortcut “C”), in RGB or HSV mode, changing any value on the saturation/hue/value/alpha´s slides, or Red/Green/Blue/Alpha´s slides, will make the shortcut to stop working till you tap on the canvas or in the close/toggle© button.

The PEN-Tool has no Feather feature available. I mean it is greyed out with a value that was lately set-up by the last Feather-BRUSH-Tool value used. If I want a Feather value of zero for instance, while using the Pen-Tool, I have to go to the Brush-tool to change its Feather to zero, and return to the Pen-tool in order to be applied to it.

I will report these ideas.

What a wonderful picture! It’s so colorful! You are real artist!


Becoming An Artist!

this is very nice :slight_smile: are you sure its not made in artrage?


Every pixel from Pencil2D :slight_smile:

Thank you

Wow, put it up on Deviant Art so i can feature it on the group.

Thank you

Nice work @kaiko

Yes,very nice, love the colors and the composition. You can almost feel the waves and the wind. :slight_smile: It’s like it’s a photo of an oil painting.


Thanks @Jose (glad to see you around here) and @Manu (my first idea was to make it looks like watercolour, but it ended up more like oil)

Glad that you liked it.
I will make another one, a different one.

Beautiful seascape in any medium. Thanks for posting. Your report on the problems with the software was a little discouraging, though.

Hi @exile

Yes, you are right. The report is discouraging but I think some of the “issues” reported there are already fixed, or minimized.
… That is why I am waiting so eagerly for the new release/build :slight_smile: before I start the new “paint”

Thank you for your words

It might just be me - I haven’t been able to warm up to this program yet. I’m used to doing cut-out animation with automatic in-betweens, Pencil users are heroic with the frame-by-frame drawing approach. I wasn’t even able to efficiently copy and move parts of drawings - Alt + LMB worked sometimes and sometimes it didn’t. Drawing is hard enough without having to struggle with the software. But I admire those of you who achieve fantastic results.

I’m curious what are people using to draw with Pencil2d. I have a cheap “and I mean cheap” bamboo tablet and pen that came with it (product of 2010) and I got what I paid for.

The issue is that I can use the touch pad on my macbook with more precision than the tablet and pen.

Just curious.


By the way, a very nice piece of work.


About your question, I used a Pen-tablet called TRUST, but it got damaged few weeks ago so I am waiting for a new one from another company.
It worked very nicely, precision and pressure sensitive were good. But it gave me a LOT of work doing the image above, but this was related to some issues presented on Pencil3D.

I think that when you say “and I mean cheap” is the main reason for your tablet lack the precision you were looking for.
Having 512 of pressure sensitivity is also one thing to consider when working with a graphic tablet. This is really a cheap one :slight_smile:

Try if you can get new drivers for your tablet.

Thank you for your comment

"Alt + LMB" is buggy at the moment. That is why it behaves like that.
I think @chchwy is working on this issue one right now.

Just be patient while the new build is being developed. And in order for you to improve the “frame-by-frame” approach, have a look to the “Animator´s Survival Kit” or similar. You will get new ideas for you to work with.

Thanks for the response. Will check it out…