My audio isn't working D:<

my audio isn’t exporting. When I click import, the audio doesn’t play and it looks like one frame. I have converted my files to .MP3 and to .WAV several times but it isn’t working.

@Peril-Pumpkin Hi. sorry to hear about your issues. This issue is quite odd indeed. Can you let us know a few things first?

  1. What is your current Operating System e.g Windows 10, macOSX Catalina, etc
  2. What is the Pencil2D version that appears in the Help > About menu?
  3. You mentioned that you converted the file to WAV. What program did you use to convert it?
  4. Is it possible that you can share both the MP3 and the WAV file for the sounds so developers can test them?

Overall, from the initial info it’s possible that the sound files have a rare form of encoding that is simply not compatible with the underlying plugin that Pencil2D uses due to licensing patents (Pencil2D licenses are open, but that doesn’t mean it can open every copyrighted codec out there; most programs pay for those rights)

There is another possibility which is that your computer doesn’t have the proper codecs to read MP4 files created with these tools, but that is an even more rare occurrence, however I mention it as installing a video player like VLC (Videolan.org) might solve this.

If and when you can share the sound file(s), I’ll take a look at it and try to review if there is a way we can help you import it and have it working. But after that if the file still doesn’t work for you, my honest recommendation is to export an image sequence with your animation, or a video even, without sound and then use a free video editor to import the video footage and finalize the movie with audio in the video editor instead.

Most modern editors are very good at handling audio from different sources and would surely allow you to export your final movie without sound problems.

Here’s a list of free video editors you can try out, there are plenty of YT tutorials for all of them.
Free / Open-Source Video Editors
Open-Source

Free

nevermind! I got it, the audio just wasn’t working for WAV(I hadn’t tried converting it into MP3 with Audacity, the program I am currently using)

@Peril-Pumpkin Thank you for taking the time to provide us with the info. It is weird however that WAV didn’t work and MP3 did, considering WAV always work and it’s recommended for better syncing.

I’m still inclined to ask if you can share the audio (you can use either wetransfer.com anonymous link option or google drive) to test the WAV but I’m glad to hear that it has worked for you after re-converting it to MP3 using Audacity.

Usually the WAV not working could also be due to an incompatibility problem with the audio sampling quality for the system (e.g 22100, 48000, 96000, etc) versus the one from the file. This can usually be inspected in the sound system settings.

To access it you can right click on the “speaker” tray icon image on the bottom right area of your task bar.
image

In the sound settings, go to the right bar
image

Press “Sound control panel”
image

And you’ll get this new window (your devices will be different)
image

Select the currently active device (denoted by the green checks), then go to properties and click on the advancedtab
image

There you’ll notice a setting that shows the sampling mode quality. Ideally the sounds you reproduce have to be equal or less that the current setting (48000 hz by default, and 16 bit dual channel)

Changing it will not make sound necessarily better, though some professional applications (like davinci resolve) do require a 96k hz setting. But in general do shouldn’t need to change this.

With Audacity then you can inspect the hz and the bits for WAV files. And when you export WAV’s you’ve got to make sure it’s on the PCM 16bit

More info on this page: https://manual.audacityteam.org/man/other_uncompressed_files_export_options.html

wetransfer.com requires an email to access(and I don’t know your business email), although I can see now that the audio is quite off with MP3 after using it

@Peril-Pumpkin They have an anonymous link option:

Have a look at this quick guide and take notice of their GIF that shows how to change from email to anon link options :slight_smile:

Thank you for taking the time to reply as well :blush:

Imprint