Move Tool Not Working

Example: I draw a circle in Vector. I click on the Move Tool. I click on the circle, but nothing happens. I cannot select the circle. Nothing happens when I left click on or near it. I’ve tried clearing, redrawing something, etc. I’ve exited the program and gone back in. I have the latest version. The move tool just doesn’t do anything. I watched someone in a tutorial video do it (only in the Vector layer), so I assume it’s supposed to work. I’m using Windows 10, 64-bit. Computer works fine. Everything else works fine, as far as I know. Super weird. Any guidance would be appreciated! Thanks! - M

I have verified it does work in the latest nightly build. Maybe try it with that.

Thank you so much for the response! I did try downloading the nightly build just now, and it still doesn’t work for me. I draw a circle in vector, the move tool doesn’t do anything. But - I appreciate the input! Thanks! - Mark

Sorry for your issue. I am on linux so it might just be related to the Windows build. Hopefully the devs can find a solution for you.

Got it. Thanks again!!

I think I just found a solution. I tried it again and I was not able to move either. I just drew another object and that then I was able to move them. You might have to draw 1 or 2 more objects. Its definitely a strange bug. I think most people are using bitmap layers so they haven’t encountered it.

That didn’t work, either. But I do appreciate you investigating it! When I see a tutorial where someone does something, and then I CAN’T do it, it makes me think something is wrong, or I’m not understanding something. As long as that isn’t the case, I’m fine with it. It does sound like a glitch of some kind. For me, I’m still in the learning phase. I’ve been messing around with this for a few years on and off - just needed a refresher. But I’ll just continue without it. Thanks again! - M

It should be possible to select strokes drawn on a vector layer with the move tool, and I don’t have any ideas why that might not be working for you. As a workaround you can try using the select tool, which should select all objects under the rectangular region created by clicking and dragging.

In generally, we do not recommend people use the vector layer. It can be quite buggy and difficult for users to understand. You will also find little-to-no improvement in this situation on the nightly builds as none of our developers are currently working on improving the vector layer.

Good to know - thank you!

Hey - on a separate note, curious to get an opinion on something. How do you handle getting a fairly long background that you want to give movement to? For example - if you had a character walking on a road for a fairly long time - several minutes, say - do you create a bunch of shorter background images and just add them as new frames when you run out of room on the previous image?

I don’t think there’s any obviously wrong way to approach that. In general you should try to use a project for short segments of your animation (usually it’s most natural to break them up by shot, but if you have a long take it may make sense to break it up further). This is a good idea to reduce the amount of work you risk losing if that particular project is lost, corrupted, etc. (backups are also essential!). With shorter projects, I would personally try to keep the background as one large image because that will make it easier to use the camera layer to quickly modify the panning speed of the whole animation

However, if the background loops, I probably would probably loop the camera motion instead copying the image many times, but neither option is ideal. There’s really no good way to handle looping in Pencil2D right now.

1 Like