Linux Installation Help

I’m trying to install Pencil2D on a chromebook with Linux, but every time I try to install I get this:

error: GDBus.Error:org.freedesktop.DBus.Error.AccessDenied: Flatpak system operation Deploy not allowed for user

Please Help!

@joey_321123 Hey thanks for reporting. I’m not well verse in chromebooks, but the error seems to hint that you don’t have the necessary permissions to install software on your chromebook, which is a common issue with Linux OS, when installing stuff that’s not on their “app store”

By any chance are you the admin of your computer? or is it a Family computer? If someone else has a password you have to ask them for it and then use the sudo command when using the Flatpack method via the Terminal window

So like instead of this:

Without administrator permissions

Install

flatpak install flathub org.pencil2d.Pencil2D

Run

flatpak run org.pencil2d.Pencil2D

With administrator permissions

Install

sudo flatpak install flathub org.pencil2d.Pencil2D
Enter Password:

Run

sudo flatpak run org.pencil2d.Pencil2D
Enter Password:

If you do have the permissions setup and are an admin, yet this is still not working it may be a problem with your Linux distro.

Which one are you using btw? Maybe we can find some hint to resolve the problem by learning what linux version you have.

If it’s Ubuntu or Debian they should work pretty much out of the box (but you still need to use the sudo command to install external stuff, not only Pencil2D but basically most apps out there) :thinking:

I worked great man thanks a bunch!

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.

Imprint