Lines Disappearing

Hey everyone. I’m new here so sorry if I’m not putting this in the right place. Anyway, I looked around a little and even though I found some similar questions I didn’t find any solutions that worked for me, so here goes:

I’m using a mac with a wacom intuos tablet and I downloaded the latest version of Pencil. But when I try to draw in the program, my lines disappear instantly. When I go to the next layer I can see what I’ve drawn on the previous layer, but when I go back it disappears. I have the same problem regardless if I’m using my tablet or not.

I’ve tried shutting down and reopening the program, reinstalling, checking and unchecking the invisible box, etc. but nothing seems to be working. If anyone has had a similar issue and found a fix, I’d really appreciate any help you could give me!

Thanks :slight_smile:


There is a known issue with the polyline in bitmap mode which sort of describes the issue you’re describing but I’m not sure that’s what your experiencing
Which layer(bitmap or polyline) where you drawing on and which tool where you using?

If you start the application fresh is this bug occurring? If you can get it to consistently occur directly after startup, a short video showing exactly what you’re doing would probably be the quickest way to getting this fixed for you.



Thanks so much for your reply! Sorry for taking so long to respond.

I seem to have the same problem no matter what drawing tool I use. Oddly enough the eraser tool doesn’t seem to do anything at all, but I’m not sure if that’s a related issue or if I’m misunderstanding something in how it’s supposed to work.

I’m drawing on a bitmap layer but I’m not sure how to describe all the technical details so like you suggested I tried taking a screen recording to better show what’s going on. This issue is always the same even if I restart the program.

I’ve never taken a screen recording before and it’s not the best quality, but I hope this is helpful. I’d really appreciate any advice you have for how to fix this issue if you have the time.

Thanks again!

EDIT: Aaaand I forgot to link the video. Here it is:

@blukat You have a really old version, which was released almost 6 years ago if, and due to Apple upgrading their stuff, I believe it’s because older Qt libraries don’t hold up well to this day with their software updates.

I’ll suggest leaving that version intact (don’t uninstall just yet) for doing other tasks and meanwhile please take a look at the newer, but developmental, versions here:

Once you download the most updated version for MAC, you’ll notice several differences. Of course these are not stable updates, but rather snapshots of how the progress is coming along. Some stuff has been removed. Some has been updated. But all in all is a whole different beast.

MAC versions are the hardest to fix mainly because there are but a handful of devs that have MACs to test and fix related issues, so all we can ask is for patience and endurance.

I believe you don’t have to install these Nightly Builds on MAC, it’s just a zip file with all the necessary files to run a “portable” version of pencil2D for said version. Hopefully most of your problems will be fixed, although many more will become apparent.